Answered

"Unable to connect to Sonos" whenever I leave wifi


Badge

So this is a continuation from another issue that got resolved last week by disabling “Private address” but now whenever I leave home [and the wifi network] when I return home and auto connect to my home wifi I get “unable to connect to Sonos. Learn More” again. See below

 

I have a Sonos Connect Amp that is connected wirelessly to our BT router in the next room [no bridges/extenders]. The router isn't new, been moved or any passwords changed; likewise for the amp.

 

To play music I use an iPad fixed in one location [this iPad connects fine to the amp and can play music using the S1 app]. However, my iPhone X [running latest software] using S1 app has just suddenly, for no apparent reason, started saying “unable to connect to Sonos. Learn More”. I have tried my work iPhone as well in case it was just my personal mobile acting out but that won't connect either and I get the same message.

I have tried:

  1. Resyncing the phone by pressing the mute and + button on the amp. Going to the app and connect to existing system. I then get a popup on the app saying “connected to Sonos system. This Sonos app is now connected to your Sonos system”. However, when I click done it takes me straight to the screen asking me to setup a new Sonos system or connected to an existing system”… I then go round in circles.
  2. Unplugging the amp and connecting it directly to the router via ethernet cable and doing that whole process… but no joy!
  3. Resetting the app
  4. Uninstalling the app
  5. Turning the router off, unplugging the amp, turning the router back on and then wait and then plug the amp back in.
  6. Turning phone off and on.
  7. Checked I am running latest app version.
  8. Disabled “Private address”
  9. All privacy settings fine

I think I have about exhausted everything so if anyone has any suggestions please let me know.

Many thanks

icon

Best answer by Xander P 14 April 2021, 16:29

Hi @ikigai, thanks for raising this with the community!

We’ve seen a small uptick recently in issues with BT SmartHub 2 routers, where it seems that they aren’t passing data between the 2.4 and 5GHz wireless bands.

Currently it looks like the workaround is to disable the 5GHz wireless from your router settings, however I’d also encourage you to reach out to BT regarding this, and let them know that devices connected to your 5GHz WiFi are not able to communicate with devices on the 2.4GHz - it seems that some kind of wireless isolation may have been implemented between bands.

View original

16 replies

Have you checked the relevant permissions? (Although I wouldn't expect it to work at all if it lacked a permission)

https://support.sonos.com/s/article/3092?language=en_US

Badge

Have you checked the relevant permissions? (Although I wouldn't expect it to work at all if it lacked a permission)

https://support.sonos.com/s/article/3092?language=en_US

Thank you but yes tried that as well… it’s almost like it’s a bug with the app update or iOS!? Everything else is a ‘constant’

App updates get blamed on here for just about everything short of the Covid pandemic. It never is the app update.

ikigai,

Maybe try resetting the iOS ‘network Settings’ on the iphone ("settings/general/reset") and after the usual reboot, ensure it connects to the same network that is in use by the working iPad (with private address switched off). See if that fixes it. Also ensure any security software/antivirus/vpn/firewall etc. is switched off, if any is installed on the phone.

What was the thinking behind pressing the mute and + buttons? What do you mean by 'resynching the phone'?

Badge

ikigai,

Maybe try resetting the iOS ‘network Settings’ on the iphone ("settings/general/reset") and after the usual reboot, ensure it connects to the same network that is in use by the working iPad (with private address switched off). See if that fixes it. Also ensure any security software/antivirus/vpn/firewall etc. is switched off, if any is installed on the phone.

Thanks but no joy unfortunately 

Badge

What was the thinking behind pressing the mute and + buttons? What do you mean by 'resynching the phone'?

So… when I went through Sonos troubleshooting it was something it suggested to try but had no luck at all

ikigai,

Maybe try resetting the iOS ‘network Settings’ on the iphone ("settings/general/reset") and after the usual reboot, ensure it connects to the same network that is in use by the working iPad (with private address switched off). See if that fixes it. Also ensure any security software/antivirus/vpn/firewall etc. is switched off, if any is installed on the phone.

Thanks but no joy unfortunately 

Does the router have "Airtime Fairness” or “QOS” enabled? If so, disable that feature.
Are you sure that there’s no other DHCP server on the Network?
Are you able to ‘ping’ the Sonos device from the phone? 
 

Have you tried completely uninstalling/reinstalling the S1 Sonos App from the App Store and reconnecting to the ‘existing’ Sonos System?

Badge

App updates get blamed on here for just about everything short of the Covid pandemic. It never is the app update.

That’s good to know thanks! It’s just very strange and literally nothing has changed at all other than updating the app around about the same time it stopped connecting. If I turn the router off and on again I can connect again via S1 iOS app but then as soon as I leave the wifi I can't get it back...

Userlevel 7
Badge +21

BT Routers. They just keep on giving, huh. Can you switch toa proper router instead?

Badge

BT Routers. They just keep on giving, huh. Can you switch toa proper router instead?

I know tell me about it. TBH I wouldn't know where to start. The BT has worked fine for round the house, smart TVs etc… until now!

Userlevel 5
Badge +14

Hi @ikigai, thanks for raising this with the community!

We’ve seen a small uptick recently in issues with BT SmartHub 2 routers, where it seems that they aren’t passing data between the 2.4 and 5GHz wireless bands.

Currently it looks like the workaround is to disable the 5GHz wireless from your router settings, however I’d also encourage you to reach out to BT regarding this, and let them know that devices connected to your 5GHz WiFi are not able to communicate with devices on the 2.4GHz - it seems that some kind of wireless isolation may have been implemented between bands.

Badge

Hi @ikigai, thanks for raising this with the community!

We’ve seen a small uptick recently in issues with BT SmartHub 2 routers, where it seems that they aren’t passing data between the 2.4 and 5GHz wireless bands.

Currently it looks like the workaround is to disable the 5GHz wireless from your router settings, however I’d also encourage you to reach out to BT regarding this, and let them know that devices connected to your 5GHz WiFi are not able to communicate with devices on the 2.4GHz - it seems that some kind of wireless isolation may have been implemented between bands.

 

Hi there - thank you for the suggestion. I spoke with BT and they have done just that, followed by a reset of the router, but unfortunately the issue persists. Is there anything else you can suggest?

 

Thanks

Hi @ikigai, thanks for raising this with the community!

We’ve seen a small uptick recently in issues with BT SmartHub 2 routers, where it seems that they aren’t passing data between the 2.4 and 5GHz wireless bands.

Currently it looks like the workaround is to disable the 5GHz wireless from your router settings, however I’d also encourage you to reach out to BT regarding this, and let them know that devices connected to your 5GHz WiFi are not able to communicate with devices on the 2.4GHz - it seems that some kind of wireless isolation may have been implemented between bands.

 

Hi there - thank you for the suggestion. I spoke with BT and they have done just that, followed by a reset of the router, but unfortunately the issue persists. Is there anything else you can suggest?

 

Thanks

If the router was factory reset that would simply enable the 5ghz band again - did you perhaps try switching that band off again (as suggested), just to see if it does resolve the matter?

I had same/similar problem to what you describe. I switched off my 5Ghz channel on BT Router - and fixed problem (so far!).

Badge

Hi @ikigai, thanks for raising this with the community!

We’ve seen a small uptick recently in issues with BT SmartHub 2 routers, where it seems that they aren’t passing data between the 2.4 and 5GHz wireless bands.

Currently it looks like the workaround is to disable the 5GHz wireless from your router settings, however I’d also encourage you to reach out to BT regarding this, and let them know that devices connected to your 5GHz WiFi are not able to communicate with devices on the 2.4GHz - it seems that some kind of wireless isolation may have been implemented between bands.

 

Many thanks for this! This has been a stable solution and back working all the time.

Reply