Answered

Unable to connect to Sonos after new router

  • 2 December 2019
  • 16 replies
  • 1439 views

Userlevel 1
Badge +2

I have a Sonos system with all speakers connected wirelessly.
I have changed my router. Same provider, just new router, new network name and new password.
Disconnected and powered down all my Sonos speakers.

Wired up a Play 1 to the new router by ethernet and it works.

Switched on my other 5 speakers and they all work wirelessly.
HOWEVER, when I unplug the Play 1 from the router, nothing works.

Using the sonos app, I go into System, Network, Networks, - it states my network is in use. Go to Wireless setup, it takes me through setting up a new network, and after entering in the details (three times) it says “verifying network name and password” then says to check the name and password. I tried to do the “alternative setup” but that tells me to permanently connect a sonos speaker.

icon

Best answer by John B 2 December 2019, 19:06

Yes you are, I think.  Although I don’t think you will have to add each device to a band in practice.

I suspect Sonos will automatically connect to 2.4 because it cannot connect to 5.  But the bands have different names now

You must choose the b/g/n setting.

View original

16 replies

Here is the relevant support article

https://support.sonos.com/s/article/1061?language=en_US

Userlevel 1
Badge +2

John B - Thanks for your reply but I’ve read https://support.sonos.com/s/article/1061?language=en_US, but it doesn't tell me anything I don't know.

It doesn’t say when to unplug the wired speaker.

It doesn't address the issue of Sonos not accepting my new network name and password

What’s the make and model of your new router?  Are you attempting to connect to a 5GHz network or 2.4GHz?  Sonos needs to connect to 2.4 GHz.  Also are you using any access points or wireless extenders with your new setup?

Can you try and get back to one speaker wired. rest connecting wirelessly.  Check in About My System that all speakers have WM:0 next to them, none has WM:1 (give it a bit of time and if necesary power cycle the wireless speakers).  If so, then go into into the Network Settings, Wireless Setup and see if it will let you delete (reset) the old wifi details and enter the new ones.

If that is successful it should tell you you can remove the wired connection.

Please post back whether that works or not.

Userlevel 1
Badge +2

meelvimbe - It is a BTHub6. I don't know if I’m attempting to connect to 5 GHz or 2.4 GHz. How do I find out? No setting in Sonos app to give me a choice.
Not using any access points or extenders. I am using a NAS to store my music.

John B - I am back to one wired speaker + rest connecting wirelessly.
All speakers have WM:0
When I go into Network Settings, Wireless Setup, I get “Set up Sonos on your WiFi” Lets get Sonos running. Press Continue. Choose a network. I see my new network (BT Hub6 xx) and select that “Use this network”. Asks for password to the router, “Please wait” and does not accept it.

Maybe it is the 2.4 / 5GHz setting as suggested by melvimbe

(I have connected all our phones, iPads etc to new network - I can type a password!)

Userlevel 1
Badge +2

OK -got into my router settings. 

4 ports - one is wired to my Play1, and the Hub tells me there are 5 Sonos devices connected to it.

This makes sense, except I have 6 speakers (are the 2 stereo linked Play 3s counted as one?).

I don't have any Sonos speakers connected wirelessly, so the 2.4 / 5 GHz is irrelevant at this stage??

I don’t have much experience here…...:grinning:

Do you know how to log in as an administrator to your router?  I think for a Hub6 you need to type the following into a browser:

192.168.1.254

Then enter your admin name and password, which are printed on the router label.

I cannot remember if there is a setting to have separate network names for the 2.4 and 5 GHz networks but it would be better to have those different.

On the 2.4 GHz network there will be a setting for which WiFi protocols are enabled.  You need ‘b/g/n’ not just ‘n’.

Hope that helps!

Our posts crossed.  The wireless speakers are connected wirelessly over SonosNet to the wired speaker.  The router will perceive them as wired.  So yes the router wifi is irrelevant in this config

Userlevel 1
Badge +2

I can get into router settings.

It has an option to separate the bands (2.4 and 5). I guess I do that and then try again?

Will Sonos automatically connect to the 2.4 band?

It also means me manually adding each device (phone etc) and to assign a band.

Am I on the right lines here?

Yes you are, I think.  Although I don’t think you will have to add each device to a band in practice.

I suspect Sonos will automatically connect to 2.4 because it cannot connect to 5.  But the bands have different names now

You must choose the b/g/n setting.

On the Hub 6 the b/g/n thing is dealt with by ‘wireless mode’ in Advanced Settings.  Try setting it to mode 2.

Userlevel 1
Badge +2

Many thanks. I have to go out, and won't have time tomorrow to do this.

I’ll post when I have tried. I’d like to read up on bands on the BT Hub first to make sure I don't mess it all up!

Cant thank you enough.

Neil

No worries, please post back whatever happens.  I would try the wireless mode thing first before you start separating the network names.

Two further thoughts. 

  1. If you can find a setting for ‘band steering’ turn it off.  This might only appear if you split the bands (not sure about that)
  2. With the number of speakers you have I’d probably recommend operating with one wired Sonos device (i.e. using SonosNet) anyway!  But worth trying on WiFi if wiring isn’t convenient.  I am sure we can get WiFi working!

Found the following thread:

https://en.community.sonos.com/setting-up-sonos-228990/the-all-new-bt-smart-hub-hh-6-issues-6738089

Userlevel 1
Badge +2

Hi John B.

After a couple of months of “stuff” I finally got around to wiring up my speakers properly using SonosNet. Everything all good now  - except that I might be buying more speakers! Many thanks for your help, Neil

Reply