Question

Unable to connect to Sonos — ABSOLUTELY crazy-making

  • 3 August 2020
  • 1 reply
  • 59 views

I recently updated to the S2 controller and I’m absolutely at my wits end. No matter what troubleshooting actions I take, the controller will not stay connected to my system. It disappears from the app constantly, seemingly without cause.

I’ve tried every solution: re-starting my router, factoy resetting all of my devices, setting them back up again one by one, unlinking them from Google Assistant, doing the silly thing where you connect one of the devices to the router with an Ethernet cable, re-booting every device (even the non-Sonos devices) that connect to my WiFi and have their own IP addresses, and NONE OF IT HAS WORKED. I’ve even tried BrianSel’s trick from about a month ago, and that didn’t take. What is this bug, why is it so persistent, and has anyone been able to figure out a real solution for it?

 


1 reply

Userlevel 5
Badge +16

Hi @sbgr253.

Welcome to the Sonos community and thanks for reaching out to us.

I would recommend temporarily connecting your Sonos device to the router via ethernet cable and then check if it appears on the Sonos app.

I would suggest connecting the ethernet cable first before connecting the Sonos device to power. If it appears on the Sonos app, try to submit a diagnostic. Please take note of the confirmation number and indicate once you reply to this topic.

Please let me know once everything is good with the diagnostic. We are always here to help.

Thanks,

Reply