Unable to connect to Plex server when trying to play music

  • 13 December 2017
  • 7 replies
  • 2321 views

I purchased the Sonos device as it said it had the capabilities to connect to Plex. I have set up my router to do a port forward. I have set up Plex to manually specify public this port and connect remote works. I am able to play music from other devices (several Roku devices) connected within the same network as my Plex server. When I try to get my Sonos to play through Alexa, it will not play the music. So, I tried to use my iPhone to play the music on my Sonos using the Sonos app. I can see the Plex server and I can see all my music, but when I try to play a song, I receive an error saying 'Unable to play 'song requested' - unable to connect to Plex. Has there been any resolution to this problem yet?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

I have spoke to Sonos support and what they are telling me is the same as what someone else has responded on another thread. I have pasted what this person (Mike V) said below and will continue to update this thread as I continue to find a work around for this solution. I plan to contact Plex and my ISP to see what they tell me. My current alternate solution will be to host my Plex Server on my NAS on another Network. So, I will have 2 Networks in my home. Not ideal, but I believe it will work. Will keep posting with findings.

From Mike V:
Depending on the capabilities of your router, you may need to enable an advanced NAT setting to allow Sonos to connect to your Plex server... at least for the time being. The issue is known, but Plex seems to have abandoned all Sonos development at the moment (there has been 0 activity in Plex's own Sonos forum by any Plex employees for over a month).

The option is often called Hairpin NAT or NAT Reflection. Also, some have found that just manually setting up the port forward in the router instead of using UPnP to create it automatically can solve the problem.

The issue is that Plex is telling Sonos to connect to your server through your router's WAN IP address. But many routers won't make a connection for an internal host trying to connect to another internal host using the router's WAN IP address. When it works, the traffic isn't actually going to the internet and back, it's just going to the router and being turned back around. The better fix to this issue would be for Plex to come up with a way to determine if the Sonos device is on the same network as the Plex server and provide the server's internal IP address instead of the WAN address.
This advice doesn't make sense. I have many, many other devices including: LG, Samsung, Vizio and Panasonic SmartTVs, (3) diff model Rokus, an older ChromeCast, literally dozens of combined iOS and Android SmartPhones and tablets as well as (11) Windows-based PCs connected to the internal network. There's probably some other devices I'm forgetting to mention, but regardless, every one of these devices connect up to my Plex Server just fine both internally and externally where applicable (i.e. laptop, phones, tablets) through their respective app/interface... except the Sonos - a Play:1 in this case purchased based on the marketed claim of working with Plex. And I mean on BOTH sides! No finger pointing here, there's plenty of touting going on re: interoperability. How does this even pass QA?? Hairpinning shouldn't even be an issue here! A simple ac WiFi router (10.1.0.1) downstream from provider router, a Plex Server (10.1.0.10) and a Play:1 (10.1.0.100). All devices on the same 10.1.0.0/24 1Gb network, shouldn't they all just communicate directly?? Again makes no sense. Put the collective powers-to-be to work and come up with a fix that supports your marketing claims.
..
And by the way, not to mention Sonos provides no mechanism for selecting the Plex user, as just about every other device will do.
C-sunnedTech, I agree with what you are saying. All of my other devices interface with my Plex Media Server just fine. Although, when I spoke to Sonos support, they do not see this as a problem with them. Very poor support if you ask me. Especially since I am a software engineer/achitect and have been for the past 27 years. Advertising something that does not work is not something I would suggest. My work around is just to get by until they actually fix the problem. I know it is a pain, but do not have plans to get rid of my Sonos for now unless I cannot get it to work at all with my Plex Media Server.
My Sonos sees all my music on my Plex, when I try to play it doesn’t play anything, cycles through the album, but won’t play a single track. Frustrating, it obviously sees my server.
Userlevel 2
Badge
Plex was working (slowly), and now I discovered I can no longer connect. I keep up with both Plex and Sonos updates. I removed the service and tried to add it again. Oddly it doesn't show as an available service on my Mac Sonos client, but I could add it with my iPhone app. I appears again, and I can see my library, but it just cycles through each song, saying "Unable to play 'song name' - unable to connect to Plex." This is so frustrating because it worked earlier. I also ensured Plex is available remotely. I thought I saw recent marketing that Plex and Sonos were going to start playing together more nicely.

For a while they fixed that issue where the start of the song would be clipped, so I was optimistic. Now I can't even play a song.
Userlevel 7
Badge +21
Plex made updates to their "app" for Sonos earlier this week. It's now able to connect directly to your local Plex server address rather than your router's WAN Address when playing music... however, some routers don't handle this right because of a setting called DNS rebinding. Typically branded as a security feature (thoughts are mixed on whether it really is or not), it prevents outside DNS lookups from returning private network IP addresses... which is unfortunately something needed in this case.

If you can't disable DNS Rebinding on your router (either globally or just for the plex.direct domain), changing your Plex server setting to prefer secure connections rather than require them might clear this up.

More info can be found in this Plex support forum topic: Sonos v2.0.5 update doesn't work
...and in this Plex support article: Secure connections - Why doesn't it work - DNS Rebinding