Answered

Unable to connect to apple music after playing first 20 seconds of any song (used to work fine)

  • 6 February 2019
  • 2 replies
  • 282 views

This is my second attempt to get support here. Can someone please help me? (Is there another place I should be going for product support?) Here is my diagnostics report number: 45429983 .

My system (2 speakers) spontaneously stopped working 2 months ago after working great for 3 months. I can no longer add songs to the queue from Apple Music. Here are the steps I have tried:

1. Disconnected from Apple Music and reconnect.
2. Moved one Sonos unit to be 2 feet away from wifi router. Powered off other Sonos unit.
3. Disconnected all devices and powered down. Disconnected wifi routers and powered down. Disconnected modem and powered down. Powered up and reconnected in reverse order.

None of these actions resulted in any change whatsoever. The symptoms remain exactly the same. If I try to play anything it will play the first 20 seconds and then say that it cannot connect to Apple Music. It will then error out on every single song on the playlist. If I try to play anything else, it will say "unable to add to to queue", and provide absolutely no additional information.

My network is very healthy. 4 computers, 4 ipads, 2 TVs all work all the time, flawlessly, streaming HD video. Amazon Echo, sitting right next to the Sonos One, is able to play Apple Music all day without any issue.

Please help. Thank you.

Dustin
icon

Best answer by Keith N 6 February 2019, 20:30

Hi there, dwcarr05. Thanks for the post and for sharing your diagnostic report number. I'm seeing a number of connectivity errors saying it is unable to connect to the Apple Music server. Is it possible to test this with the Play:1 plugged into the router? By giving it a dedicated connection we can determine if the problem is the wireless communication between Sonos and the network.

Alternatively, if you are looking for a more real-time form of support, I would recommend getting in direct contact with our support team. The Community is a great resource for setup, tips and general discussion with other Sonos users. The Sonos Staff on the Community (like myself) can take a look at diagnostics and may be able to give insight to a problem, however, we may not be able to solve every problem and you may need to reach out to the team to go further.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +19
Hi there, dwcarr05. Thanks for the post and for sharing your diagnostic report number. I'm seeing a number of connectivity errors saying it is unable to connect to the Apple Music server. Is it possible to test this with the Play:1 plugged into the router? By giving it a dedicated connection we can determine if the problem is the wireless communication between Sonos and the network.

Alternatively, if you are looking for a more real-time form of support, I would recommend getting in direct contact with our support team. The Community is a great resource for setup, tips and general discussion with other Sonos users. The Sonos Staff on the Community (like myself) can take a look at diagnostics and may be able to give insight to a problem, however, we may not be able to solve every problem and you may need to reach out to the team to go further.
I’m having the same exact issue. Apple Music played just fine up until a couple months ago. Was there a solution?