Answered

Unable to connect to Apple Music

  • 22 September 2022
  • 4 replies
  • 45 views

Hi, 

I need some help on this one. I can’t connect to Apple Music with my sonos system anymore. I am basically asked to reauthorize again and again Apple Music for Sonos, but never worked. No possibility to play any title and no access to my library. Checking Apple music third-party app with authorization, Sonos S2 does not appear. 

I do the basic process as usual when adding a music service. This worked before. Don’t know where the issue comes from. Any idea ? 

Note: My apple music is a student one. Are you aware about any compatibility restriction with sonos ? 

icon

Best answer by Kayr 22 September 2022, 20:26

View original

4 replies

Userlevel 7

Hi

As a student your eligibility must be vetted by Apple. Also  that eligibility is only good for 4 Years from date of eligibility. If you took a break from school the “Apple” clock continues to move as it applies to your eligibility. Also, have you changed schools?

If none of the above applies to you make sure your form of payment is valid on your device. Update your device to the latest software. Delete and reinstall the Sonos app. Make sure you have good WiFi and internet connection. Finally contact Apple Support about your account to make sure everything is in order.

Badge +17

Hi @Kayr,

 

Are you trying to add the service via an Android device? If so, we’re aware of an issue preventing users from adding Apple Music to Sonos using Android devices. It has been reported internally for further verification, but at this time there is no timescale for a fix.

The only workaround is to add Apple Music via an iOS device. Once added, the service will function normally on all devices.

 

If you’re not using an Android device, please submit a diagnostic after trying to add the service and get in touch with our customer care team for further investigation.

Userlevel 7

@James L. 

So the battle between iOS and Android has expanded to yet another front. LOL. 😂

Yes Android. Thank your input sir. Having no Idevice anymore, seems I have to wait for them to fix this. 

Reply