Unable to connect sonos to drobo Nas drive

  • 16 January 2014
  • 8 replies
  • 398 views

I removed the link to my drobo-fs public folder but am now unable to add it back. When I attempt to do so I get the error "The computer Drobo-FS refused to let Sonos connect to it". I have tried user/pw for Admin as well as a special user that I created for sonos both of which have full read/write access. I can access the public drive from my mac in Finder. I have entered the path as \\Drobo-FS\Public and //Drobo-FS/Public but neither work. Can you assist me with troubleshooting ideas please? Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7
Badge +21
Don't know your NAS, it should be in the NAS user's manual ot their web site though.
Userlevel 7
Badge +26
Hello Pete,

That first format \\Drobo-FS\Public should be the correct path if that Public folder is the one which has your music library in it. For music shares that are having trouble, I'd recommend following the steps described here. I'd also suggest rebooting the NAS drive and your router. You can try replacing the Drobo-FS part with the IP address of the drive to see if it's an issue resolving the name of the drive too.

If you're still having trouble getting that to share, it's be best to reach out to our Customer Care team over the phone line so a technician can assist live.

Cheers.
Hello Pete,

That first format \\Drobo-FS\Public should be the correct path if that Public folder is the one which has your music library in it. For music shares that are having trouble, I'd recommend following the steps described here. I'd also suggest rebooting the NAS drive and your router. You can try replacing the Drobo-FS part with the IP address of the drive to see if it's an issue resolving the name of the drive too.

If you're still having trouble getting that to share, it's be best to reach out to our Customer Care team over the phone line so a technician can assist live.

Cheers.

Thanks very much, Ryan. Rebooting the NAS drive did the trick. I'm back up and running. Cheers.
Does the Drobo5N have to connected to the Router, or can it be connected to the computer via Ethenet Cable?
Userlevel 7
Badge +21
Does the Drobo5N have to connected to the Router, or can it be connected to the computer via Ethenet Cable?
It should be connected to your router. It has to be accessible by the Sonos devices on your network, not just your computer.
I'm having same problem, but rebooting drobo5N NAS device did not work. Any other thoughts? BTW, I'm navigating with the Sonos file picker (for choosing a music library folder) to the shared folder on the drobo device, so resolving the IP address shouldn't be an issue.
This is a 4 year old thread that you've resurrected. I suspect a lot has changed in those 4 years.

One thing you may want to check is to see if your drobo drive has SMBv1 enabled. Sonos is still using that connection method (likely because there's not enough space on older speakers to update it)
How to check to see if SMBv1 is enabled?