Unable to connect sonos move.

  • 1 January 2022
  • 10 replies
  • 103 views

First set up went really well. Yesterday my son connected through Bluetooth but then the Move would not reconnect on the network. After various tries I reset my router and it connected but then the touch controls would not work even if I toggled them on off in the app. So I did a reboot of the sonos move in order to reset everything but now the app cannot find it even though I reinstalled the app and tried two different mobile phones. While trying all the above I noticed in a wifi analyzer app at one stage the move had its own WiFi signal. However after switching the move on off a couple of times this signal has now disappeared from my those my analyzer app can see which I guess is a bad sign. The green light continues to flash of course.

Edit: The WiFi signal on the move came on or restarted when pressing the join button and went to orange light. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 7

Reboot the router again. Then reboot the Move by following these steps:

  1. Take Move off of the charging base.
  2. Hold the power button for at least 5 seconds, or until the status light turns off.
  3. Wait 10 seconds.
  4. Press the power button or place Move back onto its charging base.

Go ahead and reboot your phone too. Then try to set up the Move again in the Sonos app.

Well it does not really reboot anymore cause it has been rebooted and not set up so it goes automatically to the green pairing mode when switched on. The join button resets the wi fi pairing process going from orange to green. What I see is that when I push the join button the move emits a wi fi signal of its own which is seen on a wifi analyzer or on the wifi network list. Then in green mode this signal disapears I guess because the move provisionally connects  on to some near wi fi network. The issue may be that my router has two signals one secured private and one that the telecom company uses for its public network if you are a subscriber to this service. I never had a problem with this so I left it as is. However just in case this was the problem I did take my move to another room with a powerline extender on my network so it would choose the home network but again after rejoining from orange to green it could not be found. So also I tried resetting the main router but again no way to find the move. In my view Sonos has bugged its own product since you have no sure way to connect to it eg ethernet to fix wifi connection issues. Its a catch 22 situation. If the move has wifi connection issues you cannot fix them since you need it to be connected to the wifi that it is not connecting to....

 

 

 

Well after rebooting the router AND resetting the app the move was found. The app then asked to do a sonic pin recognition between move and phone/app which  started with the move emitting some tones. However this did not work for some reason. I tried with a second phone and again it did not work. However then it asks as a fallback to input the 8 numeral pin number on the back of the move. This worked but I had to make sure to include the two hyphens. Finally it went to setting up the wifi network and this was finalized. The app tried to go into update check but it failed. The app seemed to work but when I tried setting up spotify and tunein services it failed again. Update was giving an error message 1101. So I rebooted the router once again and maybe the app (I have done it so many times I forget when) according to recommendations and finally the app updated properly and everything works normally. I must have spent over 3 hrs trying various options and reading the internet.

However the touch controls on the move are not working as I noted before. Despite all the rebooting done. Of course I am making sure they are toggled on from the app. I can toggle the light on off but the three touch controls are unresponsive which is a deal breaker because you will need the app/phone to stop, play,volume, skip etc

@Protos,
Can you perhaps describe your network setup in a little more detail. Is it a central router, or a mesh system? Are there any other WiFi access points and if so, are all broadcasting using the same SSID, on the same WiFi channels, with identical channel-widths?

Is there a ‘main’ non-portable Sonos system, besides the Move device and is that running on your WiFi signal or a SonosNet signal with a device wired to the main router/switch?

Its simple. The main WiFi router in the kitchen where the sonos move is is connected to two power line extenders with different SSID's. The move is the only sonos component I have and it is set up next to the main router . I made sure my phones were on the same router during set up of course. No movements involved yet. As I said the initial set up went fast. Then it all got complicated without me changing anything. Now its working but I have no luck with the touch controls and I see it is not a common problem at all so there us no available solution

I would first ensure the following…

Try to keep a distance between the Move and the router (and/or access points) at least one metre or more.

The access points on the different SSID’s are fine (if you prefer things setup that way) but ensure both AP’s are on different WiFi channels too - so if the router is on channel 6 (as an example) set the access points on 1 and 11 so their signals do not overlap.

The move connected to your router can use the 2.4Ghz or 5Ghz bands - set it to use the 2,4Ghz band for now and in the Sonos App network settings ensure that router bands SSID is the only WiFi network listed - if any others are showing then long press to remove them.

With this chosen type of setup your mobile controller (as you mentioned) must be connected over WiFi to the main router, preferably the same band. There are other ways to setup your WiFi network but let’s keep it simple for now.

Onto the speaker touch controls - having done the WiFi configuration above, goto ‘Settings/System/Network/[Move Room Name]’ and scroll down to ‘touch controls’ and disable and then enable that feature (or simply enable it, if it’s disabled already) then play some music to your speaker and try to use the speaker play/pause/previous/next buttons.

Hope that works for you.

Thanks! The AP s are on different channels. The router is about 2 meters away. The Move is still working from the app. However the touch controls are enabled in the system settings on all phones without result. The app obviously works since I can enable the light or not. But enabling the touch controls does not make them work.

Thanks! The AP s are on different channels. The router is about 2 meters away. The Move is still working from the app. However the touch controls are enabled in the system settings on all phones without result. The app obviously works since I can enable the light or not. But enabling the touch controls does not make them work.

Sounds like a fault then, in that case - perhaps submit a Sonos diagnostic report and make a note of its reference and then get in touch with Sonos Support via this LINK.

Hope you can get it sorted soon.👍

After trying various silly combinations the solution that worked was that I powered up the Move and toggled the status light off. Enabled the touch controls from the app then pressed play on the Move. For some reason this exact  combination unjammed the touch controls.