Question

Unable to connect except on primary network

  • 24 December 2016
  • 6 replies
  • 161 views

Seeking advice for a Connect and network configuration. My configuration is as follows:
network has three wifi radios one on the router and two on exthernet connected access points
- let's call them up, south and north
- all are on the same network, all have the same SSID, all operate on different channels
- the Connect is ethernet attached to south and RCA connected to my stereo
- the stereo is wired to three separate sets of speakers in the house
- I use the Sonos app on an iPhone 6
- when the iPhone is connected via south I can "see" the connect and can direct what music is played
- when the iPhone is connected to the network via up or north the Connect is not longer found
- this means the speakers in the vicinity of up and north are no good to me as I cannot use the network to select what is played-

Suggestions and advice welcomed.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

More than likely your access points are configured as routers with DHCP turned on, so your network is divided into 3 subnets. Among the other problems this can cause, Sonos uses UPnP, which requires all devices on the same subnet. You should configure your routers as access points with DHCP disabled and you should be fine.
Thank you jgatie.

The two access points do NOT have DHCP server enabled. The router, which serves as my gateway does. The access points also have a different range of client IPs just to sure (i.e. 192.168.80 versus 192.168.1). In both cases the client table display capability is disabled by the software on the AP. All clients are visible in the client table on the router.

Could there still be different subnets?

Other data points:
- the APs are wired to the router
- the router is wired to the cable modem
- the APs both point to the router as the gateway
- both AP have static IPs

Thanks again for the advice.
Easy way to test for different subnets is to check the IP on your mobile device as it migrates from router to access point. If it changes, there is another DHCP server in the mix somewhere.
The access points also have a different range of client IPs just to sure (i.e. 192.168.80 versus 192.168.1).
...
Could there still be different subnets?

Yes!!! The network prefixes (the first 3 numbers) are different!

You have a network broken into multiple subnets.
The access points also have a different range of client IPs just to sure (i.e. 192.168.80 versus 192.168.1).
...
Could there still be different subnets?

Yes!!! The network prefixes (the first 3 numbers) are different!

You have a network broken into multiple subnets.


Good catch. I missed that one.
jgatie, the iPhone IP address did not change when I went from AP to AP to router.

ratty, the range of client IPs that could be assigned was changed to validate that they were not being assigned. See below list of clients of the router's DHCP server. All have the same first three in the subnet mask.