Unable to add shared folder to your Music Library (1002) on MacBook Air

  • 5 December 2018
  • 10 replies
  • 694 views

I cannot add library and keep getting this error message. Have tried many solutions posted in forums. Have tried one agent at call centre (cut off) and another one that promised to email instructions that have not appeared. Is there a list of instructions to get rid of this issue?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Have you checked the error codes FAQ?

Have you tried unpowering and repowering (effectively rebooting) the speaker(s)? I'm wondering if there's an issue within the speaker itself that's causing the operation to fail. The controller is really just a remote control, which gives you access to the computer running on the speaker(s).

The thing I find interesting in that link is that they mention it as an issue with updating the firmware/software on the speaker, rather than an error when changing/updating your music library, so I'm unsure of how much help I'm being. When you go to the "about my Sonos system", does the firmware/software on the speaker match the software number on the controller?

Where is the controller that you're using to do this operation? What OS is on the device that you have the controller on?
Thanks.
Yes I have powered on and off the speakers and other devices.
I am not sure where to look to see if the software numbers are the same. Can you give more specific directions?
The controller is on a MacBook Air OS 10.13.4
Any thoughts?
In the controller, go to the "settings" area, and choose "About My Sonos System". This will show you the controller version at the top, and then next to each speaker, it will show the version of the firmware on each speaker.

According to supported OS , that machine should be able to be running 9.3, but you should be aware that some of the features have been removed from the desktop controllers, and moved to be only in the mobile controllers. See the thread here:

https://en.community.sonos.com/announcements-228985/updates-to-the-desktop-controller-coming-soon-6813300

I don't see listed there that they've removed the ability to change your library settings, but I'm not at home to check this on my own MacBook Air. Unfortunately, I almost always use my iPads and voice control via Alexa to control my Sonos system, so I'm not that familiar with the current Mac controller. And your issue might be covered under the "network settings" comment. Can you put a controller on another (mobile) device, such as an iPhone, to check?
Thanks, I found my way to the info about my sonos. Everything seems to be running 9.3. Is that what should be happening?
I have a controller on an iphone as well. I have tried to add the library of the Macbook from the iphone controller but it did not work as again the Macbook was not allowing access.
That's indeed odd. Do you have any virus/trojan programs running? Just checked on my Air, and it all seems feasible, but I didn't try connecting to a local iTunes library, mine happens to be on an NAS. But there's no real reason other than some other program blocking the ability of Sonos to see a local location.
Yes indeed odd. Spent a long time on the phone with Sonos and they were not able to figure it out. Suggested I call Apple. Thanks for helping to try to fix the issue.
I have exactly the same problem. Also using a MacBook (Pro).
Userlevel 7
Badge +20
I have exactly the same problem. Also using a MacBook (Pro).

Hi andrewmyers,

Thanks for reaching out. Please reproduce the issue, then submit a diagnostic report. If you reply here with the confirmation number I can take a look for you.
Here is the confirmation number: 816806983

Thanks.
Userlevel 7
Badge +20
Here is the confirmation number: 816806983

Thanks.


Thanks for the report. I see that your router is reporting an external network address for your computer when your Sonos system tries to connect to the music share. Most of the time rebooting your router and computer clears this sort of error up. Please try that, then attempt to add the music share again.