Unable to add samba share

  • 10 December 2017
  • 7 replies
  • 1726 views

Userlevel 1
I post the following on an existing and related topic but get no answer...
Anyway I post this here. I'm getting tired by troubleshooting sonos. Hardware is top quality but software sucks.

I have a samba share on a Debian system. It works great with any other smb clients, including android apps. But there's no way to use it in Sonos. The error message is "Access to share ... is denied, check username/pass...". The message is misleading because it works great on any other client. I don't know why things must be so complicated with this controller. The share is mounted on many devices here and it work great everywhere except in Sonos controller (Android, Windows or Mac, non work). It would be great also to have real error messages or a debug mode to investigate. How can I debug anything with this kind of wrong error messages. A "unknown error code" would be more useful...

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 1
I will reply my own question.

TL:DR: add 'ntlm auth = yes' in the global section of your smb.conf and restart the server.

It seams that even if samba v2 was released years before sonos creation, the brand decide to use SMB1 (it's 2017 and soon 2018 btw, and we are now using samba 4!!). Did someone at sonos ever heard about wannacry ?
It's not acceptable for such a brand to use SMB1 only!! Now I cannot use my sonos hardware (Four play:1, one sub with sub and my play:5 2) to listen to music. Well I can but I have to allow vulnerabilities on my network. It's a shame!
Userlevel 7
Badge +21
Yep... Sonos is very much aware of this. There are at least two other topics that are 8-10 months old, with many replies, regarding Sonos' continued use of SMBv1.
Userlevel 7
Badge +21
I moved my music to a Raspberry Pi computer which solved the security issue for me, cost about $50 and only took under an hour.

Beats adding a much more expensive device or worse a WD Live product that will stop getting security updates way too soon and become worthless.
Userlevel 1
Thanks for your answers and workaround ideas. I find it very unprofessional for sonos not to fix their software.
I assume there are reasons why this is a "non-trivial' software change. Otherwise, I'd bet they'd have done this ages ago.
Badge
Sorry, can i ask naively how one even attempts to connect to SMB from Sonos? My google is failing me. I have tried searching a dozen permutations of 'connect sonos to smb music' and can't find the Sonos documentation. I have looked at the list of 'Add Services' and don't see anything that makes sense. I have a smb share from a Raspbarian 3. I can connect from my laptop fine. I simply can't figure out how to connect from Sonos. Thanks.
Userlevel 7
Badge +21
Posted examples at your other topic.

https://en.community.sonos.com/setting-up-sonos-228990/how-to-set-up-a-nas-drive-with-sonos-6805662/index1.html#post16267282

The Sonos FAQ (that you can't get to from the forums) has the basics of using SMB.

https://support.sonos.com/s/article/78?language=en_US