Answered

TV remote will not control sound but used to

  • 7 December 2019
  • 2 replies
  • 353 views

I had to do a full factory reset of my speakers, Beam, two Play Ones, and a sub because I changed router passwords and didn’t realize I was supposed to prep my Sonos before doing so.  I spent about 3 hours on the phone with Sonos support last week getting it all reconfigured.  I notice now, however, that my TV remote doesn’t control the sound any longer.  I’ve tried everything I can think of.

  • Samsung 75
  • Sonos Beam is connected through Optical port on the TV
  • I have a Roku attached to the TV - when I’m using an app on the smart TV itself, or an app on the Roku, the results are the same
  • I can change my speaker output on the TV back and forth to the internal speaker, or the optical port and the remote controls the sound when it is in speaker mode, but not when in optical - the Sonos does play the content from the TV when switched to optical
  • I can control the volume using Google Assistant
  • I can control the volume using the Sonos app on my android
  • I’ve tried disabling Anynet+ HDMI-CEC on the TV, on or off has no effect.

This used to work fine before the network switch and factory reset.  Any help is appreciated.

icon

Best answer by Ryan S 10 December 2019, 01:40

Hi HemiGuy68, have you gone into the Beam setup and configured it to remember the remote? If it’s wired up via Optical, the only way for the Beam to get the remote volume commands is over IR, which the TV needs to be sending out. Check out the directions on this article about new remotes.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +26

Hi HemiGuy68, have you gone into the Beam setup and configured it to remember the remote? If it’s wired up via Optical, the only way for the Beam to get the remote volume commands is over IR, which the TV needs to be sending out. Check out the directions on this article about new remotes.

Thank you, I was not aware of this setting, but that took care of the issue.