TV group problem with additional Play1

  • 17 December 2016
  • 12 replies


I have a setup with a playbar in the living room, with a sub and two play1 all connected to the TV, this works ok.
I have an additional play1 in the kitchen that also works ok on it's own.
Grouping the living room and the kitchen works of I set it to some radio for example.
However, when I try to group them and send the TV sound to the group the play1 does not play anything.

Any ideas what could be wrong?

Thank you.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

One thing to check, although I'm not sure from your description that this is relevant.

In the room settings for your Playbar, under TV Setup and Control, make sure "ungroup on autoplay" is not ticked.
That option was indeed ticked.
I tried with that option both ticked and not ticked and the result is the same.

Additional clarification, I see that the group is created.
And when adjusting the volume of the group I see that kitchen is in there and I can adjust the volume individually for both the living and the kitchen.
It simply does not play the TV sound on the kitchen play1.
Submit a diagnostic and post the number. It could be that the wireless connections are simply choking on the uncompressed audio from the PLAYBAR.
Diagnostic Number: 6884065

Note: I forgot to mention that this worked in the past, I think before one of the last updates but I'm not 100% sure.
If anything stops working after an update the initial hypothesis would be that an IP address conflict has occurred. The first step would be a complete restart of EVERYTHING on the network.
I read this in another thread already.
What exactly is being tried by doing this?
DHCP release/refresh of IP addresses?
Because everything in the network is a lot of stuff around the house... Not even sure I'll not miss something...
I checked the About My Sonos System page and the Play:1 that is not working when added to the Living Room group is in version build b and the others are in version build c.
Yes, it would be a forced refresh of the IP leases. It needn't require a reboot if the device has a UI that can be used to refresh the connection. In Sonos' case it means power-cycling the units.

Reserving IPs in the DHCP server is the way to avoid this type of situation arising in the first place.

It's worth stressing that, with most routers' default lease time of 24 hours, any duplicated IPs ought to work their way out naturally so long as no addresses have been configured directly into the devices themselves.
My router allows me to see all active connections/DHCP leases and there is no duplicate there.
I also confirmed that the ARP table is responding properly and there is not conflict with other device on the network.

When I disconnect the Play:1 I see it as not active and when I connect it back I see it appear again online in the router interface.
I've assigned a static IP address via the router, but not luck.

I finally connected the Playbar with an ethernet cable and it works OK now with that setup.

But I would prefer to have everything working through my wireless connection.

Any other ideas?
I finally connected the Playbar with an ethernet cable and it works OK now with that setup.
Good, that suggests that IPs were indeed a red herring. Okay, so the system is now in SonosNet mode (aka 'BOOST Setup', despite there not being a BOOST involved here), and your kitchen PLAY:1 is now talking directly to the PLAYBAR rather than via the router.

But I would prefer to have everything working through my wireless connection.

The evidence points to the WiFi path, from PLAYBAR to router and router to kitchen PLAY:1, not being quite good enough for TV for some reason. Maybe the WiFi signals are low, or WiFi bandwidth is in demand from elsewhere. It wouldn't be the first time that SonosNet operation has proved to be superior. It was after all purpose-designed for audio.

If you want to pursue things then wait for Sonos to review your original diagnostic.
Thank you for your help.

I'll wait for Sonos review of the diagnostic.
Userlevel 7
Badge +26
Hi ZeroDarkLux, I took a look at that diagnostic and there was some wireless communication trouble but it's hard to say if that is the cause here. It's the most likely cause of the issue you're describing. I'd love to see a diagnostic from there after one player is plugged in. I saw you mentioned you'd done this, and if you can send in a new diagnostic that would be great.