Question

TV Autoplay on Playbar not working

  • 8 December 2019
  • 2 replies
  • 68 views

I have two ‘rooms’ configured in a group:

Room 1: TV connected to a Playbar +Sub + 2 x Sonos One surround sound speakers

Room 2: Sonos Amp driving 4 ceiling speakers.

Playing music is working fine but when I turn on the TV it does not automatically switch to TV audio.  ‘TV Autoplay’ is checked and ‘Ungroup on Autoplay’ is disabled.  To get the TV audio to work I need to use the app to uncheck and recheck the ‘TV Autoplay’ setting or select it from the ‘Browse’ function in the app.  Please help.


2 replies

Userlevel 7
Badge +21

Mine is set to “Ungroup on Autoplay” enabled and works as expected. To be honest I’m not sure what the expected behaviour of having that setting disabled.

 

  1. Does it play the video/TV (Playbar) audio to All the grouped rooms? or
  2. Does it note that it is playing grouped so carries on playing what is playing

I can see either of these working

 

First thing to do is to enable this setting and the test again. If that does not work try looking at your TV audio settings (not sure what that would be to look for),

 

Then if it still doesn't work try submitting a diagnostic after it fails to autoplay and you do it manually and post number here or contact Sonos with it (Twitter, Facebook or phone)

Thanks for the reply Stuart_W. I should have clarified: I’ve got these configured as two separate Sonos rooms but everything is actually in the same room and I want music and TV to play on all devices in the group.  If I enable ‘Ungroup on Autoplay’ then it breaks the group when I turn the TV on which is not what I want.

I think I’ve now found a workable solution: If I just press the volume button once on my TV remote the TV sound kicks in - meaning I don’t need to fiddle around with the Sonos app to get the TV sound to work.  So the workable scenario is quite simple:

  • Play music
  • Switch off music
  • Turn on TV (and there is no sound)
  • Press volume button (up or down) on the TV remote and this seems to ‘switch’ the Playbar to ‘TV audio’ and TV sound can be heard.  So all is good. :relaxed:

 

Reply