Question

TV Autoplay not working following September 2019 software update

  • 11 September 2019
  • 9 replies
  • 113 views

Good evening,

My Tv autoplay functionality stop working following the recent September 2019 Sonos ios app and hardware update on my Sonos Beam. When I switch on my tv it works fine, but when I stream music I’m unable to get the tv’s sound back. If I adjust the tv’s volume on my tv remote it prompts Receiver (HDMI) + or - but no sound is received from the tv. Any advice would be appreciated.

9 replies

Have you gone back in to the controller, and flipped it off, waited a couple of minutes, then flipped it back on?

I often find that a Sonos firmware update resets my "turn off the LED lights" function, which I have to flip back on and back off before they function properly again.
@Airgetlam thank you for the tip. I’ll try and see if it works.
Please post back if it does. If it happened to you, it might have happened to others, and would be nice to already have a confirmed fix here 🙂
Good Evening. Unfortunately I’m still having issues with the TV autoplay function. Hopefully some solution will surface. Thank you @Airgetlam
Odd. I'm assuming you've power cycled the Beam, as well as the TV (unplugging from the wall, not just turning it off with the remote).

I think I'd recommend that you contact Sonos Support directly to discuss it.

I suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
Badge
Getting same problem here as well. Stream music to the Beam using the Sonos App and then unable to switch back to get sound from TV to the Beam without recycling the Beam.

I Might have imagined it but I though there used to be a way to select TV again for the room from the app. If there still is then unable to find it now.
Click on "Rooms" at the bottom of the screen, then select your TV "room"
Then select the "Browse" to the left of the "Rooms"
Select TV.
Badge
Thank you Bruce. I’d never have worked that one out, but it does the trick.
Heh. You're welcome. It's not something I ever use, myself, but I happen to know where it is, so it was easy to double check on my TV.

It doesn't show up if the "room" you have selected isn't the TV, so it's easy to think it's missing.

And things are always slightly different after a software update. I'm still finding where things moved to 🙂

Reply