Answered

Trueplay adapting speaker sound step not working


When using Trueplay tuning for my Sonos One, the app gets to the screen that says Adapting Speaker Sound...and then never completes. It is stuck. I have tried multiple times. The only way to get back to the app is to close the app.
icon

Best answer by Keith N 3 April 2018, 20:58

Hello everyone. Thanks for keeping the conversation going about this. Are you still experiencing this issue? I am able to TruePlay without a problem with my own iPhone X. If you are still having this problem, please give our support technicians a call to troubleshoot this in real time. We will likely need to collect specific data about each case.

View original
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

44 replies

Userlevel 7
Badge +4
have you tried a reboot of controlling device.
I rebooted my iPhone and tried again. Same problem
Userlevel 7
Badge +4
strange. are you running sonos version 8.2.2. What ios version is your phone running.

Have you tried rebooting the Sonos One as well?
I rebooted Sonos One and iphone with no success. Sonos is version 8.2.2 and iPhone 8 is version 11.2.2
Userlevel 7
Badge +4
That is real strange. Really the only thing else I can think is reboot router or plug Sonos one into router and get t to run through one cycle of trueplay hooked to router then take back to where belongs and try running again.

Nothing short of some WiFi I terfernce should be causing any issue.
I have exactly the same problem on an iPhone 8. The Sonos app has been reinstalled and it just hangs as it goes through the "Adapting speaker sound..." process. The app has also been updated to 8.3 having hung at exactly the same place with the previous version.
Re: Chris...it appears that the problem was the distance from the Router causing a dropping in and out of the WiFi signal. Or, possibly, there was some sort of WiFi interference where I place the Sonos One. I moved the One to a different location and was able to complete the Trueplay on the first attempt. Thanks for your help.
I have the same problem. I was able to use trueplay. Then after updating my iOS on an iPhone 8. It hangs of both of my play1s.
To eliminate any network issues, the same process has been followed using an iPad running 8.3 of the software. The process completes successfully. Could this be an iPhone 8 issue?
Userlevel 4
Badge +3
Looks like it may be. Have you tried uninstalling and re-install of the app?
Both the iPhone restarted and the app reinstalled
I have the same problem with a Play:1 and an iPhone X. All devices and the App are up to date. I keep getting stuck at the "adapting speaker sound..." screen... The Play:1 is connected via LAN cable so the connection should not be a problem...

Edit: It did work right away with my iPad, so probably indeed a problem with iP 8 and iP X?
Ditto for me on the stuck screen. I am using the iPhone X. Play Ones, Play 5, and Playbase all the same issue. I was able to tune the Play 5’s in the past when i had an older phone.
Ryan S from Sonos has requested diagnostics from those of you for whom it is not working in another thread about this same issue. Perhaps it would help if you were to run one from your iPhone X and post the number here, to helpSonos figure out why it is working for some, but not for you?
Same problem here with iPhone X.
My previous comment still stands. If you really want them to find out why there's a problem, help them by providing a diagnostic.
Do you have a link to that thread? If I search on Trueplay I get over 100 hits...
Gah, Not offhand, I'm remembering a thread from Friday. Let me go look.

But I suspect if you were to post the diagnostic number here, he'd be able to find it. They've repeatedly said they read all threads, even if they can't respond to all of them.
Hmmm. Apparently, I'm mis-remembering his post. It's the last post on this thread:

https://en.community.sonos.com/controllers-software-228995/when-is-iphone-x-coming-to-trueplay-6796184/index1.html

And he asks for you to call in, rather than posting a diagnostic. Sorry about my error.
Badge
Has there been any further update on this as I am having problems tuning a Play 5 with an iPhone X (i.e. it hangs as noted above).

The strange thing is that I had no problem using the very same iPhone X with my SONOS 5.1 system (i.e. Playbar, Subwoofer and Connect:AMP).

With that, any and all insight would be greatly appreciated.
I’m having the same problem with my play5. The other play ones worked fine.
Same Here !!..Sonos One
Badge
Lucky for me does my daughter own an iPhone 6s Plus. The setup procedure with Trueplay worked just fine on hers and the sound improved nicely:D
Userlevel 4
Badge +3
Hi, all. We can certainly get to the bottom of this for you. Firstly, please try a different controller to complete tuning. No luck? Following an occurrence of this issue, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause for you. Alternatively, it might be an idea to get in touch with our support team via telephone. Many thanks in advance.
Just wanted to chime in and say that I have the same problem with my iPhone X, but I can successfully tune with my iPad Pro. From what I’ve read, people with iPhone 8/X seem to be having this issue. It’s definitely not a network issue in my case.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings