Tidal authorization not accepted since update

  • 2 November 2017
  • 44 replies
  • 4626 views

Userlevel 1
Since the new update, Sonos asked me to reauthorize the Tidal account. This is done thorugh Tidal, which accepts, but apparently the setting is not saved by Sonos. Consequently it not possible to use Tidal on Sonos 😞

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

44 replies

Userlevel 1
Badge +3
I have run into the same thing this morning. Worked fine yesterday. "Your TIDAL account named _____ needs to be reauthorized". This appears to be a Sonos issue as I can log in to tidal.com and access my music. I'm reluctant to hit the Reauthorize button given all the hacking that's going on out there. Any thoughts?
Userlevel 1
I agree, this is definately a Sonos issue. Hope the bright people at Sonos will work out a solution soon. And I have hit the reauthorize button several times now. Tidal accepts and ask me to return to the sonos app, however it tells me that the account has not been found. Very odd.
Same here. Frustrating
Userlevel 7
Badge +22
I had to reaauthorize my Tidal account for my own app, and it worked fine afterwards. However the manner of the failure was weird, so there may be some kind of infrastructure snafu going on. (I used the PC app to reauth in case that makes a difference).
Userlevel 7
Badge +26
Thanks for letting us know guys, we're looking into it right now as we've heard a few other reports of similar issues. An official outage hasn't been called yet, but it's under investigation. If you keep having trouble, I'd suggest that you give us a call to take a closer look.
Userlevel 1
Badge +3
Thanks, controlav. I also reauthorized on the PC and it's all working now, including the ipad controller.
Userlevel 1
@dmbyrnes by reauthorizing on the PC, do you then mean through the Sonos software programme? I tried both yesterday evening, but was not successful. 😞
I have the same issue. Sonos requires Tidal to be reauthorized, Chrome is launched on my mobile, I log in and get the message "TIDAL is now set up on Sonos Return to Sonos App to play now". Return to Sonos app which then says "Account not found". Sounds like a clear bug to me. I am on Android and latest Sonos version.
PS, my TIDAL account is valid and works on other devices. Hence, the issue is the connection between Sonos app and TIDAL.
Userlevel 1
Same issue. I have managed to have the “TIDAL is now setup on Sonos, return to Sonos app to play” message on all my devices connected to Sonos. One android mobile, one iPhone and iPad and one PC. They all tell me I can return to Sonos to play, but none seems to save the reauthorization on TIDAL. ? Apparently this issue affects many types of devices.
Works for me now. Here's what happened.
I get a question to authenticate. Enter my mobile phone number which is my user ID for TIDAL. TIDAL does not recognize it and ask for a valid e-mail. I use my e-mail and am able to authenticate towards TIDAL. Return to Sonus app results in "Account not found". BUT, if I repeat the process and add my country code to my mobile number, the user ID is valid. I can authenticate and Sonos is able to connect to TIDAL. Hence, for me the solution was to add my country code.
Badge
I have the same problem. Trying to connect via Sonos app on pc and Sonos requires Tidal to be reauthorized, over and over again
Badge
And now for no apparent reason it works again
Since one solution to try here is to re-authorize Tidal from the PC - please remind me how to connect via PC!
I found the Windows app, installed it, and tried to start TIDAL from my PC. Same message -- request to re-authoruze TIdal - and I did, and I returned to the app - and same request again. So for me, trying to re-authorize from PC does *not* work!
***Blush*** A combination of own error and un-wise message from Sonos was the explanation in my case. When trying to authorize, I entered the correct password but not the right user name ... However, the message I got as a response from Sonos, was that "now you are authorized and please return to the app"! Which is not very smart in this case, to say the least. So I switched back to the app and nothing worked, of course, not seeing that a *separate* window had opened *behind* the other windows on my screen, telling me "account not found"...
Still not working here.

I've reauthorised the Tidal account via mac (a number of times) always getting the message from Tidal that "Tidal is set up on Sonos". Same on my phone.

Return to Sonos app only to find "Account not found".

Please fix this.
Userlevel 2
Same issue here. Reautorisation does not work neither from PC nor from Android device. Tidal itself on the Android device works like a charm.
Just tried again. From both mac and iPad. Still not working.

Submitted diagnostics. Confirmation number is: 8059318.
So. This is slightly embarrassing but might be of use to anyone else struggling with this issue. It works for me now.

Why it didn't work: I logged into Tidal with my email address thinking I was logging in to the account I'm using, but this seems to have created a new account(!). This account was for obvious reasons not being authorised via Sonos as It's not active (not being paid for).
I also tried logging in with my phone number. No go there either, and probably created another account(?) before I tried:

What made it work: I logged in with my phone number. Added country code. It now works. No + in front of country code, no space between country code and phone number.

Feeling a bit dim but at least there is music in my home:D
When can we expect a solution to this issue? I have not been able to use Tidal on my Sonos system for more than a week now. Since Sonos depends totally on the streaming services this should be high priority.
This has taken too long. Are anyone working on this or should I just give up Tidal.
My wifes Ipad also cannot stream from Tidal anymore. Tidal users need to know what is going on. If we cannot stream we have very limited use of our Sonos systems.
I will add some more details to this problem. My Tidal account is a complimentary offer to my mobile subscription. I log to Tidal using phone number (user) and a password provided by my mobile operator. And these credentials are sufficient to log in to native Tidal application. There is no need to have any special account, e-mail, facebook etc. It is also sufficient to play tracks from Sonos queue! Yes, without reauthorization (which does not work, as it was reported by many users before) I can still play songs added to the queue before this stupid reauthorisation was introduced. Another interesting thing is that over some period one android device controlled asked for reauthorisation and another worked without any problems. Now the problem affected all my controllers. I am using old 5.2 version of the system (since the unfamous case of undisired change of mute button function I decided to ignore further updates to keep my system stop working the way I want it, not the way some ignorant from SONOS wants it). So it is not a problem caused by upgrade of system and controllers but it is cause by some change on server side at Sonos. And it is definitely not a problem with Tidal, it is just another stupid problem created by Sonos engineers. Shame on you! Please stop fixing something that is not broken!
It has been several weeks now without being able to use Tidal on Sonos - and no feedback what so ever from Sonos. They could at least acknowledge the problem and state that they are working on it - or just plainly say that Tidal is such a small community that they do not prioritize it. At least we would know more than we know now. At least it is evident that no Sonos representative pays any attention to this tread...