Question

Symfonisk speakers keeps disconnecting from M1 mac mini

  • 20 September 2022
  • 1 reply
  • 9 views

My Symfonisk speakers are used as all-time connected to my Mac via airplay.

Both speakers and Mac Mini M1 are connected via ethernet cable to the same switch.

Music playback normally works when changing system audio output from system speakers to Symfonisk pair and they will work without issues, but that “depends”. Depends on that is some audio (youtube, program, spotify) making noises is still active on a computer. If I stop playback of anything for 1-2 min and try to play something again - from browser, movie - there is no sound. I need to change again output to built in speakers and again - to Symfonisk pair.

Saddly I need to stop my playbacks many times during my working day I need to answer a phone and that makes that I need to each time flap the output - this is very annoying issue.

My diagnostics 1781489933


1 reply

Userlevel 7
Badge +18

Hi @acidkill 

Welcome to the Sonos Community!

This is expected behaviour - the Airplay connection is timing-out due to the lack of data being transmitted during the silent periods.

In addition, when you activate AirPlay from the macOS system menu. you are utilising AirPlay v1 which is not supported by Sonos - though it does tend to work. AirPlay v2 needs to be activated from within a particular application, like Apple Music. This brings me to my next point - Sonos (and Symfonisk) devices are media players, not PC speakers. When the media has apparently finished (silence), the connection is ended. The main issue is that you are attempting to use the speakers in a way that they were just not intended to be used. AirPlay 2 is reportedly better behaved in this respect, but you would need to change the connection with each application used and you would not get system sounds through the speakers.

There is much more information - as well as a workaround or two - on this thread:

I hope this helps.

Reply