Answered

Surround with Connect: Amp setup

  • 29 December 2018
  • 2 replies
  • 244 views

Hi, I have a Sonos Beam connected to my Sony TV (KDL-40V4000) via optical audio adapter. I am using a Connect:Amp to power my surrounds (two ceiling speakers), and the Sonos system is in a wired setup.

When I look at the app/about my Sonos it shows - Audio in : Stereo, no matter what I am watching.

I tried switching the optical cable directly to the DVD player, Apple TV (including Netflix), and foxtel box, and played programs/DVDS with DD, but it still says stereo every time. Not even DD 2.0

I played a 5.1 test DVD (via direct optical connection to the DVD player) and was able to send individual signals to the FL, C, FR on the Beam, but the individual signals (white noise) to SR and SL came through both surround speakers. This suggests that my setup is only capable of 4 channels (3 from the Beam, and 1 for the surrounds). Note I am not running a sub.

Why am I only seeing Audio in : Stereo, and why does the signal sent to either SL or SR get sent to both surround speakers? Is this to be expected?
icon

Best answer by Chris 29 December 2018, 16:11

Not sure about the SL or SR issue if has to do with your wiring or something. But your getting stereo when the source isn't outputting 5.1

on the Foxtel box as example - hook the optical direct to it. Go into the settings on the Foxtel box and make sure the audio output is set to Dolby Digital surround. There is no reason direct connected to the cable box and the cable box set to surround 5.1 that you shouldn't get the signal showing as 5.1
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +22
Not sure about the SL or SR issue if has to do with your wiring or something. But your getting stereo when the source isn't outputting 5.1

on the Foxtel box as example - hook the optical direct to it. Go into the settings on the Foxtel box and make sure the audio output is set to Dolby Digital surround. There is no reason direct connected to the cable box and the cable box set to surround 5.1 that you shouldn't get the signal showing as 5.1
Thank you Chris, I hooked up the direct optical link and set foxtel to DD surround and, like you said, am now seeing Dolby Digital 5.1 under audio in.

The other issue I had with the SR and SL was due to the DVD player outputting pcm, so I changed this in the DVD player settings. Everything seems to be working as expected. Thanks again.