Answered

Surround Sound connected but not showing up

  • 7 January 2019
  • 4 replies
  • 486 views

I have a beam and 2 play ones. I set my beam up and have been attempting to set up the surround sound. It said it is set up, but when I go to settings and advanced audio it does not show that I have surround sound speakers and no sound comes out of the play 1s.
icon

Best answer by Airgetlam 8 January 2019, 00:33

That ? generally means that the device hasn't been able to get an IP address from your router, so it's not being properly communicated with. Although I suppose it's also possible that there's enough wifi interference to cause issues, as well. They're connected to your Beam using a 5Ghz connection, so you'll be wanting to pay special attention to devices that use that frequency (although not just that one....some electrical devices don't have wifi, but spill interference out anyway).

You may want to open up your router's DHCP table and see if it thinks that the surrounds are properly provisioned. Feel free to reboot those speakers, and re-add them as necessary.

It may be best for you to contact Sonos to discuss it, too. They can walk you through this process without waiting for my random visits to the forums.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

OK, let's do this step by step.

Go into the Room Settings page in the controller app. What does the app show on the room that you've named for the Beam? It should show something like "room name" and then (+LS, +RS). Does it?

I'm interested in your Tacos tag. Do you deliver tacos? Can I order some? :)

Also, what are you watching on your TV set when you're attempting to set this up? You should be watching, for instance, a movie channel that has a Dolby Digital movie playing. You should also be looking at the audio settings on your TV, to make sure that it's setup to pass through Dolby Digital.

How do you have your Beam connected to the TV? Is it via HDMI-ARC, or is it by the optical cable and adapter?
Okay, wen i go to room setting it shows (+? +?) after my room name. I am streaming spotify through the sound bar trying to hear surround, but i have also tried streaming through my tv. My sonos is hooked up directly to y ps4 through an optical cable. I have changed the settings in the ps4 however, to work with dolby digital. I have tried several times disconnecting the surround speakers and reconnecting them and every-time it works up until after both are connected and it will say there was an error optimizing the sound please try again later. Also thank you for answering.
It says there was a problem preparing your speakers. Every time
That ? generally means that the device hasn't been able to get an IP address from your router, so it's not being properly communicated with. Although I suppose it's also possible that there's enough wifi interference to cause issues, as well. They're connected to your Beam using a 5Ghz connection, so you'll be wanting to pay special attention to devices that use that frequency (although not just that one....some electrical devices don't have wifi, but spill interference out anyway).

You may want to open up your router's DHCP table and see if it thinks that the surrounds are properly provisioned. Feel free to reboot those speakers, and re-add them as necessary.

It may be best for you to contact Sonos to discuss it, too. They can walk you through this process without waiting for my random visits to the forums.