SUB won't connect to PLAYBAR

  • 31 January 2018
  • 8 replies
  • 2352 views

Bought a sub to add to my playbar. It will not connect. It always comes up with an error saying: SUB setup error, make sure your sub and playbar are connected to power. They both are. I read some stuff here about similar issues and since I was running this through my wifi network, i purchased a BOOST. I went through the setup to add that in, and tried to add the sub again, no luck, same error. I have done just about everything i can think of, restarted everything, re-added everything, no luck. The sub and playbar are probably 15 feet from the wifi router, so it shouldnt be a distance issue, but i cant connect them directly to the router. What am i missing?

8 replies

Userlevel 7
Badge +22
can you plug one of them into router via Ethernet and try setting up again. At least the sub - not to leave that way but just for setup.
I plugged the sub directly into the router and tried to add it again. It stalled at the connecting screen and then finally gave an error that it couldn't connect to player and maybe I should move it closer to the router. I restarted everything and did it again, same result.
Userlevel 7
Badge +22
Do you have any way to connect the playbar to the router?
Userlevel 7
Badge +22
My personal way would be to plug playbar in router. Do a factory reset of the Sub. Then add sub.
I have the same problem as the OP. Have Playbar connected to Sony smart TV via optical, love it, trying to add a Sub. Cannot do it wirelessly, cannot do it with wired connection to LAN.
System environment: Playbar is connected directly to LAN (8-port unmanaged switch) via Ethernet, as it didn't like my UniFi WiFi network with three access points and 2 WLANs (2.4GHz and 5GHz), all with the same SSID, no guest portal. Playbar has a static IP address, and the Sonos Controller app on iPhone can see it from anywhere in the house, and in About My Sonos System it is listed as the Associated ZP at that IP address.
Troubleshooting: unboxed brand-new Sub, followed directions to plug in to power, sat 6 feet from WiFi access point (and Playbar), hit "Add a Speaker or Sub" in iPhone app (after running updates first), waited for green flashing lights, pressed join button, got orange light, waited several minutes, failed with "Sub setup error". I tried this 5 times, then connected Sub to same switch as Playbar, and tried 5 more times. Then factory reset Sub three times and tried again. Same errors.
I should add that with the wireless method, the app shows that the Sub was auto-detected, so the Sonos Controller app can see it, but setup still fails.
Read a ton of articles online, decided to disable two out of three APs and the 5 GHz radio on the remaining AP (close to the Playbar & Sub), so that my WiFi network is as simple as possible: just one radio, one WLAN, one SSID. I set the SonosNet channel to 11 in the app, and made sure my AP was 2.4 GHz only on channel 1. Oh, and rebooted entire LAN and WiFi to ensure all IPs are fresh and pure. (All the fixed devices on the LAN have static IPs, including the TV, Playbar, APs, desktops, etc. For good measure, since my UniFi app can see the Sub when it's connected via wire, I made that IP static too, so that it's reserved for the Sub.) Still same error.
Please help. This equipment is supposed to be plug & play, and it has been anything but.
Update: if you have "Block LAN to WLAN multicast and broadcast data" your iPhone can't broadcast to all LAN devices, so can't complete the setup. Oops. Thanks, Sonos support for describing the process by which the devices attempt to connect when adding new devices... As I had that on (blocked) for a reason, will try on/off and whitelisting devices incl the phones and the Sonos devices to see if blocking multicast is ok for normal operation (listening to audio but not adding new Sonos devices.)
CheeseWit -- did you resolve your connection issues? I also have Unifi equipment, along with an Apple extreme router. This 'setup' process is so dumbed down, it's impossible to locally troubleshoot. Just received a Sub to go with my existing play-base. Both plugged into a local 1G switch, hardwired to my LAN. Playbase works, Sub doesn't complete setup (cannot connect). No other data. Why, oh why can't this equipment see each other over the wired LAN? Why isn't there a backdoor into the device to see some logs, error codes, bluetooth localized controller -- SOMETHING.

Restarted all equipment, Sub is a half meter from the playable. Swapped ports on the switch, swapped with known working patch cables. Turned off wifi security. Rebooted repeatedly. Factory reset of the Sub. Sonos techs -- surely you can do a better job of finding some way to have proper error codes, localized troubleshooting.

A $600 frustration at the moment.

------------------

Holy smokes -- that setting in the UniFi AP resolved the cannot connect to Sub issue. Turning off the 'Block LAN to WLAN multicast and broadcast data' -- didn't even have to restart anything other than the UniFi AP with the updated setting, and the iPhone app was able to complete setup.

For other users of UniFi equipment, this is found using the Mac application UniFi Controller, allowing it to launch a browser, log into the device (AP in my case):
Select the Settings gear in the bottom left navigation bar.
Select Wireless Networks.
Edit the desired wifi device.
Under Advanced Options, deselect the Multicast and Broadcast Filtering checkbox.
Save the edit.

I do hope the Sonos folks are crafting a living document or web page collating all of these troubleshooting tips. Sifting and digging for this in the community is nice, but one-stop troubleshooting would be easier. Being a holiday weekend, it would have been Tuesday before I could have reached them on the phone to tackle this.
I was having the same similar issue with OP as well, and I tried everything advised previously (including directly connected to the router via Ethernet) but the Playbar still would not pair with the Sub, or the vise versa. Then I took a look at my reserved IP addresses within my router and saw that both devices were using the same IP address... That explained why only one would complete the setup and not the other. Once I set the Playbar and Sub on two different IP reservations and rebooted the router it immediately started working again.

Reply