Answered

Sub gen 3 will not connect


I have:

Zyxel router where Wi-Fi has been disabled. From zyxel goes a cable to DECO M9 PLUS. From Deco goes a cable to Sonos Boost.

All Sonos products (2*five, 1*3, 1*symfonisk, 1*Arc) are connected via Boost (WM: 0)

I have tried to connect Sub (gen 3). In the end of the setup it says the “Sub has been added but might not be shown. Turn it off and on again”.…

But nothing happens. It will not connect. Find missing products does not help.

 

Diagnostic: 179467386

 

Wi-Fi on Arc is enabled, and I have tried both the resetting, unplugging, and rebooting of all devices. I never get to the point where I should add Sub to Arc. It never shows on my system.

I have tried both “add product” from System and  “connect sub" from the room where the Arc is installed. No luck 👎

 

icon

Best answer by Airgetlam 11 June 2021, 00:49

You could always call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

View original

10 replies

I’m assuming due to the Arc, you’re running S2. My guess is that for some reason, the router (and I’m suspecting the Deco M9 Plus is a router?) isn’t handing out an appropriate IP address for the Sub gen 3 to use to connect to. I would, while you wait for Sonos to look at the diagnostic, try a reboot, first of the Zyxel, and then by this DECO M9 Plus, whatever that is. One of those two devices is responsible for handing out IP addresses via the BOOST to the Sub. That *may* fix the issue. 

Userlevel 6
Badge +17

Hi @Lisbetbrink 

Welcome to the Sonos Community!

I agree with Bruce - as you have a router and a mesh system, which comes pre-configured to also operate as a router, you likely have some DHCP conflicts.

Please follow the instructions on this page to put your Deco system into Bridge/AP mode:

https://www.tp-link.com/us/support/faq/1842/

Reboot your Zyxel router and Sonos devicesafterwards.

I hope this helps.

Hi @Lisbetbrink 

Welcome to the Sonos Community!

I agree with Bruce - as you have a router and a mesh system, which comes pre-configured to also operate as a router, you likely have some DHCP conflicts.

Please follow the instructions on this page to put your Deco system into Bridge/AP mode:

https://www.tp-link.com/us/support/faq/1842/

Reboot your Zyxel router and Sonos devicesafterwards.

I hope this helps.

Hi Corry

Is it the Deco system that has to go into Bridge/AP mode? I have disabled Wifi on the router in order to let the Deco control the wifi (to be able to cover the whole of our cadastre) - so could it be the router that should go into Bridge mode?

Best regards, Lisbet

Userlevel 6
Badge +17

Hi @Lisbetbrink 

I completely understand why you’d think so, and the answer isn’t clear-cut. The simplest option by far is to put Deco into Bridge/AP mode.

There’s a difference between WiFi and the network. The first device in your home that connects to the outside (apart from a modem) should be running the network (as in, providing IP addresses, SPI firewall, and other functions) whereas WiFi interfaces are added at a different level. So, your mesh system should go into Bridge/AP mode so that it doesn’t try to run your network, as providing WiFi isn’t really part of creating a network.

If you wanted your mesh system to run your network, you’d want your router to act only as a modem. This would involve disabling multiple functions on it, not just the WiFi broadcast, and never connecting anything to it apart from the device that will operate as a router.

If it helps, you can visualise a router as being a combination of a modem, a gateway, a firewall, a network switch and a WiFi access point (in that order). Disabling WiFi doesn’t affect any of the other functions. Having a second router duplicates all these functions, so you want your mesh to provide WiFi only as all the other functions are already being done by a device higher up on the connection hierarchy. Therefore, the mesh should be in Bridge mode unless you really know what you’re doing when configuring the network as a whole.

Duplicating the router functions effectively creates a separate network. When a device connects (at any point) to the network, it asks for an IP address and two routers will respond. The connecting device will listen to the first device it hears from, and ignore the second. Which reply reaches the device first is most likely due to the device’s “closeness” to one of the routers (in connection terms), but it could be either. Devices that respond to the router’s reply will be unaware of devices that respond to the mesh node’s reply, and vice versa.

While I can’t guarantee that this is the cause of the problem you’re experiencing, it’s such a big issue that we can’t really think about other possibilities until we’re sure it’s no longer a problem, and it’s best to resolve it for general network health anyway.

I hope this is of help.

Hi @Corry P 

Thank you for your detailed answer. I have not been home to try this yet, but I will let you know as soon as possible if itsolves the problem.

Best regards, Lisbet

I am so depressed… I have tried it all. I have changed the Deco M9 to AP/bridge mode. I have restarted router, mesh and all Sonos units several times. All, except Sub, are back in the system and working. The sub will not connect to the network.

First time it actually connected, stated an update but when it had finished it stopped with error code 1005 and would not connect to our Wi-Fi. 
I have tried to restart and to reboot. But the Sub will not connect.

Any more ideas or should I just drown the Sub in my tears?

 

You could always call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Userlevel 6
Badge +17

Hi @Lisbetbrink 

@Airgetlam has the right idea. With probable dual DHCP issues now out of the picture, please give our support team a call. There may have been compounded issues inyour case.

For your information, error 1005 is a timeout waiting for a player to respond.

Thank you for your guidance. I am not often home between 10-18, where support is online. But today I have asked my son to try and call them.

Late yesterday the Sub suddenly appeared in the system and it was working when we went to bed. This morning it had changed to ? and did not work again. Nothing has happened since last night to make it go offline again.

:-(

Userlevel 6
Badge +17

Hi @Lisbetbrink 

Although we always start with troubleshooting the network (because 99% of the time, that’s what the problem is), sometimes there’s just an issue with the unit. Tech support will get to the bottom of it for you.

Reply