Answered

STOP ASKING ME TO TRY SONOS RADIO, BEAM, MORE SONOS JUNK etc

  • 8 October 2021
  • 6 replies
  • 110 views

Why won’t SONOS stop spamming me? How do I stop it? There are messages from other users in this forum going back years about this that are closed topics. But still SONOS ignores its own settings. I contacted Sonos support again about this earlier in the week. They said the same things to me that they did a year ago about changing settings when I asked. And then they said they would look into it more to end the conversation. And I have now received more marketing spam from them about yet another product they are trying to sell. Sonos is a wretched company. All my devices have in app and email contact options disabled but these switches are not respected by SONOS marketing.

All my devices received the same spam. It goes on and on. If SONOS want to repeatedly send unsolicited messages then the products should be free. From what Sonos support tell me they must have been looking into a ‘fix’ for this for years. Or maybe they don’t want to fix this because people do not care.

 

icon

Best answer by Corry P 14 October 2021, 12:02

View original

6 replies

Userlevel 7
Badge +20

Try enabling and disabling the options on both the website and also the app preferences on your controller/s.  It seems they can get out of sync.

Not everyone gets these messages so the settings do work for most.  

 

Thanks bockersjv. I have tried this many times. But I’ll try again. Unfortunately, I have looked all over the app and I can’t find the setting any more. Where is it? In my App preferences I have:

Show notifications OFF
Enable Search History OFF
Confirm Locatioins OFF
Allow Pop-up Messages OFF

Data & Privacy
Use Personalization Services DISABLED

In Android App info

Notifications Blocked
Permissions No permissions allowed

Tese settings are the same in an Android tablet I have.

In IOS

Notifications OFF

Just looked in another ipad I have and it is saying

Setip → Add a voice Service, Try Sonos Radio HD, Connect surrounds to Bathroom

Not again. Eye roll. This ipad is on IOS 15 and I cannot see the Sonos notification setting that is present on my other device that is IOS 14.

Speculation: There is some sort of interaction between privacy settings that prevents the election to block the spam messages from reaching the spam server.

Userlevel 7
Badge +17

Hi @harry smith 

Thanks for your post!

Please log in to your Sonos account at https://www.sonos.com/login, then click on Profile then Edit Profile. Scroll down, find the setting in the picture shown below and disable it. Click Save Changes.

I hope this helps.

Badge +2

So if I do not want to receive repeated spam from sonos I have to tick the box. I admit that had crossed my mind but it did not seem like common sense to me. I would have thought that was the answer to “Tell us how you’d not like to get product information”.

I’ll give it a go.

Userlevel 7
Badge +17

Hi @harrysmith0 

Apologies - the picture was misleading. Please untick the box to stop the messaging.

 

Edit: This would imply that it was already unticked for you. I recommend you get in touch with our technical support team if this is the case.

Reply