Answered

Spotify via SONOS looses connection to SONOS Connect

  • 31 December 2017
  • 7 replies
  • 582 views

Userlevel 2
I play Spotify music over my SONOS Connect directly via the Spotify app using the "Connect to a device".

Lately Spotify has started to loose connection to the SONOS in the middle of playback.

- Sometimes the music stops
- Other times its only the Spotify app that disconnects from the device and just shows "Listening on This phone" even though its clearly playing through the SONOS Connect and my amp and speakers and NOT the phone, and the SONOS app shows "Playing from Spotify". If I then click "Next" on the phone SONOS stops playing and the phone starts.
- Some times when playback stoppes via SONOS I can connect to device (SONOS) again in the Spotify app and it resumes Spotify playback through the SONOS Connect.
- Other times Spotify just says "Connecting..." for a while, times out and reverts back to "Devices available" with no sound (besides on the phone).
- Some times SONOS starts playing at the same time as the phone while it says "Connecting..." if I press Play and then returns to "Devicves available" after timeout though SONOS playback continues. And when I then stop playback on the phone the SONOS also stops.

WEIRD!

The SONOS Connect is hardwired to my internet router via a switch.
The Spotify app runs on a mobile phone connected to the wifi using a Unify AP thats also connected to the same switch.

A few days ago I had everything (SONOS, internet router, firewall, switch, access point) restarted - SONOS was updated this morning and X days ago, but I still have issues.

Diagnostics 8300826 and 8300861.
icon

Best answer by Ryan S 10 January 2018, 20:26

Hi Nicolaj, I see you're already working with a technician via email. They'll help you get all sorted out and let you know if a call would be best. Great troubleshooting and details so far, thanks!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +20
When you restarted your devices did you do them this order, powering down for 10 secs and then letting each one complete it's boot sequence before moving to the next:

- Router
- Any network switches
- Any wired Sonos devices
- Any other Sonos devices

(Sorry if this is something you already know but the idea is to boot devices from the start of the daisy chain (Router) sequentially through to the end device (Sonos Wi-Fi player)

If you have your Connect wired can you ensure that your Wi-Fi credentials are removed in the Sonos app>Settings>Advanced>Wi-Fi Setup - this will ensure that the Sonos devices use SonosNet and not switch between that and Wi-Fi.

Also can you please test if this happens when using the Sonos App rather than the Spotify App?
Userlevel 2
Thanks for your reply.

My SONOS already uses mesh/SonosNet mode, the controller says WM: 0.

I'm not sure abut the restart sequence lst time I did it, but will make sure to do it the order next time.

To me it seems that it's the connection between Spotify on the phone and the Spotify service on the SONOS in one way or another. I can try to test what the status is on both the Spotify and SONOS app on my Mac when it happens.

I was hoping SONOS was able to see something from the diagnostics I uploaded.

BR,
Nicolaj
Userlevel 2
So latest status, SONOS Connect was restarted after router.

1) In Spotify app on phone, Connect to device, select SONOS device, presses play - playback starts through SONOS
2) In Spotiy app the current track isnt reflected thouh it is connected, after a while it:
2a) either turns to "Not connected" (and Play button ready like it is paused)
2b) or stays "Connected" but still without reflecting current track being played (and Play button ready like it is paused)
3) Spotify app on MacBook = same story
4) SONOS app on phone = Shows "playing from Spotify"
5) SONOS app on MacBook = Shows Playing from Spotity"
6) If I in Spotify app press "Connect to device" and select the SONOS (with playback through SONOS still running) it fails to connect to the SONOS.
7) If I in Spotify app press play, playback through SONOS stop and it start on the phone
😎 If I now press "Connect to device" it now succeeds - but goto 1) story continues
9) So SONOS is convinced it is connected to Spotify - but all Spotify apps are not aware of this or rather loose this information.

As I said this started a few months back after I think a SONOS update.

SONOS diag uploaded again: 8334418

Can anyone see anything from the uploaded diagnostic? :-/

I appreciate any help in this, thank you very much!

All the best,
Nicolaj

P.S.: Seems like I'm not the only one?
https://en.community.sonos.com/announcements-228985/outage-spotify-playback-issues-and-spotify-connect-from-android-december-2017-6795326/index7.html#post16189956
https://en.community.sonos.com/troubleshooting-228999/spotify-connection-6795367
https://en.community.sonos.com/troubleshooting-228999/play1-connectivity-issues-via-spotify-connect-6788225
Userlevel 7
Badge +26
Hi Nicolaj, I see you're already working with a technician via email. They'll help you get all sorted out and let you know if a call would be best. Great troubleshooting and details so far, thanks!
Oh, I'm facing exactly the same issue, I have all the latest version of software on my Windows laptop, Android phone and iPhone. I have tried to connect Sonos 5 via network cable and also via WiFi - the problem still remains. I did a plenty of tests of the network and it's all good so it seems like the issue on Sonos/Spotify side. This problem was appearing and dissapearing from time to time but recently it became worse so that I just can't listen to music and I have to connect via line-in cable which completely ruins the experience.

Sonos diagnostic 1387463902. Please let me know how I can assist to troubleshoot the issue.
And also if I play the Spotify music via Sonos app it seems to be working fine. But only very small part of Spotify functionality is integrated there
Userlevel 7
Badge +19
Hi there, zihotki. Thanks for the diagnostic report! I'm only seeing problems with the Living Room player losing connectivity to the main router. This wouldn't necessarily cause a problem with Spotify Direct Control only, as interference and poor signal usually creates audio dropouts. It may be best to give our support technicians a call to troubleshoot this in real time. Thanks again.