Question

Spotify skipping songs constantly

  • 9 February 2017
  • 27 replies
  • 2008 views

Spotify is constantly skipping songs in the last few weeks after the software upgrade, no issues prior. Have spoke with 2 customer service reps, been on hold for hours, restarted the system and modem, and no resolution. My internet speed is fine and that's been confirmed. No issues on pandora from what I've heard. Suggestions?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

27 replies

Userlevel 7
Badge +20
Spotify is constantly skipping songs in the last few weeks after the software upgrade, no issues prior. Have spoke with 2 customer service reps, been on hold for hours, restarted the system and modem, and no resolution. My internet speed is fine and that's been confirmed. No issues on pandora from what I've heard. Suggestions?

Hi Lindsey2212,

It looks like your case was escalated to our tier 2 team. Please reply to the emails they sent to schedule a call and they'll help you out.
Exactly the same issue here. My Sonos system has been unusable since the update. Please forward any suggestions you are given.
Userlevel 5
Badge +10
Hey Horn... Welcome to the Community

Just a friendly comment that you may have different issues than the original poster... there are a few relatively common problems that the community has seen develop in the past few weeks since the update went out, but they generally do not have to do with the update. (And yes, to be clear I'd love Lindsey2212 to provide an update on her experience and solution as well since since it helps everyone....)

If you can provide a few details of your experience, it could be helpful for others to provide some helpful advice.... as well, you could go to the Sonos App and "submit a diagnostic", record the number, and post that here - that way the Sonos staff could look at the specific log details from your system and perhaps identify any specific issues are having that may be apparent from the submitted data...
Thanks Shark,

My spotify playback is constantly skipping to another song after a minute or two. I have tried resetting my router, unplugging my Boost and adding it back into the system, and checking my Internet speeds. Everything looks fine, and yet Spotify consistently does not work. This has been happening only since the last Sonos update.

I just submitted diagnostics to Sonos, confirmation number 7087404.
Userlevel 5
Badge +10
Since Jeff is on this original thread, I suspect he should see this. He's *very* helpful.

This is one issue that I personally have struggled to identify a single common source issue with. I've experienced it for a very very limited period of time one evening only (annoying as ****) but it simply resolved itself. I've seen it on the forum, but it seems lots of source issue can present themselves as this...

So, while I have *no specific idea* that this will resolve your particular issue... work this through with me and see if this may make sense for you to try as a first level of troubleshooting:

When you use a controller to tell a Sonos you want to listen to a Spotify source... the controller connects to your system and, the controller connects through a specific player and provides instructions to the rest of the involved players on your system to retrieve the source and play it. For this to occur properly, this obviously requires proper communication to be occurring over your network and certainly for on-going communication to be effective your network needs to be operating properly.

One of the more common issues with network communication quality that appears to happen following an update occurs when players reboot themselves - they may get inappropriate addressing information from your router. I admit I was shocked at how common this appears to be, but the longer I've been connected to this community, the more I see it.... it seems that routers often struggle to effectively keep track of the IP addresses actually in use, and that, combined with devices having different approaches to requesting new IP addressing information from a router, can lead to communication issues that can exhibit itself as a number of different problems. (often as intermittent audio through some players when playing a source...)

If these duplicate IP addresses do exist on your network (I'm not saying they do, just that they may) that can obviously be a communication challenge for your system to effectively communicate with external systems like Spotify...) So, It *may* be worth you completing a full reboot of your network... while a bit of a nuisance, it certainly won't hurt anything if it isn't needed. To do this you would remove power from all of the devices on your network (all devices that use the network - Sonos Devices, computers, phones, printers, hubs, tablets, etc. etc. etc.) power off all devices, power down the Router and the modem (if different) then power up the modem, then the router, then each device one at a time. This forces new IP address assignments from the router and eliminate duplicates. This can ensure the data is flowing properly through your local network.

There are obviously other items that may be causing the problem, and Jeff may want to know the specific make and mode of your router - so you may want to post that as well... Hope you get it resolved and I'll be looking to see if you find the source issue!
Userlevel 7
Badge +20
Thanks Shark,

My spotify playback is constantly skipping to another song after a minute or two. I have tried resetting my router, unplugging my Boost and adding it back into the system, and checking my Internet speeds. Everything looks fine, and yet Spotify consistently does not work. This has been happening only since the last Sonos update.

I just submitted diagnostics to Sonos, confirmation number 7087404.


Hi Horn007,

There's some wireless interference showing up on your diagnostic report. This is making it hard for your BOOST to send data wirelessly to your Sonos units. Please make sure your BOOST is not too close to your router or to any other wireless device. Also, it may help to change the wireless channel your Sonos system is using.

Take a look around and in between your Sonos units for any third party wireless device. Common sources of interference include cordless phones, wireless cameras, wireless baby monitors and the like. Try moving any such device away from your speakers and see if things improve.

If you're still getting audio skipping, please send in a new diagnostic report and reply with the confirmation number.
No suggestion, but I have exactly the same problem. Maddening.
Userlevel 2
Badge +1
Hello Gordon, please submit a diagnostic as well and mention the confirmation number here. Thanks.
I am having the same issue, diagnostic: 7551093
I am having the same
Problem. It is driving me crazy and questioning the whole
Investment and experience.
afells,

Read the post two above yours, from Moritz M of Sonos.
Badge +1
i had this and the guys at sonos solved it for me and now works perfectly
Userlevel 2
Badge
Similar problem here, on and off for months - only sonos+spotify combo causes problems. Other streaming on the wifi works fine.

Diagnostics: 7619761
Userlevel 6
Badge +3
I am having the same issue, diagnostic: 7551093
Hello 2dimensional, I see you already have a support ticket: 170701-000150. Best would be to continue with the ticket. Let us know how it goes.

I am having the same
Problem. It is driving me crazy and questioning the whole
Investment and experience.

Hello, we'd be happy to check your system. Can send us a diagnostic and reply with the confirmation number? Here's an article explaining how to submit a diagnostic

Similar problem here, on and off for months - only sonos+spotify combo causes problems. Other streaming on the wifi works fine.
Diagnostics: 7619761

I've reviewed your diagnostic. Found a couple issue that can lead to the issue your Sonos is experiencing.
I'd like to test the different Sonos Wifi channels. At the moment your Sonos is using WiFi channel 1 to communicate with each other.
Would it be possible to test the other two WiFi channels 6 and 11 for just about 20mins each? Here's an article explaining how to change WiFi channel on Sonos.

Let us know how it goes.
Userlevel 2
Badge
Channel 11 failed instantly, channel 6 worked for about 30 minutes.
I am having the same issue: Diagnostic 7686119....please apply the patch. Regards, Rob
I enabled the SonosNet connection and it now is not skipping from Spotify. I did not have this enabled before the update and it worked fine, but I enabled it after and now it works
Hey! I am having the same issue. Soundcloud and Mixcloud work perfectly but Spotify either won't connect OR it plays the first couple of seconds of a song and skips to the next, plays the first couple of songs, keeps skipping. It's so frustrating as we bought our sonos specifically to play Spotify!! Please help? My diagnostic is 8171709. Thanks!
kt
Hi! I am having the same issue @jeff S. Diagnostic 2079351048. It's skipping songs every 30 seconds or so. It's so incredibly frustrating that we've basically given up on the service -- please let me know if you can resolve it.
Userlevel 7
Badge +20
Hi! I am having the same issue @jeff S. Diagnostic 2079351048. It's skipping songs every 30 seconds or so. It's so incredibly frustrating that we've basically given up on the service -- please let me know if you can resolve it.

Hi there,

I replied to your DM, but it looks like you have wireless interference causing some communication issues. Please start by changing the wireless channel your Sonos system is using.

It may also help to move away any third party wireless devices which might be near your Sonos speakers.
I changed the channel from my iOS app to channel 11 (from Ch. 6)... but I have both Sonos at home and at the office. I'm at the office right now. Is that all I need to do?

edit: sorry, I DM'd you back as well and meant to delete this accidental forum reply about channels but I can't find out how to delete on this forum ¯\_(ツ)_/¯
Userlevel 7
Badge +20
I changed the channel from my iOS app to channel 11 (from Ch. 6)... but I have both Sonos at home and at the office. I'm at the office right now. Is that all I need to do?

edit: sorry, I DM'd you back as well and meant to delete this accidental forum reply about channels but I can't find out how to delete on this forum ¯\_(ツ)_/¯


You'll need to change the channel while connected to the system with the skipping. Give that a shot, and send along a new diagnostic report if any issues continue.
Same issue Diagnostic confirmation number is: 957976980
Userlevel 7
Badge +20
Same issue Diagnostic confirmation number is: 957976980

Thanks for sending in the report. There are wireless communication errors between your Sonos components. Most of the time this is caused by wireless interference. Please try changing the wireless channel your Sonos system is using and see if that helps.
Im having the exact same.problem. sometimes spotify will play one full song then skip a bunch. Diagnostic code:1200787357