Answered

Spotify problem

  • 19 April 2019
  • 2 replies
  • 224 views

Hello. I have several Play 1 speakers and only having trouble with one of them. It can't play music from Spotify. It says the internet speed is to slow which it definetely isn't. It only plays the first few second of a song and then it skip the song entirely and start the one after repeating the process.
Would be very thankful for any tips!
icon

Best answer by Keith N 19 April 2019, 17:13

Hey there, aronluthman. If this is happening with one speaker, it seems like the speaker is having a hard time maintain a strong connection to the network compared to the other Sonos speakers. While some playback can work (TuneIn Radio might work with no issue, for example), Spotify does require a little more robust of a connection. That said, if you take that speaker and move it physically closer to the router, do the issues persist?

Do you have any Sonos devices plugged into the network via Ethernet cable? You may want to check out this helpful article that explains the difference between using a wireless and wired setup.
View original

2 replies

Thank you for the quick response. That solved it. I thought the connection was good enough since it was closer than other speakers but it was enough to move it 1 meter and it works flawlessly.
Userlevel 7
Badge +19
Hey there, aronluthman. If this is happening with one speaker, it seems like the speaker is having a hard time maintain a strong connection to the network compared to the other Sonos speakers. While some playback can work (TuneIn Radio might work with no issue, for example), Spotify does require a little more robust of a connection. That said, if you take that speaker and move it physically closer to the router, do the issues persist?

Do you have any Sonos devices plugged into the network via Ethernet cable? You may want to check out this helpful article that explains the difference between using a wireless and wired setup.

Reply