Spotify playback problems, skips songs


Occasionally when listening to Spotify playlists through my Play 1, tracks will pause and sometimes skip to the next one before they've ended. Is this a wireless issue, a firmware problem or some other issue? How can I overcome it, because it happens enough to be annoying. Thanks!

16 replies

It’s usually a network issue. If a connection is interrupted the queue steps over to the next song in the playlist.

Are you running all your speakers over your routers own WiFi, or do you have at least one Sonos device cabled to your local network/router?
Thanks. There's only 1 speaker and yes, it's to the router's wi-fi. I don't have any devices cabled.
A couple of things to try ... sometimes your routers 2.4ggz WiFi channel can be the same as the one used by your neighbours router, or the same as your SonosNet channel.

I would start by going into your routers configuration pages and find out what channel you are using. Then check your SonosNet channel in the Sonos App under the Advanced Settings section. I would set them at least five channels apart. So if your router is on channel 6, then set the SonosNet channel to either channel 11 or 1.

If that doesn’t help then try a different router WiFi channel.

Other things you can try ...

In Advanced Settings, set the audio compression to 'compressed'.

Make sure your speaker is at least several feet away from other wireless devices, including dect cordless home phones and your home router too.

If problems continue after doing these things, then you can Submit a Sonos System Diagnostics, post the reference back here and then Contact Sonos Support via Twitter etc. to ask them to take a look at your Sonos setup. The staff may be able to make some further suggestions to then improve your WiFi connection.
Thanks again. I couldn't find anywhere in the settings to view or adjust the channel. As previously I only have 1 speaker and it's on wi-fi.

I changed the audio to compressed so we'll see how that goes. Thanks again.
Can’t change SonosNet WiFi Channel? I’m not sure which controller you are you using?
But see if this helps...

On iOS or Android: From the More tab, select Settings > Advanced Settings > SonosNet Channel
On Mac: Select Sonos > Preferences > Advanced > SonosNet Channel
On PC: Select Manage > Settings > Advanced > SonosNet Channel
Update. Changing to "compressed" didn't work.

There's no option for SonosNet in the advanced settings.

Sonos Controller for Mac V8.6.
Try a different router WiFi channel... then if that fails go down the diagnostic submission route.
Normally the SonosNet channel dropdown is shown just above the audio compression control in the Advanced Settings. See screenshot. It’s odd that yours is not showing on your MAC?
Mine...
Yes, I see what you mean. I’ve not seen that before where the channel is not showing. Have you tried updating to the new version 9.0 of the App and firmware that came out yesterday?
Userlevel 7
Badge +20
Mine...

Hi Iuvyawork,

Thanks for posting the photo. The option to change your Sonos system's wireless channel is only present in the BOOST configuration (meaning that you have at least one Sonos unit connected to your network with an ethernet cable). If you send in a diagnostic report from your Sonos app and reply here with the confirmation number I can check things out for you.
Hey man, you might want to check out this video/tutorial about improving the wireless environment for your speakers: https://support.sonos.com/s/article/3286

Since you're speakers are running on WiFi mode it's important that the wireless communication between you router and your speakers is good enough to keep the music playing.

There are a quite a few things to take into account but making sure that your speakers aren't too far from your router is a good first step. Things like cordless phones & baby monitors can interfere with the wireless communication if they're close to your router or Sonos equipment. Using a clearer wifi channel helps too, as per the previous comments.

If you're completely stuck you might want to reach out to Sonos on Facebook/Twitter. They can take a diagnostic report and check the communication between your router & speakers, and maybe make some suggestions for improving it. Hope this helps.
@Jeff S. Done. Number is 128961741. Thanks for checking in.
Userlevel 7
Badge +20
@Jeff S. Done. Number is 128961741. Thanks for checking in.

Thanks for sending in the report. Your wireless environment looks okay. I do see that there are periodic DNS errors when your Sonos system tries to connect to Spotify. Usually rebooting your router and Sonos speaker helps with these types of errors by updating the network information and DNS server setting.

If that doesn't do the trick you might try updating the DNS setting on your router to use a public DNS server such as GoogleDNS.
Thanks @Jeff S. I'll try the reboots though have done this on a few occasions for other reasons and this problem persists.

I'm not too techy and don't know what I'd have to do to update DNS settings or whatnot, and what affect that might have on other things.
I have been struggling with this issue for weeks and finally called Sonos for help.

With the help of the tech, we discovered that the issue was interference. My main speaker (wired to my router) was about 6 inches from the router. Sonos recommends having the speaker be at least 3 feet from the router (which I did not know). We also changed the channel from 1 to 11 as the majority of devices on my network were on channel 1. It took 45 min to run through the diagnostics but it has been running without issue ever since.
Try moving your speakers away from other devices so its not fighting for bandwidth on channels. Hope that helps.

Reply