Question

Spotify & playback buffer

  • 20 October 2019
  • 22 replies
  • 184 views

Badge

For a while, I have received this message whenever playing SPOTIFY… “Unable to play ‘X SONG’ - network connection speed insufficient to maintain playback buffer.”

I do not receive the message when using other streaming services on Sonos. It does not matter if I’m using the Sonos or the Spotify app, it always happens.

I have been on the phone a few times with Sonos and been unable to find a solution. I believe at one point they asked me to plug my speaker directly into the router...then I lost my phone connection with Sonos support and have not had a chance to call them back (I hate they don’t have weekend hours).

So, I completed the experiment on my own. I have a Play:5 (Gen 1) in my living room, and my Spectrum modem and router live in the utility room in my basement. I took the Play:5 to the basement, connected it directly to the modem, had to reset the Play:5, then had to connect the Play:5 to the router’s wifi network (as opposed to the Eero network I use with all my other devices), and finally got the Play:5 up and running. The Spotify buffer problem occurred almost immediately.

So, I submitted two diagnosis reports: 1706778632 and 1558610590,

Since the problem happened again, here in the basement, I’m assuming that plaster, metal, etc between floors, and the wifi interference that this could cause, are not the problem.

We also have a Playbar in the basement, in the “mancave” next to the utility room. We almost never use Spotify on the Playbar, but I am currently trying to replicate the issue here for good measure. So far, the buffer issue has not happened on the Playbar.

Can someone from Sonos check out those diagnosis reports and weigh in please?

((Side question...should I consider getting a Sonos Boost? If I understand correctly, it creates it’s own wifi network for Sonos devices, eliminating interference issues from other wireless devices?))


22 replies

Badge

Just an update...the Spotify buffer issue just occurred with the Playbar in our “mancave.” So, now we’ve replicated the issue on both our devices.

adamads,

 

This would be my suggestion...

 

If switched on, turn off the WiFi on the ‘other’ router in the basement, as it’s not required… stick with your eero WiFi network and wire a single Sonos device to its main hub. Set the SonosNet channel in the Sonos App “Settings/System/Networks” so that it is at least 5 channels away from the eero 2.4ghz channel.

When All devices are up and running on SonosNet (see note below), goto Sonos App “Settings/System/Network/Wireless Setup” and reset/remove your WiFi credentials, as they will no longer be required whilst running your speakers on SonosNet.

NB you will be able to check that your Sonos devices are all running on SonosNet by navigating to “Settings/System/About my Sonos” and in the device list you should see WM:0  next to each one of your devices in the list.

Then try playing tracks from Spotify and see if that has resolved your issue.

Badge

Thank you, Ken_Griffiths, I appreciate the reply.

I turned off the “other” wifi from the router. 

I see that SonosNet is on channel 11 and I did a wireless diagnostic to find that the eero 2.4ghz channel is set to channel 1.

I looked in my Sonos settings and see “WM:0” next to each device listed.

I did NOT wire one of my devices directly to the eero main hub though. I do have one eero plugged directly into the Play:5. 

The problem persists. (Do I need SonosNet, or can I run directly on wifi?)

There’s no harm in trying that, I guess. This link explains how to switchover your system to WiFi and vice versa …

https://support.sonos.com/s/article/3209

Badge

Okay, we’ll see if that helps, but I’m not feeling too optimistic. :)

And Ken, can you explain if there is any merit to trying a Boost? Does that create a wifi network separate from the one Eero creates? So, no other devices would use the network the Sonos is on?

If anyone has other suggestions, I’m all ears!

By wiring a Sonos speaker to your main eero hub it creates a SonosNet signal that all the Sonos devices will connect to. You really only need a Boost if you don’t want to use a speaker to perform that role.

Badge

I see. Unfortunately, my main Eero hub sits next to the router in my utility room.

Thanks for the information, Ken, you’ve been very helpful!

I see. Unfortunately, my main Eero hub sits next to the router in my utility room.

Thanks for the information, Ken, you’ve been very helpful!

You could try ‘temporarily’ wiring a single speaker to the hub in the utility, just to check if it works for you and then go onto get a Boost afterwards to put in place of the speaker. No point getting the Boost if it’s not going to resolve your issue, so try with the speaker first wired to the main hub.

If this problem occurs when the player is hardwired to the router then it’s not a wireless issue.

If other services work fine then it’s not a local IP address problem.

On the face of it the problem is at the Spotify end or between Spotify and the home. Some years ago when I used Spotify I discovered that it would periodically randomly assign a server in some other country, sometimes a long way away. (I ended up playing some router tricks to redirect such outbound connections.)

Badge

Ugh, just happened again, so I submitted another diagnostic: 168333073.

I’m currently running “wireless.” The “extra” wifi network on the router is still turned off, running off the network created with the Eeros.

Will plug the Play:5 directly into the modem, again, to try to create a stronger connection. But aaaargh.

Badge

@ratty thank you for your response. What you describe is what I fear. If I buy new hardware, will I just have the same problem? It’s starting to look that way (since I’ve replicated the issue on the Playbar). Was trying to avoid switching to Pandora or Apple Music, since I’ve nurtured my Spotify account for so long. But running out of options...

adamads,

 

Whilst fully appreciating everything that ratty has mentioned above, you could perhaps also try the following...

 

Earlier you mentioned that your eero Network is fixed to channel 1, but is that the case for any additional eero hubs that you may have too?

Have you tried a different fixed eero WiFi channel, like channel 6, for example? ...and/or considered moving your SonosNet channel accordingly… but obviously ensure you keep the two signals at least 5 channels apart, if you do try that.

 

Also fix the DNS on the main eero device to perhaps one of the Google DNS servers 8.8.8.8 or 8.8.4.4.

 

See if that may help to resolve the issue.

I was attempting to avoid wild goose chases. If a wired device fails (and the wired connection is known to be good) then discount wireless. 

DNS failure would manifest as a failure to connect at all. 

Badge

Hello again, Ken. :)

I haven’t figured out how to change the channel on the eero. I’m guessing it’s on channel 1 based on a diagnostic report I ran...but I don’t see how to change it. I’ll figure it out, and see if it helps.

Also, I spent many hours on the phone with Sonos. Sometimes the call would drop out (I have a weekend home I go to in the country, not the strongest phone signal...but super strong wifi ironically). Anyway, one of the times the phone dropped, the Sonos technician had said “maybe it’s a DNS issue.” But we never got back to it. So, maybe there’s something there. I’ll do some research to see if I can figure out how to do that. Will keep you posted!

Badge

Welp, just changed the DNS to 8.8.8.8 and the problem immediately happened again. Oy vey. I’m resetting eero back to it’s ISP DNS default setting.

I did look within the Spotify forum, and found little help there. I completely wiped my phone of Spotify and cleanly reinstalled it. Didn’t help either.

The errors happen so often now, it’s super painful. I’m plugging my living room eero back into the play:5. I’m hoping that at least decreases how often the problem happens.

The “network connection speed insufficient ...” message suggests packet loss or complete connection failure. There are multiple potential culprits, including router errors.

There was mention of a “modem and router”, as if these were separate devices. If so, and the Eero is in its default configuration as a router, what happens if the primary Eero is connected directly to the modem? Alternatively, if the main router remains in place what happens if the Eero is switched into bridge mode?

(NB: do not dispense with the main router and switch the Eero to bridge mode at the same time, as this would expose everything to the internet.)

Badge

Ah, interesting. They are indeed separate devices. I’ll look into this next! Thanks @ratty, I’ll update you.

Btw, what does “NB” stand for? I’ve seen it used elsewhere in this forum.

Btw, what does “NB” stand for? I’ve seen it used elsewhere in this forum.

Nota bene

Badge

So, I put the eeros into bridge mode and struck out.

I tried plugging the primary eero directly into the modem (it was plugged into the router), and couldn’t get a wifi connection at all. I’m probably doing it wrong, might have to research how to make the eero’s work this way, but another strike out for the moment.

I sure hope you put the Eero back into router mode before connecting directly to the modem. 

Badge

Yes, I actually tried to connect the eero to the modem first, didn’t work, connected the eero back to the router, and then tried bridge mode.

Badge

So, I managed to get the Eeros hooked up directly to the modem, eliminating the extraneous router. Things are better, but still have the buffer problem occasionally. Any other tricks @ratty ?

Reply