Spotify loads playlists but won't play, says "Connection Lost"


Badge +1
Having problem connecting to spotify. All other services work fine. Spotify loads playlists etc, but when attempt to play says connection lost. PLEASE HELP!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

38 replies

Same here.
Userlevel 2
Badge +1
Hello George, Tara,

We have had no outage reports yet. Spotify seems to work via Sonos.

Could you please power cycle your network, meaning rebooting all Sonos speakers and your router and try again to start playback from Spotify?

Let me know if it still fails.

Thanks,

Moritz.
Seems to be working again now.I am very dissapointed in this tho.for the cost of the equipment.then price paying for spotify,would expect to be perfect.yet always read and experience issues.but for now alls good.
Userlevel 2
Badge +1
Seems to be working again now.I am very dissapointed in this tho.for the cost of the equipment.then price paying for spotify,would expect to be perfect.yet always read and experience issues.but for now alls good.
Hi Tara,

We have had some issues with Spotify in the past indeed, we keep improving the reliability contentiously. I would recommend to have a look at the service outage panel on our support site, www.sonos.com/support, if it happens again, fingers crossed it won't.

Thanks,
Moritz.
Badge +1
Spotify still a mess on Sonos for me.  Sometimes starts up fine, other times I have to reload song multiple times before it finally starts working,  I can load spotify playlists quickly - they just won't play (connection lost error)  for up to several minutes.  

All other services work with no problem, and Spotify works fine too ONCE IT FINALLY STARTS

I have to wonder whether this is a spotify effort to drive their paying customers away from Sonos and onto CONNECT?  

In either event, this is obviously NOT a bandwith, DNS, IP, WIFI channel, or any other network problem on my end.  I've rest everything and submitted diagnostics, all with no effect.  

Anyway, spotify started up pretty well this morning, but as expected took multiple efforts to get it to play tonight.

Sonos, if you are listening, your relationship with Spotify is hurting your brand name, and it isn't too great for Spotify either in my humble opinion.
Badge
I am having the same issue with Spotify. It's been ongoing and really annoying. All other forms of music (pandora, xm radio, etc) work fine via Sonos. Spotify works fine when not connected to my Sonos system. Please let me know what is being done to resolve this issue. This isn't a connection problem and a reset or restart is not the "fix all" for things like this. I have done that multiple times and it doesn't change a thing. I completely agree with George above. You must work out the kinks with Spotify. Please keep us informed as to how are going to resolve this issue. Thanks, Eric
I've just reset my Sonos box and it skipped the 3rd track I listened to, the same message 'the connection to Spotify was lost'

Why can't the Sonos box at least buffer the track I am listening to ????

I listen to music to relax, not be annoyed by the inadequacy of the Sonos products. I shall just put a CD on in the future !
 
Latest diagnostic :  3952670
I have been unable to play Spotify for nearly a month now. Same message others are seeing. Unable to play file ____ the connection to Spotify was lost. Repeat about 200 times and that is my experience via Sonos. Meanwhile I can bring up the Spotify desktop client or play on my phone or play from any other music source and everything works fine. Please help diagnose what is going on.
I have the same problem with Spotify and it's really annoying...
After 6 months of trouble free listening, I am now getting this same error message - EXTREMELY FRUSTRATING !!!!!!  I have submitted diagnostics - no. 4316089.  Help Please!!!!
Started having the samer problem yesterday. Keeps losing connection after a fgew seconds of a song. I am not a techie. What can I do?
Started having the samer problem yesterday. Keeps losing connection after a few seconds of a song. I am not a techie. What can I do?
I am getting the same message- it is driving me crazy!!!  works sometimes - drops songs.  then says connections to spotify lost.  
I too am having the same issue as the people above. I have had great experience with sonos and spotify up until this point. This is extremely frustrating, and I cannot imagine continuing to recommend sonos to others or adding to my system of this problem is not resolved
This is ridiculous!! This issue seems to be going on for 6 months now... this needs to be fixed!!!!
Got Sonos a week ago. Worked with Spotify for all of one day and have since had this same error. It's infuriating and unacceptable. I suspect it's yet another Spotify problem (not Sonos), but I don't know where else to go! Ugghhh.
Just adding my complaint to the list, I guess. Same "No Connection" message re: Spotify on the SONOS app, yet Spotify has no issues on its own. Waiting for more help than the standard "Reboot your entire system" again.
I have the same problem. I have reported this to support but they did not respond. Has anyone found a solution, its disappointing to see the age of this thread with no obvious solution .
Userlevel 7
Badge +26
I have the same problem. I have reported this to support but they did not respond. Has anyone found a solution, its disappointing to see the age of this thread with no obvious solution .

Hi Tony, if you've emailed the support team we'll be in touch there soon. Generally speaking, this sort of behavior is caused by network trouble or some excess latency. I'd be happy to take a look with you here. Can you submit a diagnostic from your Sonos system and reply back with your confirmation number?
I have the same problem. I have reported this to support but they did not respond. Has anyone found a solution, its disappointing to see the age of this thread with no obvious solution .

Hi Tony, if you've emailed the support team we'll be in touch there soon. Generally speaking, this sort of behavior is caused by network trouble or some excess latency. I'd be happy to take a look with you here. Can you submit a diagnostic from your Sonos system and reply back with your confirmation number?



Diagnostic number is 5589654.
Userlevel 7
Badge +26
Thanks for the diagnostic. Have you tried removing your Spotify account from Sonos and adding it back in?

There are some connection errors as well which could be causing this issue. Those might be resolved by a reboot of your router, but most likely you'll want to work with one of our technicians live. It'd be a good idea to give us a call on our support line.
I have rebooted the router several times and removed and reconnected spotify several times. I raised a support ticket but got no response and I called support but was put on hold for 30 mins so gave up.

It would be helpful if you Could provide suggestions on the thread as it might help others.
I am having the same problem with my system. I have tried rebooting. Setting up from scratch. Eliminating both Spotify accounts. Nothing works. iTunes works fine and streams without a problem, but Spotify does not. Please help.
My problem was due to the fact I was using a different DNS setting in the router. I now use a superset router for my sonos and all works great.
I'm not sure the DNS setting is the problem, as I am using the same router-just moved the Sonos from one room to another