spotify keeps stopping or jumping tracks


I have a Play5, Play1, and also a Connect hooked into my Bose Home Cinema, it's all been working fine until recently when the connection to spotify kept getting lost. It gives various messages on the android samsung galaxy tablet controller, sometimes saying just connection was lost, other times it says something about insufficient bandwidth to maintain buffer, but a recent speedtest check shows my download speed to be around 7mbps so that should be more than plenty to stream spotify premium. As I said, never had this problem before but recently it's just started.

Annoyingly w had Sonos playing at our BBQ recently with Spotify playing on the speakers outside and it kept cutting in and out then stopping completely. Ended up putting a CD on... Based on that quite a few friends commented that they weren't very impressed with the system and it put them off buying it when I had previously highly recommended it and was looking forward to showing them what it could do at the BBQ... 😞 Please help get my system working like it used to and restore my faith in Sonos!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

Userlevel 7
Badge +20
I have the same issue with my system. I always assumed it was because Spotify was syncing on another device but I disabled all other devices and I'm still running into the issue. Sonos will stop playing from Spotify queue and return to top of the queue. Or sometimes tracks are skipped over. I submitted a diagnostics report if someone could take a look and let me know. Thanks!

Diagnostics Report: 6150512


Hi MJames,

The error in your diagnostic is due to an account stream limit. If you've turned Spotify off on all of your devices, I'd recommend changing your Spotify password. Then, remove Spotify from Sonos and add it back.
Thank you!
I'm having the same issue with Spotify skipping, but other streaming services such as Pandora play without issue. I am familiar with monitoring channels and check it frequently. I currently have Sonos on Channel 11 and my Mac wireless diagnostics scan indicates no other devices are on that channel currently.

I submitted a diagnostics report: 6165944

Please help!
Userlevel 7
Badge +20
I'm having the same issue with Spotify skipping, but other streaming services such as Pandora play without issue. I am familiar with monitoring channels and check it frequently. I currently have Sonos on Channel 11 and my Mac wireless diagnostics scan indicates no other devices are on that channel currently.

I submitted a diagnostics report: 6165944

Please help!


Hi Chris_275,

There's quite a bit of wireless interference showing which is causing communication errors between your Sonos units. Spotify streams at a higher bandwidth than does Pandora, which is probably why you don't have issues playing Pandora. It doesn't look like there's another wireless network on the same channel as your Sonos units. There may be another source of interference nearby.

Common sources of interference include cordless phones (especially DECT phones), wireless baby monitors, wireless security cameras, wireless TVs and wireless printers. If any such device is near your Sonos units, please move them away from your Sonos units or power them off to see if that helps.
hi, i have moved the Sonos base as far away from other devices as the cable will allow and tried using all the different channels but spotify still stops abruptly when playing through sonos.
Diagnostics number: 6675984
Please take a look for me?
Hi dap23, welcome to our Sonos community! Thanks for submitting the diagnostic. We've noticed a couple errors on the report, can you provide some further information?


One error we're seeing is a stream limit in Spotify. Do you know if your Spotify account may be in use on another device or system away from your home?


We're also seeing an issue with connectivity to your router. Has the router been rebooted recently? If not, can you reboot it (unplug for at least 30 seconds), try playing audio from Spotify, then, if it doesn’t work, submit another diagnostic and post the confirmation code here?
Tried that and its still happening. Re-submitted diagnostics 6685960
Thanks for submitting the additional diagnostic, dap23. I'm still seeing a stream limitation error on the report. Spotify limits their service to one stream per account at a time. This may be referring to another instance of your Spotify credentials being used in another location, possibly another Sonos system or mobile device. Do you know if your account credentials may be logged in somewhere else other than your primary Sonos system?
Spotify stops playing. I just submitted diagnostic report 6730332.
Userlevel 7
Badge +20
Hi, Spotifonos. The issue is due to your network configuration. I can see a minimum of 8 extenders / access points which look to be configured incorrectly and are not resolving the DNS. For you, it'd be best to give us a call.
Hi All,

Just thought I'd try and help out everyone. I don't own a Sonos myself, but a quick search on Spotify's support forums will show you that Spotify cutting out is very common no matter what stereo system you've bought. I never had any issue with Pandora though. Some fixes that have worked for others are turning off your devices bluetooth, (somehow it interferes with wifi?) or changing the streaming quality down within Spotify or the devices settings. My best bit of advice though is to ditch spotify if you find something better. I've seen this issue with Spotify for 2 years now but unfortunately my wife refuses to move away from Spotify. Best of luck!
Been having the same issue - only seems to happen with streaming audio. Did all the checks and changes I have seen in previous posts. Changed channel (seemed to help a little bit but hard to measure), internet check and speed all good (16 MB/s or above) . Have a Boost as well. Even upgraded to a newer router that has greatly expanded and strengthened by wifi signal. Some of the sonos items are hardwired (when I can) but most are wifi (issue happens across the board though). Have several products from ones, 3, 5, bar, sub, connect amp

Submitted diagnostics .#8381772