spotify keeps stopping or jumping tracks


I have a Play5, Play1, and also a Connect hooked into my Bose Home Cinema, it's all been working fine until recently when the connection to spotify kept getting lost. It gives various messages on the android samsung galaxy tablet controller, sometimes saying just connection was lost, other times it says something about insufficient bandwidth to maintain buffer, but a recent speedtest check shows my download speed to be around 7mbps so that should be more than plenty to stream spotify premium. As I said, never had this problem before but recently it's just started.

Annoyingly w had Sonos playing at our BBQ recently with Spotify playing on the speakers outside and it kept cutting in and out then stopping completely. Ended up putting a CD on... Based on that quite a few friends commented that they weren't very impressed with the system and it put them off buying it when I had previously highly recommended it and was looking forward to showing them what it could do at the BBQ... 😞 Please help get my system working like it used to and restore my faith in Sonos!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

I have just submitted a diagnostic FYI Sonos Support, ref 3817706.

I have also tried chaning wifi channels and compressing audio, neither have resolved the issue.
Userlevel 6
Badge +3
Hi Al,

I have a look at the diagnostic, and ran into a couple of problems within the SonosNet and your network.

First let's focus on the SonosNet. The system is experiencing a high level of wireless interference this can be easily solved by changing wireless channel on the Sonos system and making sure the router
is on a fixed wireless channel, also make sure no other wireless device(s) are next to the Sonos units including the router.

Could you follow the steps below.
If you have set the wireless channel on your Router we need to get a diagnostic per channel option in Sonos.
It is important to keep the router and Sonos channels apart, so if Sonos is at 1, the router should be at 6 or 11. And if Sonos is at 11 the Router should be at 1 or 6.
For each channel, please wait 5 minutes and then submit a diagnostic of your Sonos system and then reply to this thread with the three different diagnostic numbers.Here is a link showing you how to submit a system diagnostic
To change to the wireless channel go to: If you are using the Sonos CONTROL, please follow the steps below:

1. Press the Music button to go the Music Menu.
2. Select System Settings -> Advanced Settings.
3. Select Wireless Channel to change channels.

If you are using the Sonos Controller for PC or MAC, please follow the steps below:
1. Select File -> Preferences  (Sonos -> Preferences on the Macintosh).
2. Go to the Advanced tab
3. Select Wireless Channel to change channels.

Let me know how it goes.
Thanks,
Max
Userlevel 2
exactly the same problem here. I switched to the wireless option so my bridge is out of the system and still spotify will jump to the next song or just stop. I submitted my diagnostics ref nr: 4045215 
Hi,

I have a similar issue. Submitted my diagnostic ref: 4888857. Please assist. Thanks
Userlevel 2
Hi. I have the same issue. Lots of drops and stops. Issue no: 4922862

I have 2 play:5, 1 play:3, 4 play:1, sonos:amp, sonos:connect and sonos:boost
I am having the same problem. It seems to be with Spotify only. Does not happen with Pandora. I have tried all three channels with no improvement. My diagnostic #4966689 on Channel 11.
Userlevel 2
I'm also having issues recently with Sonos and Spotify. I've got a Sonos Bridge, 2 Play:3's, and a Play:1. I made sure that my router and Sonos system are not on the same wireless channel, tried re-authorizing the Spotify service, rebooting my router, but nothing has seemed to improve things so far.

Spotify tracks (unlike other services, such as Songza, etc...) are having intermittent issues where the song skips (audio stops playing, and eventually it goes to the next song). If it makes a difference, I'm playing a Sonos playlist where some tracks were added from my own music library (on a NAS and those tracks play fine), and some tracks were added from Spotify (which are the ones with problems).
I have same problem... Just started recently. I have Spotify premium and it will play about 10 seconds of a track then stop. Or if I have queued a lot of tracks it just skips them all.
Playing other services like radio or Hypem works fine. Just Spotify seems to have a problem.
Userlevel 6
Badge +3
I'm also having issues recently with Sonos and Spotify. I've got a Sonos Bridge, 2 Play:3's, and a Play:1. I made sure that my router and Sonos system are not on the same wireless channel, tried re-authorizing the Spotify service, rebooting my router, but nothing has seemed to improve things so far.

Spotify tracks (unlike other services, such as Songza, etc...) are having intermittent issues where the song skips (audio stops playing, and eventually it goes to the next song). If it makes a difference, I'm playing a Sonos playlist where some tracks were added from my own music library (on a NAS and those tracks play fine), and some tracks were added from Spotify (which are the ones with problems).


I have same problem... Just started recently. I have Spotify premium and it will play about 10 seconds of a track then stop. Or if I have queued a lot of tracks it just skips them all.
Playing other services like radio or Hypem works fine. Just Spotify seems to have a problem.


Hi BigKens & conceptguy,

We'd be happy to check your system. Can you send us a diagnostic and reply with the confirmation number? Here's an article explaining how: How to Submit Diagnostic
Badge
I have the same problem. Diagnostic 5278938. Bring my Christmas music back, please ☺️

David
Userlevel 7
Badge +20
I have the same problem. Diagnostic 5278938. Bring my Christmas music back, please ☺️

David


Hi there, unfortunately when you rebooted the player the error messages associated with the problem were wiped off. Can you please recreate the issue and respond with a new diagnostic confirmation number? Thanks in advance!
Badge
Hi, Tried spotify, tunein radio and hype machine. Only spotify not working. New diagnostic 5304019

David
Badge
And spotify works fine on my pc and mobile via same network... David
Userlevel 7
Badge +20
Hi, Tried spotify, tunein radio and hype machine. Only spotify not working. New diagnostic 5304019

David



Hi, Tried spotify, tunein radio and hype machine. Only spotify not working. New diagnostic 5304019

David


Hi Schjelde,

It looks like there are some account authentication errors preventing your Sonos system from playing Spotify. Please try removing the Spotify services from your Sonos system, then try adding it back.

Please let us know if this does not work.
Badge
Hi, I must have done that about 20 times. But for you sir, one more later today. David
Userlevel 7
Badge +20
Hi, I must have done that about 20 times. But for you sir, one more later today. David

If removing and adding back Spotify does not help, please let us know and we'll create a support ticket for you. Our phone team will be able to help get Spotify up and running.
Badge
I tried again. Failed. Diagnostic: 5344432. David
Userlevel 7
Badge +20
I tried again. Failed. Diagnostic: 5344432. David

Hi David,

I've created a support ticket for you: 160107-002112. Please give us a call and reference that number. You can find our phone number and hours here.
Badge
Thanks, Jeff! Appreciate the help. David
I am having the same issues. At all the different Sonos players in my house. report #5473847
Userlevel 7
Badge +20
I am having the same issues. At all the different Sonos players in my house. report #5473847

Hi ShinyRobot09,

There's some wireless interference showing up which could explain the audio issues. This interference is causing communication errors between your Sonos units. Please try changing the channel on which your Sonos system operates, here's how.
Badge
Hi, Tried spotify, tunein radio and hype machine. Only spotify not working. New diagnostic 5304019

David



Hi, Tried spotify, tunein radio and hype machine. Only spotify not working. New diagnostic 5304019

David


Hi Schjelde,

It looks like there are some account authentication errors preventing your Sonos system from playing Spotify. Please try removing the Spotify services from your Sonos system, then try adding it back.

Please let us know if this does not work.


Hi, my problem has been resolved. It was caused by my smart DNS setup. I reset everything while on ISP dns, and after booting all players they worked again. Turned smart DNS on again afterwards without players noticing. so all works again. Until next time I reset the players while on smart DNS.
Having the same problem with premium paid Spotify but the free Pandora seems to be fine 6074262
Userlevel 7
Badge +20
Having the same problem with premium paid Spotify but the free Pandora seems to be fine 6074262

Hi SonosP,

There's quite a bit of wireless interference showing up with is likely the cause of the audio interruptions. Please make sure there are no third party wireless devices near your Sonos units. Common sources of interference include cordless phones (especially DECT phones), wireless security cameras, wireless baby monitors, wireless TVs and wireless printers.

Also, it may help to change the wireless channel your system uses, here's how.

If those steps do not help, please send in a new diagnostic report and reply here with the confirmation number.
I have the same issue with my system. I always assumed it was because Spotify was syncing on another device but I disabled all other devices and I'm still running into the issue. Sonos will stop playing from Spotify queue and return to top of the queue. Or sometimes tracks are skipped over. I submitted a diagnostics report if someone could take a look and let me know. Thanks!

Diagnostics Report: 6150512