Speakers won’t re register to Sonos account after factory reset

  • 29 September 2018
  • 38 replies
  • 22369 views

Hi, any help gratefully received. I recently factory reset my 2 Sonos Ones due to problems with the Alexa functionality. Have just set them back up again, but the app is now telling me that it can’t find any speakers registered to my Sonos account.

When I attempt to register them, after a long while of trying to link it displays a message saying “Setup problem”, asking me to check my internet connection (which is fine) and that my speakers are plugged in (which they are). It also says to check the system settings on my controller device (iPhone) to check the time and date settings are correct (which they are - just the automatic iPhone time and date).

Have checked my Sonos account on the Sonos website and it’s showing that the 2 speakers are both registered to my account (albeit showing the date of registration as the date I originally registered prior to the factory reset).

Can anyone explain to me why my speakers aren’t registering now, and how I can go about fixing the problem?

Thanks!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

38 replies

Userlevel 2

Static IP address issue for me….removed it in router and reconnected.  No issues registering Sonos 1.

Just had that problem. I spent two hours with a very nice lady on customer service and they couldn’t fixed it. I decided to factory reset my google WiFi and guess what I can register my Sonos now!

This worked for me, thanks.



I currently have exactly this problem but there doesn't seem to be a good solution in the comments. Anyone have a solution?Assuming you have already tried the things mentioned earlier in the thread, possibly switching off 'Airtime Fairness' is a solution, if that is indeed supported by your router? Otherwise more information might be required to help someone provide you with a definitive answer.
I changed my ISP and got new router (no airtime fairness function). I had problems with my sonos system thereafter so did a factory reset (which I now regret). Now, I am able to set up a new system, but when it comes to registering my speakers to my existing sonos account it doesn't work. I just repeatedly get a message saying to register my speakers but the action is unable to complete and sends me back to the initial message saying to register the speakers. This happens whether I use the iOS sonos client or the mac OS one.

Are you able to set a DNS within your router configuration pages... try the Google default servers, which are 8.8.8.8 and/or 8.8.4.4

See if that perhaps resolves the issue for you.

I currently have exactly this problem but there doesn't seem to be a good solution in the comments. Anyone have a solution?Assuming you have already tried the things mentioned earlier in the thread, possibly switching off 'Airtime Fairness' is a solution, if that is indeed supported by your router? Otherwise more information might be required to help someone provide you with a definitive answer.


I changed my ISP and got new router (no airtime fairness function). I had problems with my sonos system thereafter so did a factory reset (which I now regret). Now, I am able to set up a new system, but when it comes to registering my speakers to my existing sonos account it doesn't work. I just repeatedly get a message saying to register my speakers but the action is unable to complete and sends me back to the initial message saying to register the speakers. This happens whether I use the iOS sonos client or the mac OS one.
I currently have exactly this problem but there doesn't seem to be a good solution in the comments. Anyone have a solution?
Assuming you have already tried the things mentioned earlier in the thread, possibly switching off 'Airtime Fairness' is a solution, if that is indeed supported by your router? Otherwise more information might be required to help someone provide you with a definitive answer.
I currently have exactly this problem but there doesn't seem to be a good solution in the comments. Anyone have a solution?
Userlevel 7
Badge +21
Are you able to see the Play 1's lease in your router's DHCP page? If so then try assigning an IP address outside the DHCP address pool, if that doesn't work try one inside the pool. Some routers require one or the other so manual reading or trying each is needed. I'd assign static/reserved addresses to all Sonos to avoid future power or update related glitches. You can also give each Sonos a unique name there in most routers.

Once assigned power down all your Sonos gear, reboot the router and power your Sonos gear up one at a time at one minute intervals.
Adding to this thread, I had a brief power-outage which (for some unknown reason) stopped my Play:1 from being able to reach-out to the internet. My mobile app and Windows PC app could both contact the Play:1, but I couldn't play anything from my Spotify account.

I tried assigning a static IP address in my router for the device's hostname since this seemed to placate my Android smartphone (which was having a similar issue post-power-outage). This didn't seem to work.

I tried leaving the unit unplugged for about a day in the hope that it might be an odd DHCP-lease issue (which I believe was the problem with my smartphone). This also didn't work.

I then factory-reset the Play:1. After some on-and-off updating/troubleshooting of apps and such I was finally able to fully reset the device and reconnect to it with my apps. The final problem I ran-into was that I couldn't register the thing.

It turns out that the "Pi-Hole" I have on my network (a Raspberry-Pi computer acting as a local DNS for killing annoying ads) was completely killing the Play:1's ability to re-register to my account. I temporarily changed my router's static DNS from the "Pi-Hole" back to Google's (8.8.8.8, 8.8.4.4 for primary/secondary respectively), and the desktop Sonos app was able to register the Play:1 immediately.

Just a heads-up for anyone that stumbles-upon this thread again with the same issue. DNS problems might be preventing your product from re-registering (as was implied a few posts prior).
I spoke to customer support and resolved the issues. I had to edit my DNS Servers from automatic to manual. I also had to delete some other the other options. I had interference blocking Sonos from working properly.
Ah, that’s great. Glad you managed to sort it with Sonos Customer Care and thanks for letting us know the outcome.
I spoke to customer support and resolved the issues. I had to edit my DNS Servers from automatic to manual. I also had to delete some other the other options. I had interference blocking Sonos from working properly.
I don’t have any speakers setup. If I try to create a new account even it just tells me the email address is already in use. Even if I use an extremely unique email that I’m sure is not being used.

Device: IPhone XS
iOS: 12.3.1

Perhaps best in this case if you contact Sonos Customer Care direct to get it resolved, particularly if a factory reset has not sorted it for you.
I don’t have any speakers setup. If I try to create a new account even it just tells me the email address is already in use. Even if I use an extremely unique email that I’m sure is not being used.

Device: IPhone XS
iOS: 12.3.1
isaih_n,

Thats a real pity.
  1. So do you have any devices at all now setup in a new Sonos Household?
  2. Can you tell me what version of iOS, or Android, is running on the Sonos mobile controller device that you are using for the setup process?
All the speakers have been factory reset at this point. This was done prior to our exchange.
isaiah-n

Ok I would try this...(I’m assuming you have not factory reset any of your Sonos devices)...

Power off all devices, that is all speakers, router and modem and your mobile controller. Give it 30 seconds then power on the devices in this order (see list 1-4), but allow each and every device to settle, before moving onto the next.. If you have any wifi extenders, or repeaters, switch those off too. Also take note of my note below.
  1. modem
  2. router
  3. wired Sonos speaker
  4. mobile device... ensure the mobile is connected to the routers primary WiFi signal and not a guest WiFi network.
Note: leave any wifi extenders, or repeaters, switched off for now and all your wireless Sonos speakers. I would strongly consider using another speaker to cable to the router, rather than the one you are currently using and if possible check the Ethernet cable is working correctly ... you should see lights on the Ethernet port at both ends.

When all 4 steps above are complete, open the Sonos controller App and you should see the one and only powered-on wired speaker appear in the App. If it doesn’t appear then try another Sonos device in its place until you get it to appear. Consider using another cable too in case the original one is faulty and try a different router Ethernet port.

The initial aim is to get the one wired speaker appearing in the Sonos App.

When the above step/aim is achieved, now carry on and do this...
  • Power on each wireless speaker starting with the nearest one to the router and the next nearest and so on.. give each one chance to settle before moving onto the next device.
Each and every Sonos speaker should now reappear in your Sonos App.. if they don’t, then power them 'off' and 'on' again a second time. If they still fail to appear, then set the speaker aside and leave it powered off, for now at least.

Hopefully all, or a majority, of your speakers will reappear in your Sonos App. You may sometimes have to close and reopen the App to refresh the screen, but that’s usually not necessary.

Any wireless only speaker that fails to connect to your Sonos App after trying all these things, can now be factory reset. This is a 'last resort' step and you should not reset all your devices, maybe one, or two, only at this point.

You should now be all up and running with your system.

To now switch all your devices over to your WiFi.. goto 'Advanced Settings/Sonos Settings/Wireless Setup' in the Sonos App and enter your routers main WiFi credentials for the 2.4ghz band. Note: the credentials are case sensitive.

After 30 seconds, or so, you can then un-cable the speaker from your router and move it to where you want to. All Sonos devices should now be up and running on your WiFi signal.

You can now turn back on any WiFi repeaters, or extenders, if you have those, but if they are using the same WiFi SSID and password as your main router, then I recommend you ensure they are running on the same wifi channel(s) as your main router WiFi.

Sorry for the long winded post, but I’ve tried to cover things for you step by step.

Hope the above works for you and gets you back up and running.
I moved to a new house with a new router. I went from modem/router combo to separate modem and router. Initially when I plugged all the speakers in, they would play but I couldn’t play it using the Sonos app on my iPhone X. They only worked using my streaming service (Tidal). Since I cannot edit room settings or separate studio pairs. I then tried to reset the router. I tried to reboot. I did a hard reset. I’ve connected a speaker using an ethernet cord but once the speaker connects, it says I have no speakers registered. Almost everything I’ve done asks me to login and that’s where my issue is. I can not login. It tells me that I have a network error. I’ve checked to ensure that I’m on the same network. Still nothing.


I had the exact same problem, with the ethernet cable I resolved it, ThanksWhat process did you take to resolve this using the Ethernet cable?

Are you experiencing issues setting up your device after a factory reset then, or do you have another issue?

In most cases the cabling of a speaker to the main routers Ethernet port, post reset, will resolve almost all issues during install.

It’s not clear though if you are setting up a new Sonos Household, or adding to an existing one ...or what the exact issue is in your particular case.

More than happy to try to help you, if you can share some further detail?
I had the exact same problem, with the ethernet cable I resolved it, Thanks


What process did you take to resolve this using the Ethernet cable?
Have same problem, spent over an hour on phone with sonos tech support and did not get a solution. He did suggest going into router and check settings. We turned off 'Enable AIRTIME FAIRNESS ' apparently this can cause problems with sonos. Also, once in router settings, you can get ip address of you speaker and try to ping it. I cannot ping speaker, there is something in the router/internet settings that is blocking the registration. What makes this most confusing is the speaker was working last week...and nothing changed???I agree with Stanley_4, but I would have expected the Support Staff to have already tried that with you, if they were on the phone to you for more than an hour, however wiring a speaker is the best place to start. I would check both the router and controlling devices Network: DNS/Gateway/DHCP settings etc. too.

If using any WiFi extenders/adapters or powerline adapters, then I would turn those off whilst trying to get the speakers up and running on their own SonosNet wireless signal. Be sure to set the SonosNet channel at least 5 channels away from your main routers WiFi channel.
Userlevel 7
Badge +21
An easy way to sidestep many of the issues with flaky routers is to wire one or more Sonos components and move the Sonos devices to their own wireless network.
Have same problem, spent over an hour on phone with sonos tech support and did not get a solution. He did suggest going into router and check settings. We turned off 'Enable AIRTIME FAIRNESS ' apparently this can cause problems with sonos. Also, once in router settings, you can get ip address of you speaker and try to ping it. I cannot ping speaker, there is something in the router/internet settings that is blocking the registration. What makes this most confusing is the speaker was working last week...and nothing changed???
The old advice to power everything off and on again is often remarkably effective. Power down the router and everything on your network. Then power up one device at a time, letting each come up fully before doing the next, starting with the router.
I think I have some sort of network issue. This was a huge help: https://bsteiner.info/articles/hidden-sonos-interface and I am able to ping this laptop but not any external service. I just wish I knew how to solve that but I guess it's not a sonos issue per se.
antti-takalahti,

What happens if you reset your Sonos controller app in 'Advanced Settings' and then choose the option to 'connect your controller back to the existing Sonos system'?.. just make sure you do not create a new system with the controller, stick with the existing one.