Speakers keep dropping


I have recently changed my broadband provider and since then my connection on speakers is frequently dropping off. This has now gone on for over a week. Speaker and routers are all in the same location and no previous issues provided. WiFi signal is now stronger than previously and connection for working better than ever. Can someone please help?


3 replies

After changing a router you have to power off absolutely everything that connects to the network, Sonos and everything else, then power them back on. This is to clear out the IP addresses. 

If you have not done this you should do it now, then see if it is OK or if further troubleshooting is needed.

Do you have any Sonos device wired to your router?

Hi John, thanks for that. I will look to power down all of my Sonos products and then reconnect. 
 

I don’t have anything wired directly to my router, although I did have to connect both my play ones initially to get them back up and running. Thankfully didn’t have to do that with my play base as it connected remotely.

Hi John, thanks for that. I will look to power down all of my Sonos products and then reconnect. 
 

I don’t have anything wired directly to my router, although I did have to connect both my play ones initially to get them back up and running. Thankfully didn’t have to do that with my play base as it connected remotely.

Not just the Sonos - everything.  It is just good practice with a new router.  Even if everything else appears to be fine.

Reply