Answered

Speakers drop off after update if the have unique names/non-drop down

  • 5 April 2022
  • 4 replies
  • 44 views

Badge

Hey there,   

When a new update comes out and I update the system I typically lose 1-2 speakers that must be factory reset before I can add them again.

It seems to happen only to speakers that have been renamed from the pulldown/menu options you are given when you first add a speaker.

 

For example,  if I choose “bedroom” and edit the name of the speaker to “Master Bedroom” it has a chance of being dropped when an update comes out.

Am I doing something wrong when renaming or updating speakers?

I have one in the kitchen and garage that do not get dropped of the same model but kitchen and garage are options you can choose when adding a speaker.

I did not see anything in the forum with a similar problem, or perhaps I used the wrong keywords.

My planned next step is to have all speakers on a generic name and wait 3-4 months for some update to be applied and see what happens.  If there is something different I should do I am open to suggestions.

Thanks in advance!

icon

Best answer by Airgetlam 5 April 2022, 18:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

My process is a “temporary” fix of the duplicate IP address issue. Essentially the same thing, it’s just the reservation process is a more “permanent” fix. The reboot process works for now, but if duplicate IPs have happened before, it can happen again, unless you do the full reservation process. It’s an unfortunate failure on the router’s side, not the Sonos software side. Sonos just exposes it more frequently than average, because each time you run a software update, it forces a soft reboot, in which the Sonos asks for a new IP address from the router. 

Badge

Thanks Airgetlam and UKmedia.

I will follow the tips and tricks and set up reserved IP addresses as a secondary test.

When I do that I will use non-unique names at first just to keep the variables down when testing.  I will try and reply back in here to let you know how it worked out…. or if someone has a similar issue they can fix their problems as well.


 

Userlevel 7
Badge +20

As per the advice from Bruce ( @Airgetlam ).  You may want to view my post here: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

I don’t have this issue, but use several ‘unique’ names in my system for various ‘rooms’. They all show up after an update. My system is using S2 and is ‘wired’. 
 

I’m suspecting some sort of network issue here, more than an issue with Sonos’ software. Possibly a duplicate IP address issue, although that’s just a guess. I’d certainly try a refresh of your network by unplugging all Sonos devices from power, then rebooting your router. Once the router comes back up, plug the Sonos devices back in, and see if that resolves the issue.

If it doesn’t, I’d certainly recommend a diagnostic, followed by a call to Sonos support for further investigation.