Question

Speakers disappear when disabling WiFi

  • 22 February 2021
  • 7 replies
  • 83 views

Hi,

i use 5 Sonos speakers in SonosNET mode with a boost wired to the Ethernet. Additionally, i wired one of the Play:1 Speakers as well. If i do now chose to disable the radio (in the App) for the wired Play:1, all of my other speakers disappear, and only the boost and the wired play:1 is visible.

In the Network Configuration, the Boost is setup as root bridge. I understand that this device should manage the sonosnet. So disabling the radio of the wired Play:1 should not interfere. Where’s my mistake?

Maybe as a side note: The Play:1 and Boost which are wired are located right next to each other. I my idea was to disable the Play:1 radio to minimize network interferences.


7 replies

Userlevel 7
Badge +18

Whilst SonosNet is not using your wifi network, it is a wireless communication system. Set your wifi to channel 1,6 or 11 and SonosNet to a different one of the three. 

Hi. Two things puzzle me:

1 Why do you have a Boost when you could just wire the Play1?

2 I don't understand why your speakers aren't connecting direct to the Boost, as presumably they did before? 

If you power cycle them do they reconnect?

Hi let me clear some things up.

1.) I bought the additional Play:1 after I bought the Boost. I tried to substitute the boost with the Play:1, but wasn’t successful. I followed the regular procedure:

  1. Wiring both devices (Boost and the Play:1)
  2. Disconnecting the Boost

As far as I have read in the documentation, when disconnecting the Boost, the remaining (wired) Play:1 should take over the Sonosnet capability and act as a root bridge. When disconnecting, again, all other speakers were disappearing. After some tries I managed to get Sonosnet up and running with the Play:1 acting as a root bridge. With noticably worse performance than with the Boost (Network Matrix showed as best ANI Level 5). Therefore I decided to put the Boost back in. Performance is “okish” now. (No Dropouts, but not all speakers have a certainly stable connection. Some of them are pending between ANI Level 1-3 (Green) and 4-5 (Yellow). Sometimes, even 6 (Orange).

 

2.) Yeah, this puzzles me too. I powercylced the whole system, but it did not make any difference. If the only Solution is to reset all speakers, and setup from scratch I guess I have to go down that road, but like to avoid it ;)

 

€dit:
Worth mentioning the network setup:

  • UI Dream Machine as only AP
  • Radio transmission strenght set to medium (2,4+5Ghz)
  • Sonosnet Channel 6
  • 2.4Ghz Wifi Channel 10
  • Scan of nearby networks showed mostly saturation of channel 1. Channel 6 (Sonosnet) is not saturated at all (1 competing network @-90dbm), the regular Wifi (on channel 10) as well. 

As well as my Sonos Devices:

Upper Floor

  • Office : Sonos Boost, Play:1, UDM Wifi Router
  • Bedroom: Play:1
  • Bathroom: Play:1

Lower Floor:

  • Livingroom: 2x Ikea Symfonisk

Whilst SonosNet is not using your wifi network, it is a wireless communication system. Set your wifi to channel 1,6 or 11 and SonosNet to a different one of the three. 

Isnt the Play:1 which is wired using the radio for a meshnet for sonosnet? As the Boost is standing right next to it, I would guess that they might interfere each other. Thats why i tought the radio of the wired Play:1 can be disabled.

Userlevel 7
Badge +21

Channels 6 and 10 conflict, 6 and 11 or 6 and 1 would be better choices.

I have no issues with multiple wired and wireless Sonos speakers and a Boost, I did until I moved them a meter apart.

You might submit a diagnostic and post the number soon after seeing a problem so the Sonos staff can look into it.

Please don’t reset anything - it never provides a lasting solution and can be counter-productive.

I would try swapping the cables and ports for the Boost and Play:1 just to make sure there isn’t a fault in the Boost’s connection.

And you should re-enable the radio on the Play:1.

The elevated ANI levels are quite probably due to the overlap between WiFi and SonosNet. That should definitely be resolved. 

That said, an ANI level of 6 or less is perfectly liveable with. It indicates the WiFi card is doing its job.

Reply