Question

SPDIF audio delay with the new Xiaomi Laser 4k projector and Sonos playbar

  • 8 May 2019
  • 5 replies
  • 1157 views

Badge +1
Hi guys,

I had a quite complex setup with an old panasonic plasma TV (it didn't support passthrough) connected to an HDMI switch with Toslink output (to Sonos 5.1 with Playbar) and some players as inputs (Kodi in RPi, Apple TV 4th ge, fire Tv,...) . Last week I received my new Xiaomi Mi Laser 4k projector with MIUI TV soft inside, and I have to change the whole setup.

At this moment I have a new Apple TV 4k connected directly to the projector, and from that, audio connected to Playbar via Toslink. Tests:

With the projector as the source/player and configured to send "raw" audio via toslink, when I play something local or remote (from a NAS) using the projector, I get perfect audio (DD5.1). No occidental streaming apps like Netflix or Prime Video in MIUI TV soft, so I can't test streaming.

With the Apple TV 4k as source and configured to use DD5.1 and projector configured to send "raw" audio via toslink:, when I play a remote (from NAS) video or streaming app using Apple TV, I get DD5.1 but there is an audio delay (1seg approx). With Apple TV 4k configured to use stereo and projector configured to send "raw" (or PCM, it doesn't matter) audio via toslink, I get stereo sound without delay.

I was surfing the web looking for a way to set up a video delay in MIUI TV (xiaomi modified Android TV). No success. I played with different apps/configurations in AppleTV, but I´m quite sure delay is produced by the projector, while processing its HDMI input to extract audio and send it to Playbar via toslink.

I have just ordered a new HDMI 4K switch with audio output... :(

Any other suggestion?

5 replies

Userlevel 7
Badge +21
Does the PJ have "game mode"? That reduces delays caused by video processing. Assuming the audio is coming "first". If the video is coming "first" then I have no idea. Mind you 1 second seems way too long for any kind of processing.
Badge +1
Does the PJ have "game mode"? That reduces delays caused by video processing. Assuming the audio is coming "first". If the video is coming "first" then I have no idea. Mind you 1 second seems way too long for any kind of processing.

Audio coming later, video first... Well, I think it isn't a second, maybe half a second. But any case it's an important one, not a light lips sync problem. Later I will check game mode, and also test the new 4k HDMI switch if it arrives today.
Hi, I'm experiencing the same problem. Have you got a solution for this yet?
Appreciate any help.

Thanks

Hi, exact same issue for me. No issue with playing movies on Infuse but some of the App give me this annoying 1s sound delay. It works when I set stereo mode on the Apple TV.

 

I have the Xiaomi Mi projector (Chinese version), Apple TV 4K and Playbar/Play3/Sub.

I have exactly the same issue - would be great to know if any solutions are out there? 

Reply