Answered

Soundbar is not recognising optical output from LG 65 E6T Oled

  • 18 October 2017
  • 6 replies
  • 9575 views

We recently purchased an LG Oled 65inch E6T, have had it installed and all seems to be working ok - however we have just bought a sonos soundbar to use with the TV unit, and unfortunately the Sonos keeps saying there is no signal coming from the TV's optical output and therefore, will not play sound from the TV.
I also have a 55 inch LG oled & a 42 inch pioneer plasma that we have tested the soundbar on and it works fine on these - unfortunately I don't have another device with optical output (that's easy to move) to plug in to our 65 inch, but the soundbar seems to work perfectly on the other TV's. I have made sure all the settings on the TV allow for optical output to the soundbar. The only thing I can think of is that this TV (and ideally the soudbar) is in an outdoor studio and the doesn't have at present have a wifi connection to our internet (it is out of range at present and too far from the modem for an ethernet connection). We have obviously set up the soundbar inside with internet connection and I can't see why the soundbars lack of Internet connectivity would have an issue with an optical connection to the TV. Can you please advise if this is a technical issue with the TV or the soundbar.... any help would be appreciated!
icon

Best answer by Airgetlam 18 October 2017, 02:15

It's not the location that's the issue, it's the signal being sent by your LG (and possibly the things connected to it). You've checked to make sure the Sonos is working properly by connecting it to other TVs, so now you just need to focus your attention on the TV. Go in to the Audio settings for the TV (I don't own one, so this depends on you, and the manual for it) and make sure everything is set to be Dolby Digital, and nothing other than that. Not DTS, not Dolby Digital Plus, just Dolby Digital.

While you're in the TV's audio settings, you may want to check to see if they have a setting to turn on or off the optical output. Some TVs do, some do it automatically when you turn off the speakers, some have it on all the time and there's no option to do that. And if there's a setting in that location that allows you to switch between Fixed or Variable, make sure it's set to Fixed.

Then go in to all the devices that are connected, and do basically the same thing. Make sure that they're all set to Dolby Digital as well. This may be a problem for BluRay players, some of them don't have the option, and you have to either set it when you're watching a specific disc, or replace the BluRay player with one that does downmixing, as most BluRay discs are actually DTS, which can't be read by the PLAYBAR. There's a long thread in the Home Theater area of this board regarding which BluRay players actually can do downmixing.

Once you've done all this, you should be getting the necessary sound from the PLAYBAR.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

It's not the location that's the issue, it's the signal being sent by your LG (and possibly the things connected to it). You've checked to make sure the Sonos is working properly by connecting it to other TVs, so now you just need to focus your attention on the TV. Go in to the Audio settings for the TV (I don't own one, so this depends on you, and the manual for it) and make sure everything is set to be Dolby Digital, and nothing other than that. Not DTS, not Dolby Digital Plus, just Dolby Digital.

While you're in the TV's audio settings, you may want to check to see if they have a setting to turn on or off the optical output. Some TVs do, some do it automatically when you turn off the speakers, some have it on all the time and there's no option to do that. And if there's a setting in that location that allows you to switch between Fixed or Variable, make sure it's set to Fixed.

Then go in to all the devices that are connected, and do basically the same thing. Make sure that they're all set to Dolby Digital as well. This may be a problem for BluRay players, some of them don't have the option, and you have to either set it when you're watching a specific disc, or replace the BluRay player with one that does downmixing, as most BluRay discs are actually DTS, which can't be read by the PLAYBAR. There's a long thread in the Home Theater area of this board regarding which BluRay players actually can do downmixing.

Once you've done all this, you should be getting the necessary sound from the PLAYBAR.
thanks for that - i'm not sure the TV allows me to individually select Audio sources....may be the issue! I found this on there online user manual - If set to Auto the search order is HE-AAC → Dolby Digital Plus → Dolby Digital → MPEG and output is produced in the first Audio Format found.
The following search order may change depending on the country: HE-AAC → Dolby Digital Plus → Dolby Digital → MPEG.
If the selected Audio Format is not supported, another Audio Format may be used for output.
This function is available on certain models or in certain countries only.
I'll see how it goes 😕
It was ultimately an issue with it being defined as Dolby Digital only. The TV's sound by default is set to Auto which allows all forms of sound output including DTS, so in the sound settings it needs to be ONLY Dolby Digital that is set, otherwise it wont work through the soundbar....just a tad annoying...but very glad it now works.
I am having the same problem with the LG OLED 65C8. How did you get the Sound Out setting to be Dolby Digital? All I see is AUTO or PCM under the following menu:

Settings | Sound | Sound Out | Optical | Digital Sound Out
I am having the same problem with the LG OLED 65C8. How did you get the Sound Out setting to be Dolby Digital? All I see is AUTO or PCM under the following menu:

Settings | Sound | Sound Out | Optical | Digital Sound Out


I was having a similar issue with LG OLEad 65" B8 and Dolby Digital Plus 5.1 output on an Onkyo A/V Receiver. After trying couple things and trying several HDMI cables, it seems that unplugging the TV from power and turning it on again fixed the problem. Now Auto works besides PCM. I'm not sure if the output is DDP 5.1 or just two channels stereo but Auto is working. Hope that helps. I signed up just to reply.
I am having the same problem with the LG OLED 65C8. How did you get the Sound Out setting to be Dolby Digital? All I see is AUTO or PCM under the following menu:

Settings | Sound | Sound Out | Optical | Digital Sound Out


Okay, after some further testing it seems that the reboot didn't fix it. The PS3 HDMI cable was able to get the Auto mode to work immediately! Without even rebooting. Two other HDMI cables that I had didn't work. One from Amazon Essentials both modes failed (auto + PCM) and the other one from Mono Cable only PCM worked. My best guess is something to do with the HDMI version on the cable.
Time to buy new HDMI cables as all the ones I have are 3-5 years old.