Answered

"Sorry that device is offline"


Userlevel 3
Badge
When I instruct my Sonos One "Alexa, play", I get the message "resuming on spotify. sorry that device is offline". If I instruct "Alexa, play on ", it initiates playback.

Advice?
icon

Best answer by Edward R 18 June 2019, 17:47

Hello, we have noticed this topic getting a lot of attention as of late. If you are having issues with Alexa on Sonos, please check this link.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

When I instruct my Sonos One "Alexa, play", I get the message "resuming on spotify. sorry that device is offline". If I instruct "Alexa, play on ", it initiates playback.

Advice?


I'm having the same issue. I notice it when the music is inactive for 10-15 minutes. If I just tell my Sonos/Alexa to play vs pause vs play vs pause within minutes, it DOES work. Only when inactive does it not work. Very frustrating.
I have the same issues. Works if I deliver the command within a short period after pausing it, but does not 15 minutes or more later. :@:?
Userlevel 3
Badge
Hello there, Akiryzon. Thanks for posting. Seems like there may be a miscommunication between Alexa and Sonos. When you go into alexa.amazon.com and Settings, then Devices, do you see your Sonos One as Online or Offline? Do you see your Sonos One on this list at all?

I see all devices as online (verified as I simultaneously made the request to my sonos one)
Userlevel 3
Badge

I'm having the same issue. I notice it when the music is inactive for 10-15 minutes. If I just tell my Sonos/Alexa to play vs pause vs play vs pause within minutes, it DOES work. Only when inactive does it not work. Very frustrating.


To confirm, same behavior at my end. Works if I pause / play within a small time window but after a gap in time, playing causes the aforementioned error.
Ok fixed it - there seems to be a conflict with my Echo Dot device, I deregistered it and now the Beam can activate Spotify
Userlevel 7
Badge +19
Hello there, Akiryzon. Thanks for posting. Seems like there may be a miscommunication between Alexa and Sonos. When you go into alexa.amazon.com and Settings, then Devices, do you see your Sonos One as Online or Offline? Do you see your Sonos One on this list at all?
Same issue. When I say “Alexa, play music” it says “resuming on spotify. sorry that device is offline”. It used to work fine. Any solutions?
Okay started working fine again today. Didn’t change anything. The problem occurred after someone turned the speaker off at the wall. 24 hours later now working fine again.
Why can’t I see responses?
I have the same problem with Spotify being offline. Any idea how to fix this issue?
Userlevel 7
Badge +20
I have the same problem with Spotify being offline. Any idea how to fix this issue?

Where are you seeing that Spotify is off-line? Do you have a Premium Account?
If I ask “Alexa play Spotify” or “Alexa play Spotify on Lounge” the room where the speaker is. Yep I have a Premium Spotify account
This is on Sonos Beam btw
Userlevel 7
Badge +20
Hello, we have noticed this topic getting a lot of attention as of late. If you are having issues with Alexa on Sonos, please check this link.