Sonos will randomly stop/pause song from Spotify



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

44 replies

Userlevel 7
Badge +20
Hi Guys, Diagnostic nr is 651555569.
I've been falling back to old bluetooth speakers just to play a full album through my Spotify account. I'm constantly getting the message that it's 'unable to play 'song name' - the connection to Spotify was lost' after it's played 1 or 2 songs without issue. Trying to play the playlist through the Sonos app or using Spotify app doesn't make a difference. Ive recently tried changing the wifi channel on the Sonos to channel 11. There are no devices that emit radio signals or such next to or in between the Sonos and my wifi-router. I hope this diagnostic report will give you some handle on this issue and help solve this problem as it's increasingly frustrating


Have you tried powering down these devices for 10 secs and then powering back on - let each complete it's boot cycle before moving to the next device:

- Router
- Any other Network switches
- Any wired Sonos device
- All other Sonos devices
Hi Guys, Diagnostic nr is 651555569.
I've been falling back to old bluetooth speakers just to play a full album through my Spotify account. I'm constantly getting the message that it's 'unable to play 'song name' - the connection to Spotify was lost' after it's played 1 or 2 songs without issue. Trying to play the playlist through the Sonos app or using Spotify app doesn't make a difference. Ive recently tried changing the wifi channel on the Sonos to channel 11. There are no devices that emit radio signals or such next to or in between the Sonos and my wifi-router. I hope this diagnostic report will give you some handle on this issue and help solve this problem as it's increasingly frustrating


Have you tried powering down these devices for 10 secs and then powering back on - let each complete it's boot cycle before moving to the next device:

- Router
- Any other Network switches
- Any wired Sonos device
- All other Sonos devices



Hi UKMedia, many times including this last change to channel 11. No change unfortunatly
Userlevel 7
Badge +20
Can you try this:

http://192.168.0.201:1400/support/review

Please change the IP address to match any of your Sonos players. Please select Network Matrix and let us know if it highlights any issues.
Can you try this:

http://192.168.0.201:1400/support/review

Please change the IP address to match any of your Sonos players. Please select Network Matrix and let us know if it highlights any issues.


There is no Network Matrix to select on this endpoint...?
Userlevel 7
Badge +20
How many players do you have?
How many players do you have? Just one Play:5
Userlevel 7
Badge +20
Thanks, that's why you don't have the Network Matrix 🙂 In that case can you open the Ethernet Ports Statistics and check the error rate?
Thanks, that's why you don't have the Network Matrix 🙂 In that case can you open the Ethernet Ports Statistics and check the error rate?
Sure, but I don't understand the relevance of the ethernet port? It's all zero's as its connected thru wifi only.
Userlevel 7
Badge +20
My Wi-Fi players have an error rate and Bytes transmitted/ received. Perhaps we need to wait for the Sonos staff to investigate your diagnostic!
My Wi-Fi players have an error rate and Bytes transmitted/ received. Perhaps we need to wait for the Sonos staff to investigate your diagnostic!
Oh, Haha, I was under the impression you where... Anyway, thanx for your help
Userlevel 7
Badge +20
My Wi-Fi players have an error rate and Bytes transmitted/ received. Perhaps we need to wait for the Sonos staff to investigate your diagnostic!
Oh, Haha, I was under the impression you where... Anyway, thanx for your help


Nope just another customer... 🙂
Userlevel 7
Badge +19
Hi there, derekvonk. Thanks for posting and or the diagnostic report. It seems the Living Room Play:5 is having a hard time maintaining its connection to the network. What is the make and model of the router you are working with? Do you have any wireless extenders or access points?

Thanks in advance.
Hi there, derekvonk. Thanks for posting and or the diagnostic report. It seems the Living Room Play:5 is having a hard time maintaining its connection to the network. What is the make and model of the router you are working with? Do you have any wireless extenders or access points?

Thanks in advance.

Hi Keith, thanx for your response. I have an Asus RT-AC58U router. No extenders or access points. Relatively small house in which I use it so distance should definitely not be an issue.
Userlevel 7
Badge +19
Understood. At this point, I'd recommend giving our support technicians a call to troubleshoot this in real time. They are able to set up a remote session and get a closer look at how data is being routed to Sonos. Thanks!
Same problem w/ only Spotify and Sonos. Meanwhile, the only reason we got Spotify premium was to be able to play on Sonos. IHeart and Pandora play find. No “unable to play ____, lost connection with Spotify.” Please advise.
Userlevel 7
Badge +20
Same problem w/ only Spotify and Sonos. Meanwhile, the only reason we got Spotify premium was to be able to play on Sonos. IHeart and Pandora play find. No “unable to play ____, lost connection with Spotify.” Please advise.

Hi leone7,

Please send in a diagnostic report after you get this error. If you reply here with the confirmation number I can check it out.
Userlevel 1
Badge
Same here. Spotify stops a few minutes into a song with unable to play. Bug report 38687604

I'm really bitter right now.
Userlevel 7
Badge +20
Same here. Spotify stops a few minutes into a song with unable to play. Bug report 38687604

I'm really bitter right now.


Thanks for the report. I see that your speakers are being hit with wireless interference from nearby networks. Your area looks to be a bit crowded with signals that are fairly strong. It may help to change your router's wireless channel to 6, which looks to be less crowded than your current channel.
Userlevel 1
Badge
Hi Jeff. Thank you for your quick response. You are correct my area is very crowded, but Netflix 4K usually works.

I changed my router from automatic wireless channel to channel 1 and seems to work. I will follow your advice and change it to 6. I reserved the 2.4GHz band for Sonos.