Sonos will not add my shared Music folder on my Win7 PC


Userlevel 2
I have been using my Sonos system for some time now. All of a sudden, it stopped being able to access my Music Library on my Win7-64-bit PC. So I open the Sonos app on the PC, click on Music and screen reads "You haven't added any music folders to your Sonos system yet." So, I click on menu Manage>Music Library Settings. On the dialog screen, I click on the Add button and get another dialog box. I then click on the button for "In another location on my computer ... ." and click Next. Then yet another dialog box appears and I click the Browse button to select "C:\$Music" which is my library I have built for both Sonos and as a backup for my Android cell phone. (And it's the same one I used successfully with Sonos before.) Then I get yet another box and swirling for 10-20 seconds, then the less-than-helpful error message "Sonos was unable to add the music folder. Reason: Unable to add the the shared folder '\\pcname\$Music' to your Music Library (900)." What do I do now??

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

Userlevel 6
Badge +3
Hello NashvilleKit, This could be link to a couple of things. - Could you remove the dollar ($) in front of your music folder and try to add it again. - Is there any changes made with your computer? ( Firewalls, Firewalls updates, ect ) This could have changed the share preferences. Here is a FAQ showing you how to configure your firewall https://sonos.custhelp.com/app/answers/detail/a_id/692/kw/692/session/L3RpbWUvMTM0MTkwMDQxMC9zaWQvdWFBdjdNKms%3D Could you submit a diagnostic of your Sonos system, and reply to this thread with the confirmation number. Here is a FAQ showing you how to Submit system diagnostic Keep me posted on your progress. Thank you Max
Userlevel 2
Diagnosis is number 3029181. As to the other issues, '$' is a perfectly legitimate filename character. I used it with Sonos for several weeks before this all stopped working. I am going to do as you suggest but I want you to know this will be a bit painful for me -- it screws up my cell phone library, every music player I use and my secondary computer which syncs with it. As to my firewall, it hasn't been touched and, besides, why would that affect not being able to find a folder within the same system I'm using, i.e. Sonos app is on my C drive and so is my $Music folder. I await your analysis ...
Userlevel 2
Well, now. It's FIXED and it's VERY mysterious. Here's what I did: As I said, it would be painful to change the folder name for my music (and I didn't mention my automatic backup routines & my backup cloud service). So, I got a little smart and simply created a new folder called "Music for Sonos." Then I copied a handful of artist's folders into it from my $Music. That worked; Sonos accepted it. So -aha- I added another folder, with a few artists in it, called "$Music for Sonos" and -hey- that worked also!! Then, I decided to try one more time to add "$Music" (the original one that wasn't being accepted) and it was accepted this time. Maybe your diagnosis routine reset it or something. I haven't a clue! I'm happy but with a bit of a hangover, so to speak.
Userlevel 6
Badge +3
Well, now. It's FIXED and it's VERY mysterious. Here's what I did: As I said, it would be painful to change the folder name for my music (and I didn't mention my automatic backup routines & my backup cloud service). So, I got a little smart and simply created a new folder called "Music for Sonos." Then I copied a handful of artist's folders into it from my $Music. That worked; Sonos accepted it. So -aha- I added another folder, with a few artists in it, called "$Music for Sonos" and -hey- that worked also!! Then, I decided to try one more time to add "$Music" (the original one that wasn't being accepted) and it was accepted this time. Maybe your diagnosis routine reset it or something. I haven't a clue! I'm happy but with a bit of a hangover, so to speak.
Hello NashvilleKit, Coming back to you, to know if all is still working well? Thank you Max
Userlevel 2
Hi, sorry to jump into this conversation, but I have exactly the same problem. Up until a week or so ago, everything was fine. Since then I have been unable to - play music in the library - browse the library - update the index I have gone through the firewall instructions at https://sonos.custhelp.com/app/answers/detail/a_id/1225, and everything seems fine. I have checked http://192.168.1.73:1400/status/tracks_summary, and it kept showing the same numbers even when I added or removed tracks to the music library on my PC. Eventually I removed the library from the Sonos controller, and now the "use" counts show 0. I have tried to add my music library back (\\mypc\music), but I get the not very helpful message "sonos was unable to add the music folder. Reason: Unable to add the shared folder \\mypc\music to your Music Library (1002). I have also tried to set up a new, small folder with just a handful of tracks and share that. Same result. Any idea about what I should do?
Userlevel 6
Badge +3
Hello User821061, At this point I would ask you to check in your Network and Sharing Center. If you are in a public network or Home network. - If you are in a public network change it to Home network and the problem should be solved if your firewall is configured right. - Also power cycle your network and all the Sonos devices. Could you please perform the following steps: 1. Remove the power from your Modem, Then from the Router (Unless you got a Modem/Router Combo) 2. Remove the power from you Wired Sonos component 3. Remove the power from the rest of the your Sonos devices. Once this is done, please reconnect the power on all devices in the same order, first Modem, the Router, then the Rest of Sonos. If you are still experiencing the same issue you may have to exchange the Ethernet cable from the Sonos device that is wired to your router and submit a diagnostic of your Sonos. Here is a FAQ showing you how to Submit system diagnostic Keep me posted on your progress, if you are still experiencing this problem I will open a case ticket number and have a Sonos agent to reach out to you. Thank you Max
Userlevel 2
Hi Max, Thank you for the quick answer (I'm User821061, but I managed to change my name to something more meaningful). When I first started the Sonos controller on my PC today, it wanted me to check for updated software. I did that, and it downloaded and installed version 4.1. I have checked and confirm that I'm in a Home network. I have power cycled the network in the sequence you outlined. Although I have three Player-5 units, I only switched one one to make things simpler. I then tried to add a small folder (d:\musictest) to the library, but got the dreaded "sonos was unable to add the music folder. Reason: Unable to add the shared folder \\mypc\\musictest to your Music Library (1002). " message. I then changed the wiring so my Bridge is wired to the router and my PC is wired to the Bridge. I have a normal internet connection (as evidenced by being able to write here), so I assume that means both cables are okay. I again tried to add d:\musictest to the library and got the same "sonos was unable to add the music folder. Reason: Unable to add the shared folder \\mypc\musictest to your Music Library (1002) " message. When I then went to submit diagnostics, that failed with a "Your diagnostics information could not be sent at this time. Click 'try again' to send the information again, or click 'Done' and try again later'". I then switched my firewall (McAfee Total Protection) off and hit "try again", but I'm still unable to submit diagnostics. I will try again in a little while, but I fear this points to some sort of network issue on my end. Having said that, I'm quite confused since the diagnostics also failed when the firewall was switched off. Kind regards, Tomas
Userlevel 2
Update: I removed McAfee completely from my PC and tried to add \\mypc\musictest to the library. I now got a different error message. This one said "Sonos was unable to add the music folder. Reason: Access to the shared folder \\mypc\musictest is denied". I tried turning Windows Firewall off and adding the directory, but that gave the same error message. However, with Windows firewall switched on, at least I managed to submit my diagnostics. The confirmation number is 3034932. Kind regards, Tomas
Userlevel 2
Hi again, I managed to get the the Sonos to play, although I don't quite understand it. The latest error message was "access to ... denied", so I set up a new user account on my pc, logged in under the new account, started sonos, added \\mypc\music to the library (no problem, much to my surprise) and had access to all my music. I then logged back in under my normal user account and looked at the library. It contained \\mypc\music. When I tried to play anything I got an error message, but after updating the index (which took zero seconds), everything seems to work. I don't understand what the root cause was, and don't understand why populating the library under another user account but playing it under my normal account works. I'm worried about it breaking again. But for the time being, it seems to work. So I'm cautiously positive. Kind regards, Tomas
Badge
It sounds like a file share permissions problem OR a an NTFS file permissions problem. Note that both the share and the files/folders can have separate permissions.
Userlevel 2
Hi Mikhail, it does indeed. I tried to first amend the permissions, and when that didn't work, I unshared and re-shared, again ensuring the permissions were set on both share and directory structure. It worries me that I can't figure out what caused the thing and what actually fixed it - I fear that sooner or later it'll go wrong again. But I guess I should just be happy at the moment.
My Sonos won't connect to My Music folder, says it can't connect with my PC...Always did before. I do not know what is going on. How do I disconnect my firewall, if that is my problem, without disconnecting for everything else?
I had the same problem but I tried this. The problem started (I think) when I made my Win7 password enabled. Sonos then wouldn't allow me to add the folders thru my "Computer". Instead, I tried to add "Network/Drive/Music Folder". It popped up a window with login name and password... and Wallah!
Userlevel 1
Badge
I was experience the similar problems described in this thread. After my initial setup, I ran just fine. I have been tweaking/updating my itunes library on my base computer, so I periodically removed/added the music folder.  (Side question - is this the proper way to re-sync sonos with a modified music library?).

Now, all of a sudden, I was getting this error - "unable to add the music folder / Reason: Access to <my computer/music> is denied. Huh?!? No system changes on my side, other than adding music to itunes (ripping cds). (Note - I'm still able to connect and play various services like Pandora.)

I fiddled a bit, and did this, which seems to have worked:

* Opened windows explorer.
* Navigated to Music folder.
* Selected Properties on the iTunes Music folder.
* Clicked the "Share" tab.
* Clicked Apply.

Back in Sonos Settings:
* Clicked Add.
* And now, it is working. It is in process of Updating Music Library. And I have just played some music from the library as the final test.

If anyone can explain why this issue occurred in the first place, I would appreciate knowing. Any other general advice is also appreciated. I really liked the fact that the sonos was relatively effortless to set up and get running, but this issue was a bit disconcerting.
I got the same problem.  Sonos pretends not to find my computer.  I tried all the above mentioned suggestions without any success.  My system did work allright until recently.
I got the same problem.  Sonos pretends not to find my computer.  I tried all the above mentioned suggestions without any success.  My system did work allright until recently.
No reaction till now.  I'm getting quite desperate.  If I connect the bridge to my laptop I have to reconnect each time the subs.  Then it is possible to get access to my music library but not to the internet radio.  If I connect the bridge to my router i listenany radio station I want but I can't access my music library.  I get each time the message that Sonos can't find the library.
I got the same problem.  
To make things even crazier: if I connect one player (Sonos3) to my laptop, I get access to my music library and both players work also the one that is not connected to my laptop.  If I disconnect the player I return to the situation of before: no access to the library.  But I don't think that this is what they mean by wireless...
Userlevel 1
Badge
I got the same problem.  
Apologies, but I don't think I can help. Your issue sounds like it has taken some turns and is different from mine. I wonder if it would be worth disconnecting everything and starting from scratch with the simplest scenario and try to get things working one thing at a time? Sounds like sonos support might be your best path. 
hi, tried to add music from my computer but it said that sonos was unable to add the music folder Reason: the computer 'user" refused to let sonos connect to it.....

Please help me?
Badge
Sounds like a permissions issue to me.

In file and folder explorer, right click on the folder and go to Properties then Security and post back here the list of the 'Group or User names' that are listed.

Should be easy for me to tell what the issue is.
I got the same problem.  Sonos pretends not to find my computer.  I tried all the above mentioned suggestions without any success.  My system did work allright until recently.
Even in technology miracles happen.  yesterday I had troubles with my internetconnexion and they came to repair it.  At the same time my problem with Sonos has disappeared.  So I don't understand it and nobody does but it works.  So problem solved. I'm happy.
I have the same problem as mentioned in #0. My system worked perfectly until an update a couple of years ago. Since that I have had problems periodically. Even though I can connect to the pc from my laptop with no problems. So far I've find out that I can make it play if I simply restart the computer. Then it suddently will play, but if I want to play music again the next day, the problem is there again SOMETIMES .
I'm using Sonos controller on laptop and android devices and the problem is the same nomatter what i'm using so i'm sure the problem is between my ZP90 and the win7 pc with the music on.

Any thouhts?? I'm f.... tired of my Sonos so far.

Thanks
As a new User of two months, I've had difficulty with adding Music Folders, had unreliable connections where sometimes music plays, at other times not.
Similar to all the issues here. I thought I would try to list what worked for me as it may help/guide others having trouble:

1. Share the folders you want to access in Windows - Mine are C:/User Name/Music and C:\Users\User Name\Documents\Audible\Programs\Downloads. Remember to share the 'lowest' folder in the hierarchy.
2. Apply the Server Stack fix (error 900) I used 24 Decimal
3. Configure your firewall as Sonos recommends - I have Kaspersky Internet Security and there are TWO elements to configure: Packet Rules and Application Rules. Use Local Port addressing and local/subnet network. I found you need to configure both for access. this initially caught me out.
4. Reboot
5. Add the folders using the second option when adding through Manage Music Library- "In another location on my computer...."

I hope this helps anyone who is having the same issues as myself.
Apologies to the Mod. if I've placed this post in the wrong section.

System: Windows 10
Sonos Controller 5.4
PlayBar, 2xPlay 1s', Sub, Boost.
2.4GHz Network.
Same issue here... windows 7 box on company network... intermittent connection to my music share... today it was working fine and literally stopped working in the middle of playing my queue. All of a sudden it (sonos) popped up (disrupting what I was doing) spewed a bunch of message on screen about songs not found and then quit playing. Now it wont even replay the song it had just finished playing.

This behavior has been going on for some time. Shares coming and going. Clearly things are configured correctly as it was just working... so today after reading this thread I decided to give up and uninstalled your software. The support here is very weak. Lack of links and decent instructions is just sad.

Boo Sonos!
You've never asked a single question and yet the support here is very weak? Ok, no problem, don't let the door hit you on the way out.

By the way, you do know it's not the laptop that requires the connection to the share don't you? It's the hardware (which is presumably still sitting there after you've uninstalled the software) and yet you haven't even mentioned any Sonos hardware, odd that...