sonos was unable to add the music folder reason access to the shared folder "xxx" is denied

  • 16 February 2014
  • 41 replies
  • 10325 views

Had my system up and running for a few weeks. Today it couldn't access my music folder giving the error: Sonos was unable to add the music folder. Reason access to the shared folder //xxxx is denied. Please help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Unistalled Sonos and reinstalled, new problem, followed online suggestion (https://sonos.custhelp.com/app/answers/detail/a_id/266).

Was able to add library and play music. Went out to the store and tried to use Sonos now I could not get tracks to play getting "access denied".
Badge +3
There are a few different possible causes of the access denied message.  Make sure that the computer is powered on, connected to your home network, and that any security software (such as a firewall) is configured to allow Sonos through.  The most common reason for file sharing errors is an overzealous firewall.  

Access denied can also be returned due to a misconfiguration in the shared folder.  Try removing the share (from the Music Library Settings menu and then re-adding it.
Hi there,
I got the same problem. Everything was working correctly until I remove my shared folder and put another one. This is impossible for me to add any folder in the sonos library. I have uninstalled and re-installed Sonos. I have unplugged all network devices (sonos, adsl router, wifi router), disabled windows firewall, disabled my anti-virus, but still have the error message "sonos was unable to add the music folder. Reason: access to the shared folder xxxx denied".
What didn't I do and I should try to solve it?
Thanks a lot for your help.
I'm having the exact same issue as User123323
Me too!
this error is occurring with me and I do not have any firewall enabled.  Started when I downloaded the new Sonos update.  Please provide fix.
this error is occurring with me and I do not have any firewall enabled.  
This is crap software in my opinion and should be more trouble free than this...Very disappointed in this company...an update should not disrupt my settings...no support
I don't think I will ever download an update again as this system has caused me more headaches with this "network sharing" thing...too much money for so little support
Fix it please if you care about your company????
I found that if I add the local music folder as a Windows shared network folder and then add it as a network folder (as opposed to the default music folder location or a local folder in a different location), mapping as such, it recognizes the folder and the music files are accessible.
So,
Make sure the folder is shared.
map it as a network drive.
add it as a network location.

good luck
I've been having a similar problem and tried every suggestion I found online until deciding to call Sonos support.  It turns out my issue was with the Date and Time settings.  These settings have to be the same in both the Sonos app and the Systems Preferences in order for the Music Library to be added.

From Sonos app:
Preferences -> Date and Time
make sure "Set date and time from the Internet" is pressed
you can even select which Time Zone you are in from the above drop menu.

Go to your computer's Systems Preferences
Click Date & Time
Select Time Zone tab
Select "Set time zone automatically using current location"

The Sonos help guy said that they've been having this issue pop up lately and it seems to affect the PlayBar most often.  For multiple devices accessing the sound system, all the time zones have to be in sync.

Hope this helps anyone else who has been having the same problem.
After sending diag report to Sonos (and receiving help from Support) it was determined that my computer's node type was set to Peer to Peer. I made changes to the registry following tech's instructions:

1- Press 'Windows' button > Run... > In the box type regedit.
2- Navigate the tree to: HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/NetBT/Parameters
3- Right mouse click and select New > DWORD Value
4- Name it 'NodeType' (without the quotes)
5- Right mouse click on it and select Modify
6- Set Value Data to '8' (no quotes)
7- Leave Base alone. 'Hexadecimal' should be selected
8- Press 'ok'
9- Close regedit and reboot.

and the Controller was able to find my computer. I did have an access denied issue which I resolved by finding the network share path (navigate to \\"computer name"\My Music, right click and select properties, then click on the "sharing" tab) and selecting the "On a networked device such as..." and using the share path.

Good luck-
I've been having a similar problem and tried every suggestion I found online until deciding to call Sonos support.  It turns out my issue was with the Date and Time settings.  These settings have to be the same in both the Sonos app and the Systems Preferences in order for the Music Library to be added.

From Sonos app:
Preferences -> Date and Time
make sure "Set date and time from the Internet" is pressed
you can even select which Time Zone you are in from the above drop menu.

Go to your computer's Systems Preferences
Click Date & Time
Select Time Zone tab
Select "Set time zone automatically using current location"

The Sonos help guy said that they've been having this issue pop up lately and it seems to affect the PlayBar most often.  For multiple devices accessing the sound system, all the time zones have to be in sync.

Hope this helps anyone else who has been having the same problem.

Was really frustrated.... and this was what fixed my problem. Seriously: a time zone problem prevented me from accessing iTunes? Seems like Sonos should be a little more user friendly.
I'm having the same problem. Am on a Mac. 
I think the software update broke the link to my music library somehow. 
Time zones match.
I am also having this same issue.
same issue. Can access music library on Mac from that Mac only; all other devices - iPad and iPhone get "access denied" message. time zone is synced to Internet.
There are a few different possible causes of the access denied message.  Make sure that the computer is powered on, connected to your home network, and that any security software (such as a firewall) is configured to allow Sonos through.  The most common reason for file sharing errors is an overzealous firewall.  

Access denied can also be returned due to a misconfiguration in the shared folder.  Try removing the share (from the Music Library Settings menu and then re-adding it.

John, it looks like the recent software update broke the link to shared music on macs. Can you guys do something about this?
I updated sonos and after that i removed a shared library and added another and i got also the acces denied, but i'm sure the user & password is correct (mapping in windows & osx works !!) and no firewalls are enabled, i think there is a real bad problem with sonos 😞
There are a few different possible causes of the access denied message.  Make sure that the computer is powered on, connected to your home network, and that any security software (such as a firewall) is configured to allow Sonos through.  The most common reason for file sharing errors is an overzealous firewall.  

Access denied can also be returned due to a misconfiguration in the shared folder.  Try removing the share (from the Music Library Settings menu and then re-adding it.

I also think there is something wrong with it, i have the same problem after update, i can't add any shared library from my NAS any more (acces denied)...
I have had the same issue. Spent an hour on the phone with a Sonos tech support who accessed my machine and told me it was a Microsoft problem.I then spent an hour and a half on a tech support chat with microsoft yesterday, still no joy, and given the number of Mac users on this forum the common denominator isn't Microsoft...Have been off Sonos for over a week now.
I just deleted the connection in Sonos to the shared music library on the primary Mac where it resides, and then through the Sonos app reinstituted the shared library. Now everything works including control from iPhone.
it's horrible! I have incredible Christmas music on my playlist tat I cannot hear in my home since we replaced all of our speakers with sonos. I'm stuck with generic Pandora crap - it feels like a freakin' shopping mall in here despite the fortune I've paid on my good music library! SONOS FIX THIS NOW!!!!
Will, How did you delete the connection in Sonos to the shared music library. And how did you reinstitute the shared library. Could you please walk through the steps? 
On a Mac, open Sonos app, top Nav go to "Manage," then "Music Library Settings," then in window highlight music folders in Sonos and delete with "-" button in +/- buttons. Then hit "+" button and direct Sonos app to where you store your music and it will create new linkage to your music library.
Thank you so much Will, It worked!