Answered

Sonos was unable to add the music folder

  • 27 May 2022
  • 4 replies
  • 50 views

  • Contributor I
  • 2 replies

I recently upgraded to a Mac Studio and now I am unable to connect to my music folders which are stored on an external drive. My old iMac didn't have any issues. The location of the folders was not showing up in Sonos correctly so I deleted them from the Sonos Music Library Settings and tried to add them back. When I try to add them, I get the following message:

In the ‘Get info’ panel for the folder, Ive changed the permissions for SonosDMS from Custom to Read & Write, but when click ‘Next’ after entering the folder path, it gets changed back to Custom.

I currently have the firewall turned off.

Sonos is working as expected using streaming services.

Apple Studio M1 Max

MacOS 12.3.1

Sonos Controller 14.6

icon

Best answer by GuitarSuperstar 27 May 2022, 20:08

View original

4 replies

Under System Preferences, try toggling the File Sharing option. If it’s checked, uncheck it. If it’s unchecked, check it. Also try adding the folder where your music files are stored in the “Shared Folders” window.

Tried toggling File Sharing off and on, no success. The music folder on the external drive was already in the  folder section. I tried adding another folder and got the same error. I think I’m going to try spending some quality time with Sonos support. Since I wasn’t getting the error on my older iMac, I suspect this may be a case where Sonos dent play well with the new M1 chip. I guess the worst case. would be to use the older iMac for Sonos.

Perhaps see if this link re folder sharing might assist to sort the issue:

https://support.apple.com/en-gb/guide/mac-help/mh17131/mac

The article is a good check for what has already been done. Thanks.

Perhaps see if this link re folder sharing might assist to sort the issue:

https://support.apple.com/en-gb/guide/mac-help/mh17131/mac

Userlevel 7

Under System Preferences, try toggling the File Sharing option. If it’s checked, uncheck it. If it’s unchecked, check it. Also try adding the folder where your music files are stored in the “Shared Folders” window.

Reply