Answered

Sonos/virgin in modem mode/ google nest issues


Hi, I’ve seen various posts on this but I’m still struggling to keep all sonos’s connected, they regularly stop playing and drop off the app.

Google router is ethernet connected to a virgin hub that’s been put into modem mode. Also ethernet connected via a switch is a play:1.

I then have 3 more play:1s and a Play:5 that continually play up. I’ve tried switching the channels and have tried removing the wireless network from the app, nothing seems to fix it. They barely work for 5 minutes before one of them dropping off.

 

Any thoughts? John B - you seem yo be  bit of a pro - interested if you can help.

 

icon

Best answer by Corry P 6 May 2021, 09:51

Hi @chiprocket 

Welcome to the Sonos Community!

The first thing I recommend you do is make sure your wired Play:1 is 1m (or thereabouts) away from your main Google node - if it isn’t then the two are likely interfering with each other.

We have a reducing wireless interference help page with more information.

If you want to invoke anyone’s attention, please use an @ in front of their username as I have above - they will get a notification via email.

 

View original

8 replies

Userlevel 6
Badge +16

Hi @chiprocket 

Welcome to the Sonos Community!

The first thing I recommend you do is make sure your wired Play:1 is 1m (or thereabouts) away from your main Google node - if it isn’t then the two are likely interfering with each other.

We have a reducing wireless interference help page with more information.

If you want to invoke anyone’s attention, please use an @ in front of their username as I have above - they will get a notification via email.

 

Userlevel 7
Badge +21

Amazing - a UK user NOT affected by the BT Smart Hub router issue. Makes a nice change.

Userlevel 6
Badge +16

One more thought, @chiprocket - I assumed you have the Play:1 wired to a switch connected to the Google node. If this is not that case and you have it wired to the VM router/modem, please connect the switch to the first Google node instead. Thanks.

Hi Corry, thanks - yes switch is into Google node.

 

My play:1 is next to the router so I’ll try moving it away on a longer Ethernet and see if it improves the issue.

@John B  - If you have any wisdom to impart on this thread it would be much appreciated.

You seem to have things set up as they should be. Please check in About My System that all your speakers have WM:0 next to them, not WM:1.

(If you have removed Wi-Fi credentials then I think they must all be WM:0, but let's check anyway. )

Thanks @John B 

 

Interestingly I’m sure yesterday only the Sonia connected via Ethernet had WM0, the others were showing WM1 and I suspected this wasn’t right.

 

I connected to a different Sonos via Ethernet following Corrys advice and all sonos’s are now showing as WM:0. I’ll give it a proper test today and report back.


Really useful to get some fresh insight as I’ve been going around in circles on this for weeks - thank you 

 

 


 

 

OK - see how it goes.  When you had the original Sonos device wired, you didn’t ‘disable WiFi ‘ in the settings for that device, did you?  It is a misleadingly labelled setting, as it actually disables all wireless capability on the device.  Make sure every device, whether wired or wireless, has this setting set to ‘Enable WiFi’. (Again, evidence suggests it's OK, but worth a check.)

Reply