Sonos upgrade now music dropping when iPhone sleeps

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

125 replies

This issue has affected both my wife's and my iPhone/Sonos setup for a year or so on various phones and through multiple IOS and Sonos upgrades. I have searched for hours online and on this community and I see that this bug has existed for quite a long time without resolution. I've tried virtually everything that has been recommended and nothing resolves the issue. The only successful work-around is to set the auto-lock to 'never', which is a risky tactic if you don't remember to change it back. Sonos Staff: Have you been able to recreate this? Can you confirm that this is a Sonos bug? If not, where can we go next. If so, what is being done and how can we help you resolve this quickly? If there is already a fix and I've missed it please post it all over the place so people can find it.
Version 9.1 did not help. Sonos on my iPhoneX continues to stop playing when it locks. When can this get addressed? Very frustrating and I am not willing to keep my phone unlocked all the time. And btw... your troubleshooting guide is pretty unhelpful. Help please
This happens to me as well. Completely beats the point of controlling sonos from iphone. Is there a fix and if so when?
Userlevel 3
Badge +1
Issue still exist since the last update. Wondering if support really tried to fix it. After letting Jeff S. know about it and submitting my diagnostic number, Jeff S replied "At this point it would be best to have our phone team take a look at this issue live. Please give us a call, you can find our phone number and hours here."

Apparently, Sonos has given up on the issue, leaving us all to live with the problem. I have recently given more 1 star ratings on the products Sonos has swindled me into buying. More 1 star ratings coming up!
Userlevel 7
Badge +20
Hi Jeff, your update has not fixed the issue. I have this issue on all Iphone devices in the house, Iphone X, Iphone 8, Iphone 7. As soon I lock the screen of the phone, songs start to skip randomly. I cant get even one song to play fully. If I leave the phone unlocked there is no issue playing the songs.

You can also try disabling AirPlay on non-Sonos devices on your network. It may be best to have our phone team take a look at this live so they can investigate further. Please give us a call, you can find our phone number here.
Updated to version 9.1 software, problem still extremely annoyingly persistent for me too. iPhone 7s, iOS 12.0. Troubleshooting guide is just a waste of time. After my screen goes to sleep it takes just under 2 minutes before the Sonos app stops any song that is playing through the Sonos app from my phone music only. Not an issue with radio, Pandora etc., just with music on my phone.

I did recognize that when I unlock my phone it is no longer connected my WiFi and it quickly reconnects. Once it reconnects to WiFi the Sonos app does its black startup screen thing again and then starts playing some other song at random mid-song.

I think the issue has something to do with the iPhone dropping the WiFi connection (a newer iPhone save on battery feature?). The same thing happens regardless of whether the phone is on power save mode or not. My money is on this issue all being caused by an Apple update (iOS 11?). Changing auto-lock time out is not an option for me as I only have a company phone and the longest my auto-lock can go is 5 minutes, rendering my Sonos merely useless.....

Perhaps there is a way to force our iPhones to maintain the WiFi connection regardless of whether or not the screen is on...? If however this is the problem, and if the (WiFi) issue cannot be fixed, then I will not being buying any more Sonos equipment in the future.

PLEASE LOOK INTO THIS JEFF S/SONOS TECH! If I can help in any other way or provide additional information to help get this issue resolved please email me.
Userlevel 2
Can somebody please fix this? Jeff - what is the issue here? Why is there no resolve?
Thank you John Here for what seems to be a solution. I have an iPhone 6s latest IOS, and Sonos Play 1 and Play 3's. I was having drop out soon after iPhone locked. Changing the time to Auto-lock to "never" was the only way to have content from iPhone play reliably. But John's suggestion of forgetting my wifi network and then re-joining appears to have fixed the problem. No more drop-outs after iPhone locks. At least so far . . . .
Userlevel 2
Thanks Adrian. I’ve tried that but it still doesn’t work. And unfortunately I cant use the “never lock” feature because my coprporate email has disabled that feature.

Would be super cool if somebody from Sonos would, I don’t know, get back to me with a fix...
Userlevel 7
Badge +20
Hi folks,

There is an issue with playback from the storage on iOS devices when there are non-Sonos AirPlay devices on the network and the iOS device goes into auto lock. We're investigating this issue. For now, you can get streaming from your iOS device's storage going again by disabling AirPlay on any non-Sonos devices on your network or by disabling auto lock in the iOS device's display & brightness settings menu.

Another option is to sync your iOS device's storage with the iTunes on a computer, then set up a music share.
I lied - the iPhone network setting (forget and re-join), which appeared to fix dropping music when iPhone locks was temporary. Back to dropping today. Come on Sonos. Step it up!!!
Userlevel 7
Badge +20
I lied - the iPhone network setting (forget and re-join), which appeared to fix dropping music when iPhone locks was temporary. Back to dropping today. Come on Sonos. Step it up!!!

My guess is that's how long it took for your non-Sonos AirPlay devices to re-engage with the phone. If you don't want to disable AirPlay on non-Sonos devices, or disable the auto lock on your controller, try uninstalling the Sonos app from your iOS device entirely, then download it new from the app store, let me know if that helps.
Deleting the app and re-installing extended the time before dropping. But still happening. I frequently use Airplay to connect iPhone to AppleTV. Disabling Airplay to enable Sonos to work - no thanks. Having to set iPhone to auto lock never, probably means I will seldom use Sonos.
I’m on night 3 of using my newly bought Sonos speakers.

As you can see from my screen name, the #1 reason I bought a Sonos was to play 1 song on loop non-stop, uninterrupted for 10 hours straight. I use my Sonos as a white noise machine for my 2 year old. The song is called brown noise loop. I use the Sonos speakers secondarily to play music.

Unfortunately- it keeps stopping. I disabled airplay, and it seems to work but I have found that I have to do this a few times for it to stick.

When is this bug going to be resolved because there is nothing more stressful than sitting down watching a tv show and then to be woken up by a crying baby because the Sonos app stopped looping.

I would think this bug would be labeled as escalated and critical and would have gone through QA and would be resolved by now. The fact that it hasn’t seems very concerning.

My ignorant Advice: it seems that the main issue is airplay. If this is the issue, there should be an option on Sonos to disable Airplay with the use of the Sonos controller or something.
I’ve been lurking on this thread for the last few weeks. I started encountering this same problem when I try to play downloaded podcasts and music (MP3s, .M4A files purchased from the iTunes Store) from my iPhone (items “On this iPhone” on my Sonos app) to my multiple Sonos Play:1s a few weeks ago. This problem occurs to this very day; all my Sonos apps and controllers and firmware are up-to-date. I’m using an iPhone X running iOS 12/12.0.1 and an iPhone 5 running iOS 10.3.3.

I did not have this problem until a few weeks ago. Things were working smoothly and as expected prior to a few weeks ago; maybe it started happening more like a month ago vs. a few weeks ago, but this is a fairly recent development for sure. I attribute it to a Sonos Play:1 firmware upgrade, because I have two iPhones running different versions of iOS and the problem occurs irrespective on iOS version.

I have tried all the various recommendations on this thread and other various related threads on this topic, such as powering down my Wi-Fi router and cable modem and turning them back on, powering down all my Play:1s and turning them back on, deleting my Sonos app and reinstalling the Sonos app, forgetting my Wi-Fi network on my iPhones, turning off AirPlay on Apple TVs, Macs, etc. etc. The only solution that works is to set “Auto-Lock” to “Never” on the iPhones and to leave the iPhone screen on (don’t lock the screen and have the iPhone screen go dark). I agree with everyone that this solution is not viable, because keeping the iPhone screen on will eat up the phone’s battery life. Yes, we can keep the iPhone plugged into a charger while the iPhone screen is on, but that is cumbersome and not a good user experience.

Having a song or podcast stop and then skip to the next song/podcast is frustrating. I hope you’ll help us solve this problem soon, Sonos technical support. Thank you.
Since July 2018, I have been in touch with SONOS all the way up to the CEO's office. There is not a fix for this issue, and IMO there will not be one. Other than confirming that there is an issue and presenting a completely ludicrous solution to deactivate AirPlay on my other devices, SONOS has gone silent on this issue.

Your brand share will continue to decline until you get off your high horse and remember your commitment to your product and customers are a reflection of your future. That is what set you apart, what happened?

SONOS, if I am offbase show us a real timeline and project plan already in play to correct this PARTICULAR issue.

As for my SONOS, I have found a new use for it and decided to admit I got ripped off.

LESSON: You don't always get what you pay for.
Or, they may be at the mercy of Apple making changes behind the scenes, and not caring how it affects other parties.
If that is the case, then why not officially communicate this fact and let us know with certainty if they plan on a fix? All I want is closure so I can buy something compatible or wait for my SONOS to work again.
Let's say, as a mental exercise, that 40% of your total installed users rely on Company A for a device both to control your product, and some subset stream music stored on your product. Are you interested in blaming that company for doing something that made your system work for these customers? Or do you continue to try to maintain a civil relationship for the future, and work on getting this company 10 times your size to recognize that they've significantly impacted your ability to operate, and that they should probably make some accommodation for you?

The scary thing in this whole scenario is that Company A may not care, since it doesn't affect their revenue at all. So company B is busy trying to figure out some other way to get around the restrictions that Company A has imposed on all customers, without pissing them off, in the hopes that they will come around and make some change that will benefit you.

Note: This is entirely speculation on my part. It fits what the circumstance, but that doesn't mean it's true. You have to figure out whether it works for your mindset or not.

It's just hard for me to believe that Sonos, who depends on our revenue in order to stay in existence, doesn't care, and did this on purpose, and won't do everything possible to fix it. But if they have to wait on Company A to make a change, and Company A doesn't give a hoot one way or the other, you and I are stuck in the middle.
Userlevel 2
Jeff - anything productive to add here? Would be nice to have a company take on the past few comments that have been made that isn’t the standard, “we’re aware of the problem and our tech team is working on it...”

This is a pretty crummy issue and frankly I kinda think you guys are on the clock to come up with a solution.
Or, they’re beholden for a change from Apple in order to fix this issue, and are waiting for them to add something different to iOS ....
Userlevel 2
Airgetlam - best of luck to them in the public markets if their business model can be disrupted with an Apple iOS update. Hope the Board knows how to handle the folks at Starboard...

Jeff - any update? Thoughts? Comments other than the generic statement?
I think you’ve solved it. Had music streaming from iPad all day. This coincided with the latest iOS and Sonos updates. Either way - appears to be fixed (touch wood). Thanks
Joining the throngs of hacked off Sonos/Apple users skipping to next tracks when mid-track. I have powered off Apple TV, no fix. Indexed the music library, no fix (was autoscheduled anyway), forgot wifi and reconnected , no fix. Turned off autolock - fixed, but that is unacceptable to me. No issue on Macbook, but ipad and iphone both skip tracks randomly, and evermore rapidly repeating skips, after about 12 minutes of clean playing. Ridiculous that Sonos cannot identify fix. All software bang up to date, no fix.
I think you’ve solved it. Had music streaming from iPad all day. This coincided with the latest iOS and Sonos updates. Either way - appears to be fixed (touch wood). Thanks - Cancel that - back to the same problem. Must have been an aberration. C’mon SONOS - time to sit down with the folks at Apple a get this problem sorted!