Question

Sonos Update Won't Work on Windows 10

  • 7 December 2017
  • 3 replies
  • 1631 views

When I try to start Sonos on my Windows 10 PC, I get prompted to update Sonos. When I try to update I get a popup box with the message "the sonos controller failed to install. The rest of the update cannot continue." I tried to manually download an install the update. The install shield process works and then quits with the message, "the wizard was interrupted before the Sonos controller could be completely installed." I tried to uninstall Sonos , but the uninstall wouldn't work.

I am currently running Sonos Controller for PC version 7.3 build 36441272. I have one Play 1, two Play 5s, and a Connect. I am currently running Window 10 Home Version 1703 Build 15063.726 on a Lenovo C460.

Please let me know how to resolve this problem and get my sonos investment working again.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Hi Jeffrey , you are not alone . I updated to Windows 10 and SONOS can no longer access my music files. I was using Windows 8 before with no problems. I have wasted lots of time with Microsoft trying to sort , my next move is to contact SONOS engineers. Or I am going to remove Windows 10 from my Computer. Hope you get some luck
Userlevel 7
Badge +21
Two different issues here...

oliverclarke, your issue is likely related to some changes Microsoft made to sharing files on your network in the latest "Creators Update" to Windows 10. If you have Build 1709 (go to Start > Settings > System > About to see), I made a couple of posts in another topic about this - here and here - the first of those two posts is likely the fix, but if you still have issues, the second gives something else to check.

Jeffrey, I'm not sure what would be causing the Sonos controller installer to fail when you try to install the desktop controller software. I know in the couple of weeks there was a new update that was made available. The latest controller software should be 8.2.2 and can be downloaded from here. See if the new version might work for you.
Mike V,

Thank you so much for your reply and a Happy New Year to you. I have done as you suggest and it worked. I am up and running again and enjoying my music library again. All the best . Oliver