Answered

Sonos update

  • 30 January 2021
  • 3 replies
  • 75 views

Hi I changed WiFi router and since then have not been able to use my Sonos one. I ended up resetting to factory settings and it found it, chimed that it was connected. However, it says it needs an update but every time comes back with error 30 or error 1013. 
 

I have deleted apps restarted everything and managed to connect my sonos play but the one just shows the error. 
 

Any suggestions 

 

thanks Laura 

icon

Best answer by Corry P 2 March 2021, 12:50

Hi @Laurawak 

Welcome to the Sonos Community!

Are you still having this problem?

If so, please try the following:

  1. Switch your WiFi router off for at least 30 seconds. Switch back on and wait about 5 minutes for internet access to return
  2. Switch off all Sonos devices apart from the Sonos One that doesn’t update (you can do this while waiting for WiFi to return)
  3. Connect the Sonos One to the router with an ethernet cable (to a port labelled LAN, Ethernet or Network)
  4. Try the update again. If it fails, try doing the update from another controller, if you have one. If you have another ethernet cable, please try that too.

If the above steps don’t help, please get in touch with our technical support team for a resolution.

View original

3 replies

The error messages and possible solutions are explained here: https://support.sonos.com/s/article/2382?language=en_US

Try to wire the One directly to the router to make the update.

Yes sorry tried all those first  and also plugged in with Ethernet cable. Any other ideas ?

Userlevel 5
Badge +15

Hi @Laurawak 

Welcome to the Sonos Community!

Are you still having this problem?

If so, please try the following:

  1. Switch your WiFi router off for at least 30 seconds. Switch back on and wait about 5 minutes for internet access to return
  2. Switch off all Sonos devices apart from the Sonos One that doesn’t update (you can do this while waiting for WiFi to return)
  3. Connect the Sonos One to the router with an ethernet cable (to a port labelled LAN, Ethernet or Network)
  4. Try the update again. If it fails, try doing the update from another controller, if you have one. If you have another ethernet cable, please try that too.

If the above steps don’t help, please get in touch with our technical support team for a resolution.

Reply