Question

Sonos system loses connection with Android.

  • 11 November 2020
  • 7 replies
  • 75 views

I know there are a lot of questions regarding the system losing connection, but I believe I have a different situation than those I’ve seen described.  My system often can’t be found on my Android phone.  Sometimes I can play an album, and while it continues to play (off of my NAS) I am unable to get back in to change albums - the system is not found.  However, my wife, who uses an iphone, remains connected without issue.  We can be in the same room and I get a message that the Sonos system can’t be found and from her phone everything works perfectly.


7 replies

Userlevel 6
Badge +15

Hi @Sling, Thank you for reaching out and welcome to the community. Sorry to hear about this issue on your Android controller on the Sonos App. I’ll ask some questions to check on this issue.

  • When did the issue start happening on the Android controller?
  • Are there any changes made before the issue occurred?
  • Have you tried to uninstall and reinstall the Sonos app on the Android device to check for any improvements?
  • Do you use Wifi extenders or Mesh networks that could be causing the issue if you are not connected on the right network?
  • What is the exact error message that you’re getting on the Android controller?

Answers to these questions will help us check what could be causing this issue. 

Let us know what you have in mind with the advice above.
The Sonos community is always here to help.

the problem has been going on for the past 3 months.  I have Uninstalled the app and reinstalled with the same issue.  I'll try to capture the exact error code but it generally states that a Sonos system could not be found and to reset/install.  I did that tice before realizing that my wife's iPhone remained connected with no issue

Userlevel 6
Badge +15

Hi @Sling, thanks for the update, sorry to hear that the issue persist. So we can check the status of your Android controller and the Sonos system, I’ll ask you to submit a diagnostic report to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue.  

Let us know what you have in mind with the advice above.
The Sonos community is always here to help.

672900354 is confirmation number

Userlevel 6
Badge +15

Hi @Sling, thanks for the update and for sending a diagnostic report of your Sonos system. Upon checking the diagnostic information. It shows that your devices are offline. Kindly do a sequential reboot starting from your network connections, unplug it from the power source for 1-2 minutes. And once it’s back online, Do the same thing on your Sonos speakers. Let me know how it goes. 

The Sonos community is always here to help.

I have EXACTLY the same issue. I rebooted and reinstalled a device today because of this issue, but it has just happened again. I started one of my Play:1 devices playing music through my android device. The Sonos App then lost it completely. My wife's iPhone was able to connect and turn the music off. The device is connected because I can view it through my Omada controller. 

Userlevel 6
Badge +15

Hi @Yarp, Thank you for reaching out, and welcome to the community. Sorry to hear that you have the same issue with your Sonos system. So that we can check the current status of your Sonos system and the device controllers being used on Sonos, I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. 

Let us know what you have in mind with the advice above.

The Sonos community is always here to help.

Reply