Answered

Sonos stops playing

  • 6 November 2021
  • 9 replies
  • 71 views

Userlevel 1
Badge +1

Hi Sonos. My music stops playing. I think it might be tied to the speaker in my kitchen.  Can you see anything out of the ordinary?

Diagnostic confirmation number:

1168524756

icon

Best answer by Peheje 6 November 2021, 21:53

View original

9 replies

Userlevel 1
Badge +1

Just tried to factory reset it. Now it won't connect

Userlevel 1
Badge +1

Could connect it with wire. Testing it around the house. 

Is the speaker now working on your routers wireless signal, or is it only working when wired?

Was the speaker wired to begin with, before you decided  to factory reset it? Only you may just need to be careful at this point, particularly if you have other Sonos devices, as you ’might’ end up splitting your system into two separate Sonos Households. I would not factory reset any other devices.

Userlevel 1
Badge +1

On router wifi now and to begin with.

 

Never had issues factory resetting, do it often when l take a speaker with me. Never heard of issues Sonos products suddenly splitting into two households, where are you getting that from?

 

So I did some wifi analyzing. And it's very poor in the kitchen. Could Sonos Boost help? Trying to find new spots for the router but it's difficult. 

Factory resetting a speaker is usually only ever a ‘last resort’ option only - sometimes users can accidentally end up creating a new Sonos HH and if they then wire it to their router (switching their entire system over to SonosNet), they can sometimes overwrite their original Household settings - so just didn’t want to see you do that. However it sounds as though all is good. 

To get a better signal to your Kitchen speaker, may depend on the location of your Sonos devices and the distance between them, as in SonosNet wired mode they behave like a mesh system as shown in this support document…

https://support.sonos.com/s/article/3235

However you could also try a different ‘non-overlapping’ ‘fixed’ 2.4Ghz wifi router channel (either 1, 6 or 11) and set the channel width to 20MHz to see if that may improve things for you.

This may also help perhaps, rather than keep factory resetting a Sonos speaker when you take it with you, maybe consider using the ‘Manage Networks’ option in the Sonos App to switch your network connections instead.

If you have a ‘Roam’ or ‘Move’ (portable) speaker, you can add upto 16 separate WiFi networks to those devices too. See attached ‘example’ screenshot.

HTH

Userlevel 1
Badge +1

Hi Ken, thanks for this tip, didn’t know will try it.:sunglasses:

 

I ended up buying a Boost to run on wired setup for a while. Let’s see if it works.

I was however surprised to see the Roam didn’t support connecting to the Boost! However Roam does seem to run on the “5ghz” WIFI. So I could disable my 2.4ghz wifi router antennae entirely to at least do my part on lessening the interference.

Whilst the 5Ghz WiFi band is faster, it has a shorter reach than the 2.4Ghz band and its signal does not penetrate through walls as good as the 2.4Ghz band. You will likely find you are better off moving your Roam onto the 2.4Ghz band instead, on either fixed channel 1, 6 or 11 and limit the channel-width to 20MHz. I think that will fix your issue and leave the 5Ghz band for use with your static network devices (particularly non-Sonos devices).

Userlevel 1
Badge +1

Thanks for mentioning that Ken. I will consider it if 5ghz ever gives me issues on the roam.

Reply