Question

Sonos Speakers Randomly Turn On & Often At High Volume

  • 21 January 2017
  • 37 replies
  • 10762 views

Badge
I have 3 Sonos Play: 3's and 5 Sonos Play: 1's in my system. My wife and I each control the system with our iPhones.

In the last two weeks the system randomly turns itself on during the day - and often at a pretty loud volume.

We have no alarms set (never used that feature) and we deleted the Sonos app from our other devices (couple of iPads.). At first it seemed to do it at random times in the late afternoon while I was home, but before my wife got home. Then it started doing it in the evening when she was hear - but always while someone was home.

Last night we came home and could literally hear the sound from the speakers while walking up to the front door. For the first time the system turned itself on while we we away from the house and was extremely loud. So loud in fact we found out dog hiding in a room without speakers.

This is totally unacceptable. The wife is ready to put the system on Craigslist and sell it.

At first I thought it might be because my neighbor has a Sonos controlled system (just the app and amp, not the speakers) and his wifi signal is strong in our house and we have connected to his Songs system when we've been at his house in the past. However, I'd call him when our's would turn on randomly and his was never on at that time.

Does anyone have any troubleshooting ideas? Thanks!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

You're looking at the wrong player. The one in the screenshot is slaved to the group, which is why it's 'playing' all the time. (It could also be, say, the right one of a pair.)

You need to identify the group coordinator. This is the first room in the list at the top of the Now Playing display, or the top one in the group list in the Rooms drop-down menu. If that room is in fact a stereo pair, choose the left unit.
Badge
You're looking at the wrong player. The one in the screenshot is slaved to the group, which is why it's 'playing' all the time. (It could also be, say, the right one of a pair.)

You need to identify the group coordinator. This is the first room in the list at the top of the Now Playing display, or the top one in the group list in the Rooms drop-down menu. If that room is in fact a stereo pair, choose the left unit.


Thanks for that clarification. Unfortunately, I ungrouped everything after posting that. I have now created a new group, based on the Play: 3 in my office and grouped all other speakers in the house to it. I'm going to play it for awhile. Then shut it off and wait for it to come back on by itself. Then, take a screen shot based off the Office Speaker...... would that be the correct way to trouble shoot this for now? Thanks again, we really appreciate it.
Unfortunately, I ungrouped everything after posting that.
Well it would be possible to go through all the players and find out which was the coordinator at the time, but it takes some tedious arithmetic to compute the clock time from the numeric timestamps.

I have now created a new group, based on the Play: 3 in my office and grouped all other speakers in the house to it. I'm going to play it for awhile. Then shut it off and wait for it to come back on by itself. Then, take a screen shot based off the Office Speaker...... would that be the correct way to trouble shoot this for now?

Good. That's laid the trap. Let's see if anything takes the bait.
Thanks @ratty for taking this forward. I was going to take a look at effects of grouping on my own logs but no longer needed.
Userlevel 7
Badge +26
Great troubleshooting everyone. Just a note for more details, on the diagnostic it looked like Master Bedroom (L) was the group coordinator at the time. Also, the command to start playing had most recently come from an iPhone on the system.
Assuming he has iPhones of his own the OP will need the IP. He can then check to make sure it's one of his.
Userlevel 7
Badge +26
Assuming he has iPhones of his own the OP will need the IP. He can then check to make sure it's one of his.

Good call, the diagnostic is a little old now, so IPs could have changed, but at the time it was 192.168.1.24.
Userlevel 1
Badge +1
Hey very urgent! One of my speakers has just started randomly playing on its own. Happened 3 times today. Please help I don't want to have to turn then off!

Diagnostic: 8125711
Userlevel 1
Badge +1
One of my speakers has just started randomly playing on its own. Could be since I connected to Alexa. Happened 3 times today. Please help I don't want to have to turn then off!

Diagnostic: 8125711
Userlevel 7
Badge +26
Hi Scott, looks like the most recent messages sent to play music on your players came from a Spotify App on an Android device. When you're using Spotify Connect on Sonos, the mobile device connects on the local network, but after that it remains connected when you go off the local network. So if you were linked and playing music, then left home and tried listening to Spotify, it might still be connected to your Sonos, and start playing there.

To disconnect a mobile device that is using Spotify Connect linked to Sonos, just make sure to use the Sonos App to play something on those players. Anything else then Spotify will disconnect the Spotify app from its control. If you forgot to disconnect them before you leave the house, just make sure when you open the Spotify app that you pick the phone's speakers before playing.

Sometimes your phone might automatically connect to a Bluetooth device and hit play, which could theoretically restart your music playback on Sonos if not disconnected. This is rare to happen, but I've seen it a time or two.
Badge
Had the same problem with my PLAY:5 2nd gen. It would randomly start playing music at an extremely loud volume. It got so bad that it would start playing while I was stopping it. I ended up resetting the player and reconfiguring from scratch.The culprit appears to be Spotify, in particular, Spotify Connect. If you use the Spotify app to control your player directly and then switch to Sonos to change the music source, Spotify doesn't always close the connection.

Right now, I'm testing with a limited number of music services configured to see if the problem still persists. Does this happen with Pandora as well since it can control the player directly?