Answered

Sonos shuts off Logitech Harmony Activity

  • 11 November 2019
  • 11 replies
  • 385 views

Badge

Hi All,

 

I’ve had an issue that has been bothering me for a bit.  Here’s the scenario:

 

If I’m listening to music or a podcast on my Sonos Beam without utilizing my Harmony remote and then select the “Watch TV” activity on my Harmony remote to start watching TV the remote will turn on the TV and pull up the right settings but as soon as TV audio starts coming through the Beam it triggers a signal that shuts down the Watch TV activity and then I have to restart everything.

 

It seems that if my Beam is receiving another audio source other than from the TV and then I press Watch TV this always happens.

 

The TV Autoplay settings is turned on so I’m not sure what’s causing this issue.

 

Any advice would be much appreciated.

icon

Best answer by Jrgatfh 12 November 2019, 18:08

I figured out the issue.  The Anynet+ (HDMI-CEC) settings on my TV were incorrect - “Auto Turn Off” was set to on.  Everytime I switched from an Airplay/Sonos App Audio signal to a TV-based audio signal the TV would send an “Auto Turn Off” signal out and the whole system would shut down until I restarted it.

 

So happy to have figured this out.  Just wanted to report back in case someone else had the same issue.

View original

11 replies

Userlevel 7

Hi

The Beam if connected via HDMI-ARC is designed to turn TV on/off, mute, switch input via voice command. Any remote programed to the Beam only controls volume which is the case whether the Beam is connected via HDMI-ARC or via the optical adapter.

There is a possibility that the Harmony is sending a signal that is scrambling commands causing the problem you are having. In any event the problem lies with the programming of the Harmony remote and not the Beam. 

I suggest three courses of action.

  1. If your TV has an IR remote use it to control the Beam to see if the problem remains, if not you have your answer regarding the Harmony remote as the culprit.
  2. Consult Logitech to see if they have any programming solutions that may be of use.
  3. Maybe someone in the forum may have a programming solution.

Cheers!

Badge

I figured out the issue.  The Anynet+ (HDMI-CEC) settings on my TV were incorrect - “Auto Turn Off” was set to on.  Everytime I switched from an Airplay/Sonos App Audio signal to a TV-based audio signal the TV would send an “Auto Turn Off” signal out and the whole system would shut down until I restarted it.

 

So happy to have figured this out.  Just wanted to report back in case someone else had the same issue.

Badge +1

Thank you!

I had worked out this issue happened when the Beam switched to TV audio but couldn't figure out why. I had disabled Anynet+ and it was still happening, but going back and turning Anynet+ back on and turning off “Auto Turn Off” fixed it. Looks like that setting is still active even with Anynet+ turned off, at least on my 10 year old TV!

This only started happening in the last couple of months, must have been an update from either Sonos or Harmony, I guess.

Glad to have it sorted out now, anyway!

Badge +1

Ok I spoke too soon, it just happened again. :rolling_eyes:

Badge

Ok I spoke too soon, it just happened again. :rolling_eyes:

I spoke too soon as well. This happens in my bedroom using a Beam and my living room using a Playbar.

 

It’s EXTREMELY frustrating. If I toggle TV Autoplay on and off in the Sonos app it appears to make the problem go away temporarily but then it just comes back.

 

Sonos, please help!  This seems like a fairly common issue amounts users.

@Jrgatfh , Thank you for bringing your question to the Sonos Community. If I understand, the steps you have tested have been with the TV settings and Sonos settings for autoplay. Please confirm for me that your Beam’s autoplay feature is turned off. When you are playing music or a podcast to your Beam and autoplay for Sonos is still active the new signal generated from your Harmony remote to your TV is sending a new signal/command from your TV to your Beam and trigger the change.

Please confirm the setting in your Beam is off by tapping settings » system » Beam Room Name » Home Theater/Cinema there you can then toggle TV autoplay off. Please follow up with these testing steps along an updated diagnostic report and report number here.

Badge

@Jrgatfh , Thank you for bringing your question to the Sonos Community. If I understand, the steps you have tested have been with the TV settings and Sonos settings for autoplay. Please confirm for me that your Beam’s autoplay feature is turned off. When you are playing music or a podcast to your Beam and autoplay for Sonos is still active the new signal generated from your Harmony remote to your TV is sending a new signal/command from your TV to your Beam and trigger the change.

Please confirm the setting in your Beam is off by tapping settings » system » Beam Room Name » Home Theater/Cinema there you can then toggle TV autoplay off. Please follow up with these testing steps along an updated diagnostic report and report number here.

Hi John,

 

The diagnostic report # is 2067864700.

 

The problem is that if I’m listening to music/radio via Airplay OR the Sonos App and then turn on the TV the Sonos system won’t switch to the TV audio source, it will just turn my whole system off and then I have to restart the TV activity.  If i toggle the TV Autoplay setting in the Sonos app it will temporarily relieve the issue but then it just comes back

 

I’m pretty tech savvy and have troubleshooted this multiple ways and best I can tell it’s an issue with the Sonos system.  It’s been extremely frustrating and from my research it seems like its a pretty prevalent issue - it never used to do this.

 

Please help us resolve this issue.  I’ve spent thousands of dollars on my Sonos system, and I’m sure like many forum members, this issue has been extremely frustrating.  

 

Please let me know what you find.  Thanks.

 

 

@Jrgatfh Thank you for the follow up information and the diagnostic report. When you toggle off autoplay in Sonos that is the result you will get. It will no longer get that random signal sent from your Logitech remote to the TV to the Beam that stops your music playing. You should not have to restart your whole system off/on, but just go in the Sonos app and under browse and tap TV as the source to the Beam. If this is shutting down your Home AV system, this could be something with that configuration.  You mention that when you have made the autoplay change in Sonos it works fine. It should not come back unless the autoplay feature in the Beam is being toggled back on.

The most significant thing I can see in your diagnostic report is you could very much benefit from a full network and Sonos equipment re-boot. After confirming the full re-booting and testing with the Sonos Beam auto play off you can follow up here with the testing result or reach out to our phone agents using this link

Same issue here with a beam, harmony, and lg tv. If my most recent played source on my beam is Not TV, then when I turn on the TV via harmony activity it all turns on for a moment then turns back off. I have to restart the activity in harmony to get things working. Very consistent results, very easy to reproduce, always happens if trying to watch TV and the most recent Sonos source was not tv. If the most recent Sonos source Was tv then everything works fine

Badge

Same issue here with a beam, harmony, and lg tv. If my most recent played source on my beam is Not TV, then when I turn on the TV via harmony activity it all turns on for a moment then turns back off. I have to restart the activity in harmony to get things working. Very consistent results, very easy to reproduce, always happens if trying to watch TV and the most recent Sonos source was not tv. If the most recent Sonos source Was tv then everything works fine

Thanks for reporting @lazyboy0172 

This is clearly a common issue from what I’ve read and it never used to happen. 
 

@John G Ive reboot everything and still have the same issue. Is there anyone Sonos can take a deeper look into this?

@Jrgatfh Thank you for the follow up information. I would ask that you call in for live phone assistance and start a case to track the troubleshooting steps with our agents.

Reply